You are not logged in.

#1 2019-05-04 10:41:40

dewid2
Member
Registered: 2019-05-04
Posts: 7

sway with firefox-nightly and other applications

Hi, i currently run sway on wayland only, and i've heard that firefox-nightly supports it. However, when i type the command in my terminal emulator, no reaction occurs, not even error messages, and the program must be stopped with ctrl-c.
The same thing happens to every application i try to open, except for one which is alacritty itself and works as intended. Tried so far: gnome-terminal, epiphany, nautilus, gedit. Since all have native wayland support, i think i just oversee some basics that seem to be obvious to everyone else succesfully launching those apps. Would be grateful if you could point me the right way.

Offline

#2 2019-05-04 13:36:01

Mortimer Houghton
Member
Registered: 2014-09-28
Posts: 58

Re: sway with firefox-nightly and other applications

You don't need Firefox nightly.  The stable version 66.0.3 works fine with wayland.  What you do need to do is set the environmental variable for it to work with wayand.  You can either launch firefox with "env GDK_BACKEND=wayland firefox" or else define the variable for your system.  For that, you will want to use "MOZ_ENABLE_WAYLAND=1".

For the rest, apps like epiphany really did launch without issue.  The only thing I can think of is to add "xwayland disable" to your config to make sure it isn't used.  Try "env GDK_BACKEND=wayland" when launching them as well and see if they work then.  However, the sway wiki doesn't believe you should do this globally.  You can read more about it here (Running programs natively under Wayland)

Last edited by Mortimer Houghton (2019-05-04 13:45:26)

Offline

#3 2019-05-04 16:13:01

dewid2
Member
Registered: 2019-05-04
Posts: 7

Re: sway with firefox-nightly and other applications

This solved my problem, thank you very much! Indeed during my websearches ive also come across GDK_BACKEND=wayland, but that alone did not do the trick. For me, your second suggestion, to write "xwayland disable" in the sway config file, was also mandatory.
making it globally worked, but as you pointed out this is not ideal, and neither do i want to type "env GDK_BACKEND=wayland" before 80% of my desktop applications. I could think of replacing the standard commands with shellscripts that invoke the enviroment before, but that also seems bad. Do you see a better solution?

Offline

#4 2019-05-05 23:10:54

Mortimer Houghton
Member
Registered: 2014-09-28
Posts: 58

Re: sway with firefox-nightly and other applications

Don't use "env GDK_BACKEND=wayland" for everything, use MOZ_ENABLE_WAYLAND=1 in your environment settings instead.  This is Firefox specific and won't have you spamming GDK_BACKEND to everything.

Look at the link on setting environmental variables I posted above for what files to edit.

Offline

#5 2019-06-28 16:11:57

theduke
Member
Registered: 2013-03-09
Posts: 1

Re: sway with firefox-nightly and other applications

Thank you Mortimer, I was running into the same issue.

This thread saved me quite a bit of time.

Offline

Board footer

Powered by FluxBB