You are not logged in.

#1 2019-05-18 07:10:49

wire7ack
Member
Registered: 2019-05-18
Posts: 35

[SOLVED] oh-my-zsh auto-complete bug

Hello everybody. I work under i3, termite, oh-my-zsh shell and noticed such a "bug" with oh-my-zsh when the auto-completion menu appears:

Screenshot

my zshrc: https://pastebin.com/F65HRX6Z

How to fix it? Thank you (:

[EDIT] Add in your locale.conf:

LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8

Last edited by wire7ack (2020-05-30 14:48:37)

Offline

#2 2019-05-18 07:14:50

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,738
Website

Re: [SOLVED] oh-my-zsh auto-complete bug

Read the Code of Conduct and only post thumbnails http://wiki.archlinux.org/index.php/Cod … s_and_code

And if you want help with OMZ, which is a clusterfsck every which way, post your configs. All 19,000 lines of them...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2019-05-18 07:23:18

wire7ack
Member
Registered: 2019-05-18
Posts: 35

Re: [SOLVED] oh-my-zsh auto-complete bug

jasonwryan wrote:

Read the Code of Conduct and only post thumbnails http://wiki.archlinux.org/index.php/Cod … s_and_code

And if you want help with OMZ, which is a clusterfsck every which way, post your configs. All 19,000 lines of them...

Ok

Offline

#4 2019-05-18 07:24:54

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,738
Website

Re: [SOLVED] oh-my-zsh auto-complete bug

So, what exactly is the bug?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2019-05-18 07:34:35

wire7ack
Member
Registered: 2019-05-18
Posts: 35

Re: [SOLVED] oh-my-zsh auto-complete bug

Thanks, I solved the problem by adding in zshrc:

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

Last edited by wire7ack (2019-05-18 07:41:04)

Offline

#6 2019-05-18 07:52:55

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,738
Website

Re: [SOLVED] oh-my-zsh auto-complete bug

Or, you know, you could actually fix your locale...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#7 2019-05-18 09:07:14

wire7ack
Member
Registered: 2019-05-18
Posts: 35

Re: [SOLVED] oh-my-zsh auto-complete bug

jasonwryan wrote:

Or, you know, you could actually fix your locale...

Thanks for the advice

Offline

Board footer

Powered by FluxBB