You are not logged in.

#1 2019-05-18 13:20:28

hwvgyngd
Member
Registered: 2019-05-18
Posts: 2

[SOLVED] Steam hangs on startup

On launching steam it produces the following output and then hangs:

$ steam
Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
/home/user/.local/share/Steam/steam.sh: line 828: /home/user/.local/share/Steam/ubuntu12_32/steam-runtime/run.sh: No such file or directory
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Installing breakpad exception handler for appid(steam)/version(0)

The only advice I've found from searching is to install correct graphics drivers, ie:
https://wiki.archlinux.org/index.php/St … dler...%22
https://bbs.archlinux.org/viewtopic.php?id=177245

However as far as I'm aware mine are correct.

$ lspci | egrep "VGA|3D"
01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
$ pacman -Q | grep mesa
lib32-mesa 19.0.1-1
mesa 19.0.4-1
mesa-demos 8.4.0-1
$ pacman -Q | grep nvidia
lib32-nvidia-cg-toolkit 3.1-7
lib32-nvidia-utils 418.56-1
nvidia 430.14-1
nvidia-cg-toolkit 3.1-5
nvidia-settings 430.14-1
nvidia-utils 430.14-1

When I last launched steam a few months ago it worked. I haven't changed anything since then beyond installing updates.

pls halp

Last edited by hwvgyngd (2019-05-18 13:44:06)

Offline

#2 2019-05-18 13:26:49

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,134
Website

Re: [SOLVED] Steam hangs on startup

Your lib32-nvidia-utils is outdated.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2019-05-18 13:45:13

hwvgyngd
Member
Registered: 2019-05-18
Posts: 2

Re: [SOLVED] Steam hangs on startup

Switching to a mirror with a more up to date version of lib32-nvidia-utils and updating fixed the issue.
Thanks!

Offline

Board footer

Powered by FluxBB