You are not logged in.

#1 2019-05-26 18:21:03

lula
Member
Registered: 2009-07-16
Posts: 63

[Solved] Error in libmatroska.so.6

After todays update from libmatroska (1.5.0-1 -> 1.5.1-1) mkv-tools (mkvmerge, mkvtoolnix-gui) doesn't work anymore. Errors:

mkvmerge: symbol lookup error: /usr/lib/libmatroska.so.6: undefined symbol: _ZTIN7libebml10EbmlMasterE
mkvtoolnix-gui: symbol lookup error: /usr/lib/libmatroska.so.6: undefined symbol: _ZTIN7libebml10EbmlMasterE

Anyone else experiencing this?

Last edited by lula (2019-05-27 20:24:38)

Offline

#2 2019-05-26 18:43:59

lula
Member
Registered: 2009-07-16
Posts: 63

Re: [Solved] Error in libmatroska.so.6

Update: downgrading libmatroska und libebml makes them work again

[root@lifebook:~]# LC_ALL=C pacman -U /var/cache/pacman/pkg/libmatroska-1.5.0-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/libebml-1.3.7-1-x86_64.pkg.tar.xz 
loading packages...
warning: downgrading package libmatroska (1.5.1-1 => 1.5.0-1)
warning: downgrading package libebml (1.3.8-1 => 1.3.7-1)

Last edited by lula (2019-05-26 19:05:40)

Offline

#3 2019-05-27 10:57:29

arkxoz
Member
Registered: 2019-05-25
Posts: 4

Re: [Solved] Error in libmatroska.so.6

I too have this problem, can't downgrade since i didn't have it installed before

Offline

#4 2019-05-27 11:06:30

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,489

Re: [Solved] Error in libmatroska.so.6


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#5 2019-05-27 12:54:02

DoXer
Member
Registered: 2017-08-27
Posts: 26

Re: [Solved] Error in libmatroska.so.6

pacman -U https://archive.archlinux.org/packages/l/libmatroska/libmatroska-1.5.0-1-x86_64.pkg.tar.xz
pacman -U https://archive.archlinux.org/packages/l/libebml/libebml-1.3.7-1-x86_64.pkg.tar.xz

--
Regards
Michael

Offline

#6 2019-05-27 16:24:47

DoXer
Member
Registered: 2017-08-27
Posts: 26

Re: [Solved] Error in libmatroska.so.6

Updated LIBs available. No downgrade required.


--
Regards
Michael

Offline

#7 2019-05-27 20:13:45

lula
Member
Registered: 2009-07-16
Posts: 63

Re: [Solved] Error in libmatroska.so.6

Yes, todays update of libebml (1.3.9-1) and libmatroska (1.5.2-1) make them work again

Offline

Board footer

Powered by FluxBB