You are not logged in.

#1 2019-06-04 10:02:58

sunjob
Member
Registered: 2019-06-04
Posts: 5

Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

good day

subj: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc
repo.nasutek.com

1. add repo

/etc/pacman.d/mirrorlist # default

/etc/pacman.conf

#
# Trintiy/TDE
#
[trinity]
# SigLevel = Never
# SigLevel = Optional TrustAll
# SigLevel = PackageReguire
SigLevel = TrustAll
Server   = http://repo.nasutek.com/arch/contrib/trinity/x86_64/

2. update

pacman -Syu

3. install Trinity/TDE

pacman -S tde-tdebase
or
pacman -S tde-meta

many message aka
- can't packages
- can't full install, but part...

warning: cannot resolve "lcms", a depend of ...
warning: cannot resolve "tde-libkdcraw"
...
lcms, tde-libkdcraw, tde-tdeadmin

but packages exist on repo

tde-libkdcraw-14.0.4-1-x86_64.pkg.tar.xz
tde-tdeadmin-14.0.4-1-x86_64.pkg.tar.xz

lcms is not important, but these tde-package's are present on repo ...???

agree, set-install "what is"

4. run TDE, trouble

run/login throu TDM - error as "up-s-s-s ...":

could not start tdestartupconfig. Check your installation

remember my TDE & Slackware - The "content" of the error does not reflect the true state of affairs

-->

take the tail and launch the serpent forcibly:

$ /opt/trinity/bin/starttde
->
blah-blah-blah ... error while loading share libraries: libidn.so.11: cannot open ... blah-blah-bla
...
libidn.so.11
libmysqlclient.so.18
(many-many ... screan is scroll )

...

ArchLinux - install "as is" on VirtualBox, perhaps something is not well tuned, but what already works should be enough ...: o)

"error and text-error" on manual write to forum

i'm not user arch-linux

question:
- ideas, links, comments, what we think about this ...
- what do we have here with addictions? (during installation and after installation)
- m.b exist tru repo with normal working TDE-14.0.6?

thanks

Last edited by sunjob (2019-06-04 14:30:49)

Offline

#2 2019-06-04 16:10:11

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,536
Website

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

sunjob wrote:

i'm not user arch-linux

What does that mean?


Moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2019-06-04 18:42:45

sunjob
Member
Registered: 2019-06-04
Posts: 5

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

>> i'm not user arch-linux
What does that mean?

I am not an ArchLinux user, my native distributor is Slackware (ArchLinux is interested)

installation / problems of TDE (repo.nasutek.com) - already solved, now I am clarifying details, I will make a report later

...

and repeat my question:
may be exist tru repo with normal working TDE-14.0.6?

thank

Last edited by sunjob (2019-06-04 18:44:35)

Offline

#4 2019-06-04 18:55:00

metak
Member
Registered: 2009-09-27
Posts: 189

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

That repo is seriously outdated (latest binaries built on 12-Jun-2018) it's not a surprise it doesn't work.

Offline

#5 2019-06-05 05:54:11

sunjob
Member
Registered: 2019-06-04
Posts: 5

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

...  it's not a surprise it doesn't work. ...

->

installation / problems of TDE (repo.nasutek.com) - already solved

install and work...

...

1. add repo

/etc/pacman.d/mirrorlist # default

/etc/pacman.conf
#
# Trintiy/TDE
#
[trinity]
# SigLevel = Never
# SigLevel = Optional TrustAll
# SigLevel = PackageReguire
SigLevel = TrustAll
Server   = http://repo.nasutek.com/arch/contrib/trinity/x86_64/

#
# AUR
#
[archlinuxcn]
Server    = https://cdn.repo.archlinuxcn.org/$arch

2. Update

sudo pacman -Syu

3. Install

sudo pacman -S archlinuxcn-keyring

sudo pacman -S --needed base-devel sddm

sudo pacman -Syu
sudo pacman -S yay

yay -S lcms

sudo pacman -S libidn
cd /usr/lib; sudo ln -sf libidn.so libidn.so.11; cd -

sudo pacman -S mysql # and remove conflict pkg
cd /usr/lib; sudo ln -sf libmysqlclient.so libmysqlclient.so.18; cd -

#
# TDE
#

pacman -S tde-tdebase
or
pacman -S tde-meta

4. run ssdm

sudo systemctl start sdd.service

start TDE session is OK ... smile

Last edited by sunjob (2019-06-20 19:06:19)

Offline

#6 2019-06-05 07:56:34

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,908

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

You are creating breaking symlinks this way, you really shouldn't do this. To proper way to fix this this is to rebuild these packages, contact the repo maintainer and ask for a rebuild/confirmation on whether the repo is abandoned. If the packages exist in the AUR without prebuilt packages it'd be better if you built them yourself.

Offline

#7 2019-06-05 09:22:34

sunjob
Member
Registered: 2019-06-04
Posts: 5

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

You are creating breaking symlinks this way, you really shouldn't do this.

??? breaking...  shouldn't do this ???
I do not see anything broken and what should not have been done!

To proper way to fix this this is to rebuild these packages, contact the repo maintainer and ask for a rebuild/confirmation on whether the repo is abandoned.

rebuild these packages
contact the repo maintainer
ask for a rebuild

Is this a simple user path? TDE is install and running natively! What problems? Need to break the rock, if we need to drink coffee?
obviously, you are a specialist, can you do it?
maybe YOU build TDE-14.0.6? I hope the community will come in handy and appreciate it!

If the packages exist in the AUR without prebuilt packages it'd be better if you built them yourself.

yay -S lcms

Last edited by sunjob (2019-06-05 09:24:34)

Offline

#8 2019-06-05 09:37:35

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,908

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

Read https://en.wikipedia.org/wiki/Soname . Soname bumps don't happen just cause, it usually means that the library developers think that there have been incompatible changes that existing binaries shouldn't rely on. You are running the TDE packages in an undefined state. While it looks like it might go well right now, it's not guaranteed and can potentially introduce subtle breakages. As the only thing directly affected by this should be the incorrectly linked TDE packages, the impact should be limited to there, so yes indeed if you just absolutely want to run them and being aware of the risk, that is something you can do.

I have no intention of maintaining the TDE packages so I will not be the one doing this, no. I will still warn people when they are doing unsafe practices for a perceived fix. But it's your system, do whatever...

Offline

#9 2019-06-05 09:37:37

Alad
Wiki Admin/IRC Op/TU
From: Bagelstan
Registered: 2014-05-04
Posts: 1,958
Website

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

You use AUR helpers and pacman on Slackware? Maybe it's the language barrier, but something's off here...


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby
Honest Alad's Package Emporium—Now with added bugs! (Grand reopening: December 1st 2018)

Offline

#10 2019-06-05 10:14:11

sunjob
Member
Registered: 2019-06-04
Posts: 5

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

about wiki/Soname - I understand and agree :о)
but TDE is not officially supported (almost unofficially too), therefore SUCH a way out

You use AUR helpers and pacman on Slackware?

no-no... i'm interested in Arch-Linux, installed to see

apologies for my english, thanks all

Offline

#11 2019-06-18 00:53:11

lucas2santos
Member
From: Brazil
Registered: 2019-06-17
Posts: 2

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

I had the same problem and solved it as follows:



Install lcms from Arch Linux Archive:

# pacman -U https://archive.archlinux.org/packages/l/lcms/lcms-1.19-7-x86_64.pkg.tar.xz

Install libidn11 package:

# pacman -S libidn11

Install (or downgrade to) libmariadbclient-10.1.37 from Arch Linux Archive:

# pacman -U https://archive.archlinux.org/packages/l/libmariadbclient/libmariadbclient-10.1.37-1-x86_64.pkg.tar.xz

Try to install tde-base again:

# pacman -S tde-base

Copy xinitrc file to your home directory:

$ cp /etc/X11/xinit/xinitrc ~/.xinitrc

Add the following line to your ~/.xinitrc file:

exec starttde

Change your $PATH to the following:

PATH=/opt/trinity/tqt3/bin:/opt/trinity/bin:$PATH

Then, start X:

$ startx

I'm not a "Linux expert", but that was what I did in order to make Trinity work. If I did something that I shouldn't, please guys, let me know! (I'm still learning)

jasonwryan wrote:
sunjob wrote:

i'm not user arch-linux

What does that mean?

I think that he meant that he is not a active/frequent user of Arch Linux, so maybe he is not used to that distro yet.

Last edited by lucas2santos (2019-06-18 01:33:40)

Offline

#12 2019-06-18 07:59:42

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,908

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

You now have 2 packages that are partial upgraded in comparison to the rest of your system, this might™ work fine for now, but there's no guarantee for that in the future , in particular keeping an old mariadb lib might go south real quick. Partial upgrades are not supported

Offline

#13 2019-06-18 22:48:50

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,060

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

lucas2santos,
lcms was dropped to aur, see https://aur.archlinux.org/packages/lcms/ .
It looks to be maintained, just build it yourself.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#14 2019-06-19 11:19:31

lucas2santos
Member
From: Brazil
Registered: 2019-06-17
Posts: 2

Re: Trinity/TDE bin repo (repo.nasutek.com), install, trouble, etc

V1del wrote:

You now have 2 packages that are partial upgraded in comparison to the rest of your system, this might™ work fine for now, but there's no guarantee for that in the future , in particular keeping an old mariadb lib might go south real quick. Partial upgrades are not supported

Yes, I'm aware about that. That is the price I'm paying to have TDE in my system. If I have some problem in the future, I'll have to remove it and use another DM/WM.

Lone_Wolf wrote:

lucas2santos,
lcms was dropped to aur, see https://aur.archlinux.org/packages/lcms/ .
It looks to be maintained, just build it yourself.

Thanks for the advice! So I will be using that package instead.

P.S.: I just noticed that libmariadbclient is in AUR too: https://aur.archlinux.org/packages/libm … noconflict. Now I can use Trinity without partial upgrades in my system! smile

Last edited by lucas2santos (2019-07-18 16:23:00)

Offline

Board footer

Powered by FluxBB