You are not logged in.

#1 2019-06-17 08:44:15

sairuiu
Member
Registered: 2019-05-18
Posts: 12

Firefox not using GTK font

The font Firefox uses for its components (tab title, address bar, right-click context menu, about:preferences elements, etc) isn't the one specified by my gtk configs (~/.gtkrc-2.0 or ~/.config/gtk-3.0/settings.ini). Initially it was displaying as a monospace font, but I fixed that by deleting /etc/gtk-2.0/gtkrc and /etc/gtk-3.0/settings.ini and the font displayed correctly. After updating earlier, Firefox now displays with some serif font (probably georgia), and I can't figure out how to get it to use my gtk themed font.

Tried downgrading Firefox, playing around with font-config, setting the system-wide gtk theme, clean profile, rebooting and probably some other things I'm forgetting, no dice. Any advice would be great, thanks.

Offline

#2 2019-06-17 12:20:03

W_KIWAN
Member
From: Netherlands
Registered: 2018-02-23
Posts: 28

Re: Firefox not using GTK font

What DE/WM are you using?
Is it Wayland or Xorg session?
Do you run Firefox with Wayland or X11 backend?

Offline

#3 2019-06-17 13:23:41

sairuiu
Member
Registered: 2019-05-18
Posts: 12

Re: Firefox not using GTK font

W_KIWAN wrote:

What DE/WM are you using?
Is it Wayland or Xorg session?
Do you run Firefox with Wayland or X11 backend?

i3-gaps, xorg, x11

Offline

#4 2019-06-17 13:37:25

W_KIWAN
Member
From: Netherlands
Registered: 2018-02-23
Posts: 28

Re: Firefox not using GTK font

Can you run this command and check if it makes any change for you?

gsettings set org.gnome.desktop.interface font-name "<NAME> <SIZE>"

Offline

#5 2019-06-18 11:43:25

sairuiu
Member
Registered: 2019-05-18
Posts: 12

Re: Firefox not using GTK font

Thanks, I gave it a go but couldn't observe any changes.

Offline

#6 2019-06-18 11:59:10

W_KIWAN
Member
From: Netherlands
Registered: 2018-02-23
Posts: 28

Re: Firefox not using GTK font

Please paste the output of this two commands

cat ~/.config/gtk-3.0/settings.ini
gsettings get org.gnome.desktop.interface font-name

Offline

#7 2019-06-18 12:10:49

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,851

Re: Firefox not using GTK font

What if you change font?
In the past i've had troubles with one in particular (but can't remember which one), "rejected" only by firefox.

-EDIT-
Oh, now i remember.
Using kde to set the gtk-3 font, it wrote that:

koko@Gozer# grep font ~/.config/gtk-3.0/settings.ini
gtk-font-name=PT Sans [PARA] Regular 10

That way, firefox ignored PT Sans and used Liberation Sans instead, but modifying it with the following made it work:

koko@Gozer# grep font ~/.config/gtk-3.0/settings.ini
gtk-font-name=PT Sans 10

Last edited by kokoko3k (2019-06-18 12:15:08)

Offline

#8 2019-06-18 13:47:31

sairuiu
Member
Registered: 2019-05-18
Posts: 12

Re: Firefox not using GTK font

W_KIWAN wrote:

Please paste the output of this two commands

cat ~/.config/gtk-3.0/settings.ini
gsettings get org.gnome.desktop.interface font-name
$ cat ~/.config/gtk-3.0/settings.ini
[Settings]
gtk-icon-theme-name = "Arc"
gtk-theme-name = "Arc-Dark"
gtk-font-name = "Source Han Sans JP 8"

$ gsettings get org.gnome.desktop.interface font-name
'Source Han Sans JP 8'
kokoko3k wrote:

What if you change font?
In the past i've had troubles with one in particular (but can't remember which one), "rejected" only by firefox.

-EDIT-
Oh, now i remember.
Using kde to set the gtk-3 font, it wrote that:

koko@Gozer# grep font ~/.config/gtk-3.0/settings.ini
gtk-font-name=PT Sans [PARA] Regular 10

That way, firefox ignored PT Sans and used Liberation Sans instead, but modifying it with the following made it work:

koko@Gozer# grep font ~/.config/gtk-3.0/settings.ini
gtk-font-name=PT Sans 10

I've tried setting a few different fonts in ~/.config/gtk-3.0/settings.ini but nothing seems to change it.

Offline

Board footer

Powered by FluxBB