You are not logged in.

#1 2019-07-03 21:29:58

miomio
Member
Registered: 2016-01-17
Posts: 158

[SOLVED] Cannot get SANE to change network port

I'm using the Samsung unified driver AUR package as I have a C480FW MFP. I have no problems printing with cups. The scanner is proving a little tricky. Sane does detect it:

# scanimage -L
device `smfp:net;192.168.0.22' is a Samsung C48x Series on 192.168.0.22 Scanner

I did not make much config changes from default install (sane then driver) except for: https://wiki.archlinux.org/index.php/SA … ms#Samsung and hence added the following line to the `/etc/sane.d/xerox_mfp-smfp.conf` file:

# Samsung C480FW
tcp 192.168.0.22

Bad news is Sane doesn't scan an image:

# scanimage --verbose --format=png > test.png
scanimage: open of device smfp:net;192.168.0.22 failed: Device busy

Good news is I think it's because Sane is trying to send a TCP SYN to the wrong port via 9400, however an nmap scan shows that the printer is listening on 9100 hence the printer returning an immediate RST packet. According to the Sane docs the port can be specified in the config: http://www.sane-project.org/man/sane-xerox_mfp.5.html

# Samsung C480FW
tcp 192.168.0.22 9100
 

But unfortunately, the same port is still being used rather than the new port 9100.

What extra am I missing? Does sane/scanimage have a way for me to specify via the cli an alternative port?

EDIT:

Port 9400 and 9100 are different services (twain something vs raw (9100)). I solved this by resetting the printer, and was able to establish port 9400 was then available `nc -zv 192.168.0.22 9400`.

Last edited by miomio (2019-07-04 00:06:56)

Offline

Board footer

Powered by FluxBB