You are not logged in.

#1 2019-07-08 21:25:01

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 326
Website

[SOLVED] Cannot build some of KF5 packages

When I try to build KF5 5.59 from sources, some of them cannot be build with the same error. For kauth it's:

[ 76%] Generating pybuild/PyKF5/KAuth/unifiedKAuth.cpp
Traceback (most recent call last):
  File "/usr/share/ECM/find-modules/run-sip.py", line 9, in <module>
    from PyQt5.Qt import PYQT_CONFIGURATION
ImportError: No module named PyQt5.Qt
make[2]: *** [src/CMakeFiles/sip_generated_KAuth_files.dir/build.make:65: src/pybuild/PyKF5/KAuth/unifiedKAuth.cpp] Error 1
make[1]: *** [CMakeFiles/Makefile2:4276: src/CMakeFiles/sip_generated_KAuth_files.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 77%] Building CXX object src/CMakeFiles/KF5AuthCore.dir/BackendsManager.cpp.o
[ 77%] Building CXX object src/CMakeFiles/KF5AuthCore.dir/HelperProxy.cpp.o
[ 78%] Building CXX object src/CMakeFiles/KF5AuthCore.dir/kauthhelpersupport.cpp.o
[ 80%] Linking CXX executable ../bin/kauth-policy-gen
[ 80%] Building CXX object src/CMakeFiles/KF5AuthCore.dir/kauthdebug.cpp.o
[ 80%] Built target kauth-policy-gen
[ 80%] Building CXX object src/CMakeFiles/KF5AuthCore.dir/backends/fake/FakeBackend.cpp.o
[ 81%] Building CXX object src/CMakeFiles/KF5AuthCore.dir/backends/fakehelper/FakeHelperProxy.cpp.o
[ 82%] Building CXX object src/CMakeFiles/KF5AuthCore.dir/ECMQmLoader-kauth5_qt.cpp.o
[ 82%] Linking CXX shared library ../bin/libKF5AuthCore.so
[ 82%] Built target KF5AuthCore
make: *** [Makefile:130: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

I can send whole build log.
My system is up to date, and all dependencies of kauth are installed (both for depends and makedepends).
What's wrong?

EDIT:
It seems, that it's something related to sip, because without it as makedepends kauth builds well (in KaOS it's building without it as well).

Last edited by pb (2019-07-09 18:37:43)

Offline

#2 2019-07-09 11:46:39

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,288

Re: [SOLVED] Cannot build some of KF5 packages

Looks like sip maybe looking for the wrong pyqt (python2 version instead of python3 or reverse) .

Are you building with python2 AND python3 installed ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2019-07-09 18:38:09

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 326
Website

Re: [SOLVED] Cannot build some of KF5 packages

Yes, I've right. Without python2 builds well.

Offline

Board footer

Powered by FluxBB