You are not logged in.

#1 2019-07-15 23:30:22

Registered: 2013-10-12
Posts: 62

[Solved] Help Narrowing Down Aosp Build Error

So I'm not sure if this is an error in the device I'm trying to build Android/aosp for which is Pixel XL/marlin or conflicts with libraries from the build tree and my systems'. The version I'm building is pie from this fork of aosp. I've built successfully once before the 5.1 kernel update dropped and I'm not sure if the kernel update is even related or not. I've added a log but it just seems like one of the prebuilt toolchains was built with Werror and is stopping the build from a warning. Which confuses me as I've already built fine once, could that really have been a fluke or have I yet to find the introduced breakage?

Forgot to include my hardware info sorry
I have a ryzen 1600 with 16gm of ram and a 960gb m.2 ssd that I'm building with.

Another update

Tried building with -j4 instead of -j10, actually says java crashed during compilation

Here's the java log

Another edit, could be because I have smt enabled according to … ler-Issues will test with it disabled.

Updated by bios to the latest version and built aosp with -j4 so I guess this is solved for the most part.

Last edited by cj360 (2019-08-09 20:21:54)


Board footer

Powered by FluxBB