You are not logged in.

#1 2019-07-25 01:59:42

Registered: 2019-07-21
Posts: 1

Black screen for two minutes when waking from suspend

I've been having this issue for awhile, and the issue I have is pretty much described on the suspend Arch wiki, but I tried their solutions to no effect. Some things I've tried: adding

MODULES=(intel_agp i915)

to mkinitcpio.conf, blacklisting thunderblot, and blacklisting nvidiafb.
Here's the output to lspci for my VGA graphics card:

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Lenovo ThinkPad T480
	Flags: bus master, fast devsel, latency 0, IRQ 148
	Memory at eb000000 (64-bit, non-prefetchable) [size=16M]
	Memory at 80000000 (64-bit, prefetchable) [size=256M]
	I/O ports at e000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: [40] Vendor Specific Information: Len=0c <?>
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [100] Process Address Space ID (PASID)
	Capabilities: [200] Address Translation Service (ATS)
	Capabilities: [300] Page Request Interface (PRI)
	Kernel driver in use: i915
	Kernel modules: i915

My journalctl -f also spit out this line, but I dont know if it's of any significance:

Jul 24 21:51:16 StinkPad kernel: nouveau 0000:01:00.0: DRM: failed to idle channel 1 [DRM]

Here's the lspci for that card too:

01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)
	Subsystem: Lenovo ThinkPad T480
	Flags: bus master, fast devsel, latency 0, IRQ 154
	Memory at ec000000 (32-bit, non-prefetchable) [size=16M]
	Memory at 90000000 (64-bit, prefetchable) [size=256M]
	Memory at a0000000 (64-bit, prefetchable) [size=32M]
	I/O ports at d000 [size=128]
	Expansion ROM at <ignored> [disabled]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [100] Virtual Channel
	Capabilities: [250] Latency Tolerance Reporting
	Capabilities: [258] L1 PM Substates
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [420] Advanced Error Reporting
	Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
	Capabilities: [900] Secondary PCI Express <?>
	Kernel driver in use: nouveau
	Kernel modules: nouveau

I've been trying to fix this for a long while so any help is greatly appreciated.


Board footer

Powered by FluxBB