You are not logged in.

#1 2019-07-27 09:02:51

gerald82
Member
From: The known universe
Registered: 2011-03-25
Posts: 74

[Solved]Issues with mesa

Hello,

I did a fresh Arch installation on my new laptop at work. Basically it's all set up and I can work with the machine now.
However, there are three annoying drawbacks that I really would like to fix:

  • Hibernation does not work (yes, went through the wiki and think I did everything right)

  • Shutting down and rebooting more often than not requires me to kill the machine manually (the machine gets stuck before reaching shutdown target)

  • After logging out of the Desktop environment (Plasma), the display manager (SDDM) does not set up a new login screen

The laptop is a ThinkPad T480 and I use Intel graphics.
I went through the logs after each of the issues and i believe they all have the same root cause:

kernel: nouveau 0000:01:00.0: DRM: failed to idle channel 0 [DRM]
kernel: nouveau 0000:01:00.0: DRM: failed to idle channel 1 [DRM]
kernel: nouveau 0000:01:00.0: tmr: stalled at ffffffffffffffff

Especially the last line also appears on screen and then the system halts and I have to power it down hard.

I find lines like these quite frequently in the journal, despite that I'm not using nvidia graphics and also not the nouveau driver. I use xf86-video-intel and mesa.
From this point on I have no clue how to resolve this, unfortunately. Could you help me out?

-----------
Edit:
All the listed issues are solved by blacklisting nouveau. Kernel parameter: modprobe.blacklist=nouveau.

Last edited by gerald82 (2019-07-27 11:56:15)

Offline

Board footer

Powered by FluxBB