You are not logged in.

#1 2019-07-28 15:55:32

taumeister
Member
Registered: 2019-01-06
Posts: 28

[solved] Arch on ZFS Root | modules are not loaded

Hello,
I already asked this question in the German ArchLinux Forum , but unfortunately nobody could help me there.
Maybe here someone has some information that could help me.

I have written a wonderful working manual for me how to install Arch on zfs root. The installation works fine in virtual machines as well as on my company laptop or test laptop.
Only not on my new PC.
The system is an AMD CPU, 32GB RAM, SSD, nothing special.

After the first start I get the following error message.

::running hook [zfs]
The ZFS modules are not loaded.
[rootfs ]# 

Since I've done this installation countless times successfully, I'm arrogantly assuming that there's nothing wrong with my installation process itself.

If I install the hard disk from my PC into a test laptop, the system starts without problems. The modules are available at once and the pool is integrated, the system runs as desired.

The only possibility on my PC is to start the system in fallback mode.
This works.
This would explain the error message - in fallback.img the autodetect mode is disabled and all needed modules are included.

But why the hell does the hard disk boot in any other system without problems?

Modules(zfs) in the mkinitcpio.conf did not change anything.

I'd really appreciate help.


Anleitung
 
GPT Partitionstabelle                  Mountpunkt
/dev/sda1 fat32   UEFI ESP            /boot/     # benutze aber die Windows UEFI Partition
/dev/sda2 ext4    Rescue              /rescue     # später für rescue und backup system mit clonezilla
/dev/sda3 zfs     ZFS                  

Windows_UEFI=ata-Samsung_SSD_850_EVO_500GB_S21JNXAGB09833X-part2

zpool create -o ashift=12 \
      -O atime=off -O canmount=off -O compression=lz4 -O normalization=formD \
      -O mountpoint=/ -R /mnt \
      rpool /dev/disk/by-id/ata-Samsung_SSD_850_EVO_500GB_S21JNXAGB09824D-part3 -f
      
      
zfs create -o mountpoint=/ rpool/ROOT/arch
zfs create -o setuid=off -o mountpoint=/home rpool/home
zfs create -o mountpoint=/var/cache/pacman/pkg rpool/pkg
zfs create -o mountpoint=/var/log   rpool/log

zfs create -V 32G -b $(getconf PAGESIZE) \
              -o logbias=throughput -o sync=always\
              -o primarycache=metadata \
              -o com.sun:auto-snapshot=false rpool/swap

mkswap -f /dev/zvol/rpool/swap

zpool status
zfs list
df

zpool export rpool
zpool import -R /mnt rpool

swapon /dev/zvol/rpool/swap
              
df
-------------------------------------

mkdir /mnt/boot
mount /dev/sdb2 /mnt/boot    # hier muss das Windows ESP (efi) gemountet werden.


-------------------------------------

pacstrap  /mnt git sudo base base-devel bash-completion dosfstools efibootmgr nano linux-headers networkmanager acpid cronie openssh zsh cifs-utils gdisk

genfstab -U /mnt >> /mnt/etc/fstab

# alles raus bis auf efi und swap
nano -w /mnt/etc/fstab   

# /dev/zvol/<pool>/swap none swap discard 0 0

--------------------------------------

arch-chroot /mnt

echo LANG=de_DE.UTF-8 > /etc/locale.conf
echo LC_COLLATE=C >> /etc/locale.conf
echo LANGUAGE=de_DE >> /etc/locale.conf
echo KEYMAP=de-latin1 > /etc/vconsole.conf 
echo FONT=lat9w-16 >> /etc/vconsole.conf 
ln -sf /usr/share/zoneinfo/Europe/Berlin /etc/localtime 
sed -i "/#en_US.UTF-8 UTF-8/c\en_US.UTF-8 UTF-8"  /etc/locale.gen
sed -i "/#de_DE.UTF-8 UTF-8/c\de_DE.UTF-8 UTF-8"  /etc/locale.gen
locale-gen 

sed -i 's/#\(PermitRootLogin \).\+/\1yes/' /etc/ssh/sshd_config
sed -i "s/#Server/Server/g" /etc/pacman.d/mirrorlist
sed -i 's/#\(Storage=\)auto/\1volatile/' /etc/systemd/journald.conf

echo "zero" > /etc/hostname
echo "127.0.0.1          localhost
127.0.1.1          zero
::1                zero" >> /etc/hosts

#USER
# root
echo root:myPassword | chpasswd
usermod -s /usr/bin/zsh root
cp -aT /etc/skel/ /root/
#chmod 700 /root

# tom
! id tom && useradd -m -p "" -g users -G "adm,audio,floppy,log,network,rfkill,scanner,storage,optical,power,wheel" -s /bin/zsh tom
chown -R tom:users /home/tom
echo tom:myPassword | chpasswd
usermod -s /usr/bin/zsh tom
echo "tom ALL=(ALL) NOPASSWD:ALL" > /etc/sudoers.d/tom

sed -i '/#MAKEFLAGS=\"-j2\"/c\MAKEFLAGS=\"-j13\"' /etc/makepkg.conf

su tom
cd
pwd
mkdir .AUR
cd .AUR
git clone https://aur.archlinux.org/zfs-utils.git
git clone https://aur.archlinux.org/zfs-dkms.git
cd zfs-utils
makepkg -rsi --skippgp

cd ..

cd zfs-dkms
makepkg -rsi --skippgp

--> neues Terminal öffnen
sudo su
zpool set cachefile=/etc/zfs/zpool.cache rpool
cp /etc/zfs/zpool.cache /mnt/etc/zfs/
--> Terminal schließen

systemctl enable zfs.target zfs-mount.service acpid.service cronie.service NetworkManager

nano -w /etc/mkinitcpio.conf
...block keymap keyboard zfs filesystems

mkinitcpio -p linux


# systemd boot
# https://wiki.archlinux.de/title/Systemd-boot

bootctl install

echo "timeout 3
default arch" > /boot/loader/loader.conf

echo "title          Arch Linux on ZFS
linux          /vmlinuz-linux
initrd         /initramfs-linux.img
options        zfs=rpool/ROOT/arch rw" > /boot/loader/entries/arch.conf

exit
umount -R /mnt
zfs umount -a
zpool export rpool


# reboot
# bootctl remove # deinstalliert systemdboot
# 
# # efibootmgr -c -d /dev/sdX -p Y -l "\EFI\systemd\systemd-bootx64.efi" -L "Linux Boot Manager"

Last edited by taumeister (2019-08-05 13:36:24)

Offline

#2 2019-07-28 18:48:13

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,290

Re: [solved] Arch on ZFS Root | modules are not loaded

and what happens when you modprobe them from that prompt?

Offline

#3 2019-07-28 20:23:21

taumeister
Member
Registered: 2019-01-06
Posts: 28

Re: [solved] Arch on ZFS Root | modules are not loaded

modprobe works.
zpool import works.
zfs list works.

to understand just doesn't work..

But remember, before you get too caught up in configuration details, when I install the same hard disk into another PC, it boots immediately, even with the normal default entry.
That must be something PC/architecture specific, right?

Last edited by taumeister (2019-07-28 20:27:10)

Offline

#4 2019-07-28 20:29:43

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,290

Re: [solved] Arch on ZFS Root | modules are not loaded

Did you generate the initramfs in a different system?

Offline

#5 2019-07-28 20:43:38

taumeister
Member
Registered: 2019-01-06
Posts: 28

Re: [solved] Arch on ZFS Root | modules are not loaded

No, I have an Archiso CD with ZFS modules. From this I install my systems. sorry

Offline

#6 2019-07-29 14:24:30

taumeister
Member
Registered: 2019-01-06
Posts: 28

Re: [solved] Arch on ZFS Root | modules are not loaded

Update:
If I deactivate the 'autodetect' feature, i.e. remove it from mkinitcpio.conf, I can start with the normal entry without any problems.
Something in the autodetect part seems not to work properly.

Offline

Board footer

Powered by FluxBB