You are not logged in.

#1 2019-07-31 18:07:56

Registered: 2019-07-31
Posts: 3

[SOLVED] Path of Exile Locks up PC

I started by trying to follow "Chris Linus Tech's" tutorial @ … =59&t=693s - and his tutorial did not work; its also six months old.  But while reading through some of the user comments; they mention that Proton 4.2-9 works with Path of Exile without any runtime options what so ever.  So i decide to give it a shot as it was the version of Proton that steam installed automatically.  SUCCESS!!  the game loaded faster than i had time to contemplate if it would work or not.  I go into the options and turn off V-Sync like i do with every game and as per 99% of every forum post or comment i have seen regarding the topic.  I play the game for about 15-20 minutes going about completing the first qust "Mercy Mission" in the Tidal Flats.

    This is where it went down hill.  As soon as i loaded the environment/scene for the Tidal Flats - my computer monitor goes completely black and i can hear the waves crashing againts the shore.  ALT+F4, ALT+TAB, SUPER+D(show desktop), even CTRL+ALT+DEL; did not work!  I had to hold the power button my machine to force a shut down.  I cringed thinking about the SSD that Path of Exile was installed on as i held down the button.  After a reboot, i decide to try a few of the runtime options that are floating through forums and comments.  I used the arguments from the tutorial i posted earlier- as well as different variations of runtime options that are listed on the ProtonDB for Path of Exile "".   I kept getting a black screen lockup at the Tidal Flats, as soon as it would leave the loading screen and try to draw the world - black screen.
   The only runtime option that worked, was from the PrtotonDB reviews - "PROTON_USE_WINED3D"  I was able to load the Tidal Flats and complete my first quest without a hitch.  I got really excited after turning in my first quest and hit "ESC-Exit to OS" *BLACK SCREEN LOCK UP* - yet again!.
   I have updated Nvidia drivers, LLVM7, Python3, Vulkan-icd-loader & lib32-vulkan-icd-loader.  I am about 99% certain i have every pre-requisite, including the steam-native-runtime.  My steam has beta updates enabled.

I enabled SSHD on the machine, to try and at least "sudo reboot" or "sudo shutdown now" from an SSH session over my phone.  I can successfully connect; but after i issue the CMD in SSH, i get disconnected from SSH and the computer does not reboot.
  Seeing as how the computer hard locks up - im not sure as how to troubleshoot here?

Anyone have luck running Path of Exile from the Steam-runtime?     As per the ProtonDB site - they ask everyone to post the system information copied from the steam window - so just to eliminate all questions about hardware:

***EDIT: The only runtime options I have not tried are "PROTON_NO_D3D11" forcing it back to a d3d9 environment instead of D3D11.

Computer Information:
    Manufacturer:  Unknown
    Model:  Unknown
    Form Factor: Desktop
    No Touch Input Detected

Processor Information:
    CPU Vendor:  GenuineIntel
    CPU Brand:  Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz
    CPU Family:  0x6
    CPU Model:  0x3f
    CPU Stepping:  0x2
    CPU Type:  0x0
    Speed:  3900 Mhz
    6 logical processors
    6 physical processors
    HyperThreading:  Unsupported
    FCMOV:  Supported
    SSE2:  Supported
    SSE3:  Supported
    SSSE3:  Supported
    SSE4a:  Unsupported
    SSE41:  Supported
    SSE42:  Supported
    AES:  Supported
    AVX:  Supported
    CMPXCHG16B:  Supported
    LAHF/SAHF:  Supported
    PrefetchW:  Unsupported

Operating System Version:
    Unknown (64 bit)
    Kernel Name:  Linux
    Kernel Version:  5.2.4-arch1-1-ARCH
    X Server Vendor:  The X.Org Foundation
    X Server Release:  12005000
    X Window Manager:  Mutter(Budgie)
    Steam Runtime Version:  steam-runtime_0.20190711.3

Video Card:
    Driver:  NVIDIA Corporation GeForce GTX 980/PCIe/SSE2
    Driver Version:  4.6.0 NVIDIA 430.34
    OpenGL Version: 4.6
    Desktop Color Depth: 24 bits per pixel
    Monitor Refresh Rate: 59 Hz
    VendorID:  0x10de
    DeviceID:  0x13c0
    Revision Not Detected
    Number of Monitors:  2
    Number of Logical Video Cards:  1
    Primary Display Resolution:  1920 x 1200
    Desktop Resolution: 2944 x 1200
    Primary Display Size: 20.39" x 12.76" (24.02" diag)
                                            51.8cm x 32.4cm (61.0cm diag)
    Primary Bus: PCI Express 16x
    Primary VRAM: 4096 MB
    Supported MSAA Modes:  2x 4x 8x 16x

Sound card:
    Audio device: Realtek ALC1150

    RAM:  15949 Mb

    UI Language:  English
    LANG:  en_US.UTF-8
    Total Hard Disk Space Available:  238836 Mb
    Largest Free Hard Disk Block:  177205 Mb
    VR Headset: None detected

Recent Failure Reports:

Last edited by Ganome (2019-07-31 21:16:21)


#2 2019-07-31 19:40:58

Registered: 2019-07-31
Posts: 3

Re: [SOLVED] Path of Exile Locks up PC

I think i may have solved my own problem.  By simply using the Final resort of D3D9.  I have been playing the game for about an hour now, and no freezes or hard lock ups.      Steam-runtime Launch Options for Path of Exile: "PROTON_NO_D3D11"  and thats it.    When i first started the game - there was some horrid visual glitches, maybe textures being mapped or something? i haven't the slightest.  But i could see the game, with White triangles of various sizes flashing all over the screen.  I hit ESC, and they went away.  Haven't returned.  Only lasted about 5 seconds.  I will update Forum post to [SOLVED] after some further play-testing

I have included screenshots of my In-game settings for anyone interested

I just played for over 2 straight hours, and not a single hiccup.  Great gameplay and usually around 100 FPS. 

I would eventually like to figure out why the DXVK drivers are freezing my computer, but in the meantime i will just use the D3D9.

I just installed path of exile on my son's desktop with a G-Force 610 and it runs the game natively with Vulcan support.  My GTX 980 has as much RAM as his entire computer!!  Maybe I did something wrong.....

Last edited by Ganome (2019-08-01 02:00:31)


#3 2019-08-01 04:06:39

Registered: 2019-07-31
Posts: 3

Re: [SOLVED] Path of Exile Locks up PC

This is my second reply to my own post - yes.   I just got tired of the countless edits i was doing and probably hard to keep track of my nonsense.   


  Path of Exile runs perfect on my machine with over 100FPS (~140FPS).   I just found out that a few hours ago Proton updated to Version 4.11-1.   This new version takes a runtime variable to enable the improved D9VK library.  The only runtime option i have running now is the option to ENABLE the D9VK.  These options can be found here .  I have also modifed the way sysctl handles VM's.  By editing "/etc/sysctl.d/99-sysctl.conf" to include the following:

vm.swappiness = 10
vm.vfs_cache_pressure = 50
vm.watermmark_scale_factor = 200
vm.dirty_ratio = 3

Reboot after editing/creating that file.  Found this advice as per the youtube tutorial from Chris Titus Tech Linked in the first post.

EDIT:  Sorry folks.   After a few hours of gameplay - i got this from dmesg after a crash.  Any pointers??

I think i need to change my MTRR values - but havent the slightest clue how?  i cant find the option in the BIOS of my Asus X-99A.   Above 4G decoding?

Last edited by Ganome (2019-08-01 09:01:02)


Board footer

Powered by FluxBB