You are not logged in.

#1 2019-07-31 21:33:50

Buddlespit
Member
From: Chesapeake, Va.
Registered: 2014-02-07
Posts: 449

[Solved] libXNVCtrl

It appears that the latest update forgot to package libXNVCtrl.so.0 and it has broken conky. The filelist for libxnvctrl-430.40-1 doesn't list the .so.0 in /usr/lib/

pat@PatsMain:~$ /usr/bin/conky -p5 -c "/home/pat/bin/pat1"
/usr/bin/conky: error while loading shared libraries: libXNVCtrl.so.0: cannot open shared object file: No such file or directory

edit: Ummm, sorry.... this should prolly be in the pacman and packaging sub forum
edit#2: downgrading to 430.14 works. I was worried I would break something by not downgrading any other nvidia pkg.

Last edited by Buddlespit (2019-08-01 20:16:18)


AMD Ryzen 7 1700X | Asus PRIME X370-A | GeForce GTX 980 Ti | 16G Ram | KDE Plasma | Zen Kernel
Until linuxcounter.com closed, I was registered linux user #560427

Offline

#2 2019-08-01 06:37:51

seth
Member
Registered: 2012-09-03
Posts: 11,983

Re: [Solved] libXNVCtrl

a) please use more meaningful subjects
b) looks deliberate: https://git.archlinux.org/svntogit/pack … 1d32cc1227
c) filing a patch against the package will probably work better than a forum post, but …
d) I don't see where conky links xnvctrl - do you use a custom build? (This would explain why the maintaner thought the shared object was useless)

Offline

#3 2019-08-01 09:22:09

xafnir
Member
Registered: 2019-08-01
Posts: 1

Re: [Solved] libXNVCtrl

Same here. Because I use the custom build 'conky-lua-nv' from the AUR. I just recompiled it and it works again.
Try to recompile conky, I you use a custom build.

Offline

#4 2019-08-01 11:17:32

d_fajardo
Member
Registered: 2017-07-28
Posts: 408

Re: [Solved] libXNVCtrl

I had a conversation with the maintainer. Rebuilding the package works. Basically just delete the conky-lua-nv or whatever package from cache and try again. It works for me anyway.

Last edited by d_fajardo (2019-08-01 11:18:16)

Offline

#5 2019-08-01 11:33:12

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,920
Website

Re: [Solved] libXNVCtrl

Mod note: moving to AUR Issues.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#6 2019-08-01 20:15:55

Buddlespit
Member
From: Chesapeake, Va.
Registered: 2014-02-07
Posts: 449

Re: [Solved] libXNVCtrl

Thanks all. Sorry about the trouble. You're right, I should have filed a bug report instead of the forum. Uninstalling, deleting and rebuilding conky-lua-nv worked like a charm


AMD Ryzen 7 1700X | Asus PRIME X370-A | GeForce GTX 980 Ti | 16G Ram | KDE Plasma | Zen Kernel
Until linuxcounter.com closed, I was registered linux user #560427

Offline

Board footer

Powered by FluxBB