You are not logged in.

#1 2019-08-04 23:10:31

antoyo
Member
Registered: 2012-08-16
Posts: 37

[Solved] Default printer is LPR

Hi.
I set the default printer in the cups configuration website (and it says that the selected printer is the default), but the GTK printer dialog always select "Print to LPR" as the default instead of the default printer.
How can I make it select the default printer instead?
Or, is there a way to remove the "Print to LPR" option?
Thanks.

Last edited by antoyo (2020-04-04 01:24:33)

Offline

#2 2019-08-06 11:16:15

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,573

Re: [Solved] Default printer is LPR

Some DE's have their own tools to setup printing and don't use cups settings.

What DE are you using and is sytem-config-printer or print-manager installed ?

What is the output of

$ lpr

Last edited by Lone_Wolf (2019-08-06 11:17:16)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2019-08-07 12:24:45

antoyo
Member
Registered: 2012-08-16
Posts: 37

Re: [Solved] Default printer is LPR

I don't use a desktop environment (I use the i3 window manager), but I recently installed (and uninstalled) the mate desktop environement, which is approximately the time where this issue happened.
Neither system-config-printer, nor print-manager are installed.
`lpr` seems to wait for input, so if I hit ctrl-d instantly, it will say "No file in print request". If I hit enter, then ctrl-d, it will print with my default printer (the real one, not the "Print to LPR" thing).
Does that mean it's a GUI config thing?

Thanks for your answer.

Offline

#4 2019-08-07 13:23:12

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,573

Re: [Solved] Default printer is LPR

I should have mentioned the waiting for input part, sorry about that.

man lpr wrote:

DESCRIPTION
       lpr submits files for printing.  Files named on the command line are sent to the named printer or the default destination if no destination
       is specified.  If no files are listed on the command-line, lpr reads the print file from the standard input.

I do remember seeing "print to lpr" in some print dialogs , possibly related to having only one printer  configured.

Try creating a 2nd printer (can be same physical printer, just with a slightly different name) .
Does gtk print dialog now show printer names ?

Last edited by Lone_Wolf (2019-08-07 13:29:09)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#5 2019-08-07 13:38:10

progandy
Member
Registered: 2012-05-17
Posts: 4,626

Re: [Solved] Default printer is LPR

What is your GTK package and version? Have you compiled your own gtk package without libcups?  The gtk3 package is not damaged?

pacman -Qi gtk3
pacman -Qkk gtk3

The most recent similar problem I found with a websearch was a (fixed) manjaro issue with gtk3-classic.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#6 2019-08-07 13:52:00

seth
Member
Registered: 2012-09-03
Posts: 24,895

Re: [Solved] Default printer is LPR

I've never seen that - maybe some generic printer?

lpstat -v

Offline

#7 2019-08-07 23:49:37

antoyo
Member
Registered: 2012-08-16
Posts: 37

Re: [Solved] Default printer is LPR

Thanks for your answers.
Adding a second printer does not fix the issue.
Here's the output of the required commands:

~ pacman -Qi gtk3
Name            : gtk3
Version         : 1:3.24.10-1
Description     : GObject-based multi-platform GUI toolkit
Architecture    : x86_64
URL             : https://www.gtk.org/
Licenses        : LGPL
Groups          : None
Provides        : gtk3-print-backends
Depends On      : atk  cairo  libxcursor  libxinerama  libxrandr  libxi  libepoxy  gdk-pixbuf2  dconf  libxcomposite
                  libxdamage  pango  shared-mime-info  at-spi2-atk  wayland  libxkbcommon  adwaita-icon-theme  json-glib
                  librsvg  wayland-protocols  desktop-file-utils  mesa  cantarell-fonts  colord  rest  libcups
                  libcanberra  fribidi  iso-codes  gtk-update-icon-cache
Optional Deps   : None
Required By     : connman-gtk  firefox  flips  gcr  girara  gtkmm3  libnma  seahorse  simple-scan  snes9x-gtk
                  termite-bepo  webkit2gtk
Optional For    : avahi  ghostscript  gssdp  libinput  libreoffice-fresh  qt5-base  redshift
Conflicts With  : gtk3-print-backends
Replaces        : gtk3-print-backends<=3.22.26-1
Installed Size  : 72.74 MiB
Packager        : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Build Date      : Thu Jul 4 07:02:41 2019
Install Date    : Tue Jul 9 09:02:49 2019
Install Reason  : Installed as a dependency for another package
Install Script  : Yes
Validated By    : Signature
~ pacman -Qkk gtk3
gtk3: 1701 total files, 0 altered files
~ lpstat -v
device for Samsung_M267x_287x_Series: socket://192.168.1.114

Offline

#8 2019-08-09 06:50:54

monodromy
Member
Registered: 2014-02-08
Posts: 62

Re: [Solved] Default printer is LPR

Is this with a variety of applications? I have the same behavior when I print from the zathura pdf viewer, but not when I print with (for example) a web browser.

Offline

#9 2019-08-09 22:32:51

antoyo
Member
Registered: 2012-08-16
Posts: 37

Re: [Solved] Default printer is LPR

monodromy wrote:

Is this with a variety of applications? I have the same behavior when I print from the zathura pdf viewer, but not when I print with (for example) a web browser.

Indeed. The problem occurs with Zathura, but not Firefox. But it happens with my webkit2gtk-based web browser.

Offline

#10 2020-04-04 01:24:16

antoyo
Member
Registered: 2012-08-16
Posts: 37

Re: [Solved] Default printer is LPR

I finally found the solution to my problem:
Completely disable lpr in the gtk-print-backends by adding the following:

[Settings]
gtk-print-backends=file,cups,pdf

in ~/.config/gtk-3.0/settings.ini.

Offline

Board footer

Powered by FluxBB