You are not logged in.

#1 2019-08-08 00:02:14

core_contingency
Member
Registered: 2019-08-07
Posts: 1

How to remove a git clone url in AUR package

*****EDIT: nevermind, apparently ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git only shows up when logged into my account, so I think this is something normal. I'm dumb.******

I am very new with git, and the aur in general, so sorry for the newbie questions!

Just made my first package, and I accidentally added ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git as a git clone url, and want to remove it.
Here is the link to my package: https://aur.archlinux.org/packages/brother-mfc-9325cw/

So how I think I added it:
I was having some problems trying to figure out how to push my package to the aur.

I eventually figured it out by running

$ git push --set-upstream ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git master

to upload my package to the aur. However, before I ran this, I was following the instructions on the arch wiki

https://wiki.archlinux.org/index.php/AU … positories

with no luck, and ran this:

$ git remote add original ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git
$ git remote -v
original        ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git (fetch)
original        ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git (push)
$ git fetch original ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git
fatal: invalid refspec 'ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git'

I suspect that this added ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git as a git clone url somehow.

I have tried removing it with a couple of different methods, but no luck.

$ git remote remove original ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git
usage: git remote remove <name>
$ git remote remove original
$ git commit
On branch master
nothing to commit, working tree clean
$ git remote -v
$ git push ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git
Everything up-to-date
$ ssh aur@aur.archlinux.org/brother-mfc-9325cw.git git remote remove original
ssh: Could not resolve hostname aur.archlinux.org/brother-mfc-9325cw.git: Name or service not known
$ ssh aur@aur.archlinux.org git remote remove original
git: invalid command: git
Try `ssh aur@aur.archlinux.org help` for a list of commands.

How do I properly remove ssh://aur@aur.archlinux.org/brother-mfc-9325cw.git from the git clone url?

Last edited by core_contingency (2019-08-08 00:24:29)

Offline

Board footer

Powered by FluxBB