You are not logged in.

#1 2019-08-11 20:00:35

rsamajdwar
Member
Registered: 2019-08-11
Posts: 3

Display problem in amd ryzen 2500u

I recently installed arch linux with gnome and there is display issues like screen flickering and tearing. I tried almost every solution given to the forums and those didn't work. Can anyone please help me?

Offline

#2 2019-08-11 20:47:09

loqs
Member
Registered: 2014-03-06
Posts: 8,225

Re: Display problem in amd ryzen 2500u

To avoid making suggestions you have already tried that did not work please list what you have tried so far plus the log and diagnostics you have obtained.

Offline

#3 2019-08-12 05:38:04

rsamajdwar
Member
Registered: 2019-08-11
Posts: 3

Re: Display problem in amd ryzen 2500u

loqs wrote:

To avoid making suggestions you have already tried that did not work please list what you have tried so far plus the log and diagnostics you have obtained.

Sorry it was my bad I didn't give the details. I am actually pretty new in case of these forum stuffs and also in arch linux. I tried the solutions given in amdgpu archwiki page. Like setting the dpm off, dc off, setting the tearfree option on. None of them worked.
This is my xorg log https://pastebin.com/jiWLBLa1
dmesg output https://pastebin.com/qZPE3iT6
journalctl -k output https://pastebin.com/kAhEf7yU
This my screen.
https://ibb.co/0K9Bfgx
Btw If it is somehow related, I also use Ubuntu and haven't faced these kinds of problems there.

Last edited by rsamajdwar (2019-08-12 05:42:23)

Offline

#4 2019-08-12 11:56:16

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,148

Re: Display problem in amd ryzen 2500u

First, configure Early microcode updating .

Also try with xf86-video-amdgpu (just install it) instead of modesetting driver.

There are several messages in logs(see below)  that hint to low level problems.
Brand and model of Motherboard and/or system ?
Are you using latest uefi / bios firmware ?

[    0.146946] APIC: Switch to symmetric I/O mode setup
[    0.147845] AMD-Vi: [Firmware Bug]: : IOAPIC[4] not in IVRS table
[    0.147845] AMD-Vi: [Firmware Bug]: : IOAPIC[5] not in IVRS table
[    0.147846] AMD-Vi: [Firmware Bug]: : No southbridge IOAPIC found
[    0.147846] AMD-Vi: Disabling interrupt remapping
[    0.147851] Switched APIC routing to physical flat.
[   22.277209] amdgpu 0000:02:00.0: remove_conflicting_pci_framebuffers: bar 0: 0xd0000000 -> 0xdfffffff
[   22.277211] amdgpu 0000:02:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xe0000000 -> 0xe01fffff
[   22.277213] amdgpu 0000:02:00.0: remove_conflicting_pci_framebuffers: bar 5: 0xe0800000 -> 0xe087ffff

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2019-08-12 14:06:30

rsamajdwar
Member
Registered: 2019-08-11
Posts: 3

Re: Display problem in amd ryzen 2500u

Lone_Wolf wrote:

First, configure Early microcode updating .

Also try with xf86-video-amdgpu (just install it) instead of modesetting driver.

There are several messages in logs(see below)  that hint to low level problems.
Brand and model of Motherboard and/or system ?
Are you using latest uefi / bios firmware ?

[    0.146946] APIC: Switch to symmetric I/O mode setup
[    0.147845] AMD-Vi: [Firmware Bug]: : IOAPIC[4] not in IVRS table
[    0.147845] AMD-Vi: [Firmware Bug]: : IOAPIC[5] not in IVRS table
[    0.147846] AMD-Vi: [Firmware Bug]: : No southbridge IOAPIC found
[    0.147846] AMD-Vi: Disabling interrupt remapping
[    0.147851] Switched APIC routing to physical flat.
[   22.277209] amdgpu 0000:02:00.0: remove_conflicting_pci_framebuffers: bar 0: 0xd0000000 -> 0xdfffffff
[   22.277211] amdgpu 0000:02:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xe0000000 -> 0xe01fffff
[   22.277213] amdgpu 0000:02:00.0: remove_conflicting_pci_framebuffers: bar 5: 0xe0800000 -> 0xe087ffff

My device is acer swift 3, sf315-41, ryzen 2500u
I installed amd-ucode and turned on the microcode by setting the initrd as amd-ucode.img but after reboot and selecting arch linux from refind the screen is stucked on "acer" logo.

Offline

#6 2019-08-12 23:40:52

waylaxr
Member
Registered: 2019-08-12
Posts: 1

Re: Display problem in amd ryzen 2500u

@rsamajdwar  I used to use Manjaro before I switched to arch, and I on my old laptop, I had a ryzen 2500u. This thread helped me getting it working:
https://forum.manjaro.org/t/amd-ryzen-p … ixes/55533

It was like almost a year ago that I had to deal with all this, so I don't remember what the exact fix was, but I know it was in that thread on the manjaro forum.  (i think it was the zenstates disable c-6 thing in my case...)

Try using the fallback kernel and see if it boots past the acer screen. good luck

Last edited by waylaxr (2019-08-12 23:42:31)

Offline

Board footer

Powered by FluxBB