You are not logged in.

#1 2019-08-17 01:54:54

Registered: 2019-08-17
Posts: 1

docker-credential-secretservice troubles [Solved]

Is anyone successfully using this? I installed the package from the AUR after seeing compose up fail saying it needed this service.

Recently came back to Arch, need a little help getting my development environment working.

Here is the message after I got it installed.

Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/docker/credentials/", line 80, in _execute
    [self.exe, subcmd], input=data_input, env=env,
  File "/usr/lib/python3.7/", line 395, in check_output
  File "/usr/lib/python3.7/", line 487, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['/usr/bin/docker-credential-secretservice', 'list']' returned non-zero exit status 1.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/docker-compose", line 11, in <module>
    load_entry_point('docker-compose==1.24.1', 'console_scripts', 'docker-compose')()
  File "/usr/lib/python3.7/site-packages/compose/cli/", line 71, in main
  File "/usr/lib/python3.7/site-packages/compose/cli/", line 127, in perform_command
    handler(command, command_options)
  File "/usr/lib/python3.7/site-packages/compose/cli/", line 287, in build
    parallel_build=options.get('--parallel', False),
  File "/usr/lib/python3.7/site-packages/compose/", line 386, in build
  File "/usr/lib/python3.7/site-packages/compose/", line 368, in build_service, pull, force_rm, memory, build_args, gzip)
  File "/usr/lib/python3.7/site-packages/compose/", line 1084, in build
  File "/usr/lib/python3.7/site-packages/docker/api/", line 261, in build
  File "/usr/lib/python3.7/site-packages/docker/api/", line 308, in _set_auth_headers
    auth_data = self._auth_configs.get_all_credentials()
  File "/usr/lib/python3.7/site-packages/docker/", line 302, in get_all_credentials
    for k in store.list().keys():
  File "/usr/lib/python3.7/site-packages/docker/credentials/", line 71, in list
    data = self._execute('list', None)
  File "/usr/lib/python3.7/site-packages/docker/credentials/", line 93, in _execute
    raise errors.process_store_error(e, self.program)
docker.credentials.errors.StoreError: Credentials store docker-credential-secretservice exited with "Error from list function in secretservice_linux.c likely due to error in secretservice library".

UPDATE: Solved - my /home directory I migrated had a bad cache in ~/.docker

Last edited by typ3def (2019-08-17 02:01:42)


Board footer

Powered by FluxBB