You are not logged in.

#1 2019-08-18 06:21:50

Hamish
Member
From: Rural Alberta, Canada
Registered: 2013-02-26
Posts: 42
Website

Xfce 4.14 breaks with Zaphod Mode

I have a custom X11 setup which allows me to use Zaphod Mode, making each of my two monitors display separate X screens. My xorg.conf file is included below:

Section "ServerLayout"
        Identifier      "Default Layout"
	Screen	0	"Screen0" 0 0
	Screen	1	"Screen1" LeftOf "Screen0"
EndSection

Section "Monitor"
	Identifier  "RightHead"
	Option	    "ModelName" "Acer X223w LCD"
	Option	    "Position" "0 0"
        Option      "Primary" "true"
EndSection

Section "Monitor"
	Identifier  "LeftHead"
	Option	    "ModelName" "Samsung SyncMaster 753DF CRT"
	Option	    "Position" "0 0"
        Option      "Primary" "false"
EndSection

Section "Device"
	Identifier  "Card0"
        Driver "radeon"
	Screen 0
EndSection

Section "Device"
	Identifier  "Card1"
        Driver  "radeon"
	Screen 1
EndSection

Section "Screen"
	Identifier "Screen0"
	Device "Card0"
	Monitor "RightHead"
        Option  "ZaphodHeads" "DVI-0"
        DefaultDepth 24 
EndSection

Section "Screen"
	Identifier "Screen1"
	Device "Card1"
	Monitor "LeftHead"
        Option  "ZaphodHeads" "DisplayPort-0"
        DefaultDepth 24
EndSection

Section "InputClass"                                                            
        Identifier "Keyboard Defaults"                                          
        MatchIsKeyboard "yes"                                                   
        Option "XkbOptions" "terminate:ctrl_alt_bksp"                           
EndSection

After installing my updates this evening which included Xfce 4.14 I was greeted by this on my two screens at launch (primary on the right):
IMG-20190817-222934.jpg IMG-20190817-231723.jpg

After some troubleshooting I found that turning off display compositing from Window Manager Tweaks gets around this issue. However, there are still other problems.

The xfce4-panel no longer respects the boundaries of my second head, with my third panel on the second head hiding off of the screen, most actions from the panel actually taking place on the primary head with the exception of launching applications, and the panel settings being glitchy when it comes to screen selection and crashing when launched from the second head.

Windows also only maximize to size of second head (in this case 1024x768) even on the primary (1680x1050):
Screenshot-2019-08-17-23-27-58.png

For the moment I am operating Xfce with my xorg.conf and second head disabled. You will notice that the icon positions of xfdesktop vary between the two modes (Zaphod Mode on the right):
Screenshot-2019-08-17-23-49-56.png Screenshot-2019-08-17-23-27-52.png

For reference, this is the expected behaviour from the previous version of Xfce packaged by Arch:
August-2019-Desktop.png

Launching Blackbox with Zaphod Mode in place works as expected, so this is definitely seems to be a regression in the latest version of Xfce.


Thank you,
Hamish Paul Wilson

Offline

#2 2019-08-18 09:20:30

newbie1962
Member
From: italy
Registered: 2012-07-24
Posts: 135

Re: Xfce 4.14 breaks with Zaphod Mode


hp-envy dv7

Offline

#3 2019-08-18 14:42:23

Hamish
Member
From: Rural Alberta, Canada
Registered: 2013-02-26
Posts: 42
Website

Re: Xfce 4.14 breaks with Zaphod Mode

Good call newbie1962, setting the vblank mode to "blank" or "xpresent" does indeed seem to get around the first issue.

The other quirks and issues remain. That said, I now find that the problem with maximizing applications only appears after my third panel hides on the second screen. It seems to launch out of bounds on first launch, forcing me to move it back to the primary head with the Output toggle in the panel settings and then drag it over to the second and reset the Output toggle.

Launching the panel settings from the second head results in this error as I said before:
Screenshot-2019-08-18-08-40-39.png

Last edited by Hamish (2019-08-18 14:54:46)


Thank you,
Hamish Paul Wilson

Offline

#4 2019-08-18 14:54:32

Hamish
Member
From: Rural Alberta, Canada
Registered: 2013-02-26
Posts: 42
Website

Re: Xfce 4.14 breaks with Zaphod Mode

For clarity, I should also mention that the "glx" vblank mode worked fine with zaphod mode disabled.

It may also be relevant to mention that the xfce4-display-settings now launches with zaphod mode enabled. This did not use to be the case in previous versions, where it would error out.

I have also discovered that all panel actions regarding menus only take place in a 1024x768 area of the primary head, regardless of which screen the panel is on.

EDIT: I have also had the maximize window issue reappear in other contexts, although I have not isolated the cause.

EDIT 2: Like with the screen maximization, the issue with the panel menus is also intermittent. Using the panel on the second head is one cause.

Last edited by Hamish (2019-08-18 17:44:36)


Thank you,
Hamish Paul Wilson

Offline

#5 2019-08-20 05:37:38

Hamish
Member
From: Rural Alberta, Canada
Registered: 2013-02-26
Posts: 42
Website

Re: Xfce 4.14 breaks with Zaphod Mode

So as an experiment I tried switching the window manager to Openbox, and that does indeed seem stop the issues with windows only being able to maximize to the resolution of the second head as well as resetting the desktop icons to their proper positions.

It does not seem to have any effect on the problems with my third panel though. There seem to be separate bugs in both xfwm4 and xfce4-panel at play.


Thank you,
Hamish Paul Wilson

Offline

#6 2019-08-20 15:09:23

Hamish
Member
From: Rural Alberta, Canada
Registered: 2013-02-26
Posts: 42
Website

Re: Xfce 4.14 breaks with Zaphod Mode

Okay, the main issue with xfwm4 seems to be due to some confusion with having two different resolutions on the two monitors. Changing the resolution on the primary and then changing it back to the default 1680x1050 seems to resolve all of the problems with it.

I have created the following script to be executed on login or called when needed:

#!/bin/bash
xrandr --output DVI-0 --mode 1600x1200
xrandr --output DVI-0 --mode 1680x1050

I now have three workarounds for my problems:
1. Setting the vblank mode to "blank" or "xpresent" bypasses the issues with "glx".
2. Changing and then changing back the resolution resolves the issues with window maximization and desktop icon position.
3. Since xfce4-panel does not like my second head I have now setup an lxpanel instead.

I will see if I can cobble together a bug report, now that I seem to have isolated at least one of the issues.

Last edited by Hamish (2019-08-20 15:31:09)


Thank you,
Hamish Paul Wilson

Offline

Board footer

Powered by FluxBB