You are not logged in.

#1 2019-08-20 20:14:24

justdanyul
Member
Registered: 2011-09-29
Posts: 83

Problem with intel RST

Hi all,

I just build a new box for my other half, which has a pair of NVME drives installed. Now, I'm planning on running Linux on this when she isn't looking, I configured these as a RAID-0 volume in the BIOS, and I was planning on just creating a little partition for me to mock around with Linux on.

However, even though the bios reports the Intel RST volume is correctly configured (and, the windows 10 is successfully running on the volume), I got problems getting it visible to the Arch Linux Live media. I've tried loading the dm-mod and raid0 modules, but I can't for the life of me get the volume to show up in /dev , lsblk or anywhere really.

when doing a mdadm --detail-platform , it tells me no devices are connected to the RST controller (so, basically, it's having a disagreement with the bios on that one).

I'm a bit stuck for the next steps. And I'd love to hear what you guys think.

Some hardware info (if that is useful):

9900K + Gigabyte Aorus Master z390 motherboard
x2 Samsung EVO 970 NVME SSD's

(i presume gfx cards and memory wont matter)

Last edited by justdanyul (2019-08-20 20:40:05)

Offline

#2 2019-08-21 08:06:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,256

Re: Problem with intel RST

According to https://wiki.archlinux.org/index.php/RA … ementation you will want to use dmraid for this, alternatively, just use software RAID instead, keep the disks in AHCI mode on a BIOS/firmware level.

FWIW I don't think fakeraid works with nvme drives, at least I haven't encountered a case where this worked properly, at least for linux.

Last edited by V1del (2019-08-21 08:23:18)

Offline

#3 2019-08-21 15:03:59

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,188

Re: Problem with intel RST

While it's from before nvme drives, https://wiki.archlinux.org/index.php/In … _Fake_RAID seems to have useful info.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2019-08-23 11:00:37

justdanyul
Member
Registered: 2011-09-29
Posts: 83

Re: Problem with intel RST

Thanks for the replies guys. I been through both the above links, and intel official documentation for RST on Linux. And have concluded that fakeraid currently doesn't play nicely with Linux when using NVMEs, at least not on my motherboard. To confirm, its not just me being a wally, I even tried using RST with a couple of SATA disks on the same motherboard and it works a charm.

Offline

Board footer

Powered by FluxBB