You are not logged in.

#1 2019-08-21 04:48:07

21violins
Member
Registered: 2017-07-15
Posts: 7

fcitx running but not functional in Gnome

Seems like there's been a lot of threads posted by people with similar problems, but I've tried everything I've come across and nothing has worked. I've put the lines

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

everywhere I can think of, to no avail.

Here's the output of my fcitx-diagnose:

# System Info:
1.  `uname -a`:

        Linux TolEressea 5.2.9-arch1-1-ARCH #1 SMP PREEMPT Fri Aug 16 11:29:43 UTC 2019 x86_64 GNU/Linux

2.  `lsb_release`:

    `lsb_release` not found.

3.  `/etc/lsb-release`:

    `/etc/lsb-release` not found.

4.  `/etc/os-release`:

        NAME="Arch Linux"
        PRETTY_NAME="Arch Linux"
        ID=arch
        BUILD_ID=rolling
        ANSI_COLOR="0;36"
        HOME_URL="https://www.archlinux.org/"
        DOCUMENTATION_URL="https://wiki.archlinux.org/"
        SUPPORT_URL="https://bbs.archlinux.org/"
        BUG_REPORT_URL="https://bugs.archlinux.org/"
        LOGO=archlinux

5.  Desktop Environment:

    Desktop environment is `gnome3`.

6.  Bash Version:

        BASH_VERSION='5.0.7(1)-release'

# Environment:
1.  DISPLAY:

        DISPLAY=':1'

2.  Keyboard Layout:

    1.  `setxkbmap`:

            xkb_keymap {
            	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
            	xkb_types     { include "complete"	};
            	xkb_compat    { include "complete"	};
            	xkb_symbols   { include "pc+us+us:2+inet(evdev)"	};
            	xkb_geometry  { include "pc(pc105)"	};
            };

    2.  `xprop`:

        `xprop` not found.

3.  Locale:

    1.  All locale:

            C
            en_US.utf8
            POSIX
            zh_TW.utf8

    2.  Current locale:

            LANG=en_US.UTF-8
            LC_CTYPE="en_US.UTF-8"
            LC_NUMERIC=en_US.UTF-8
            LC_TIME=en_US.UTF-8
            LC_COLLATE="en_US.UTF-8"
            LC_MONETARY=en_US.UTF-8
            LC_MESSAGES="en_US.UTF-8"
            LC_PAPER=en_US.UTF-8
            LC_NAME="en_US.UTF-8"
            LC_ADDRESS="en_US.UTF-8"
            LC_TELEPHONE="en_US.UTF-8"
            LC_MEASUREMENT=en_US.UTF-8
            LC_IDENTIFICATION="en_US.UTF-8"
            LC_ALL=

4.  Directories:

    1.  Home:

            /home/reflynn

    2.  `${XDG_CONFIG_HOME}`:

        Environment variable `XDG_CONFIG_HOME` is not set.

        Current value of `XDG_CONFIG_HOME` is `~/.config` (`/home/reflynn/.config`).

    3.  Fcitx Settings Directory:

        Current fcitx settings directory is `~/.config/fcitx` (`/home/reflynn/.config/fcitx`).

5.  Current user:

    The script is run as reflynn (1000).

# Fcitx State:
1.  executable:

    Found fcitx at `/usr/bin/fcitx`.

2.  version:

    Fcitx version: `4.2.9.5`

3.  process:

    Found 2 fcitx processes:

         1377 fcitx
         1398 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` works properly.

5.  DBus interface:

    Using `dbus-send` to check dbus.

    Owner of DBus name `org.fcitx.Fcitx` is `:1.64`.

    PID of DBus name `org.fcitx.Fcitx` owner is `1377`.

# Fcitx Configure UI:
1.  Config Tool Wrapper:

    Found fcitx-configtool at `/usr/bin/fcitx-configtool`.

2.  Config GUI for gtk2:

    **Config GUI for gtk2 not found.**

3.  Config GUI for gtk3:

    Found `fcitx-config-gtk3` at `/usr/bin/fcitx-config-gtk3`.

4.  Config GUI for kde:

    **`kcmshell4` not found.**

# Frontends setup:
## Xim:
1.  `${XMODIFIERS}`:

    Environment variable XMODIFIERS is set to "@im=fcitx" correctly.
    Xim Server Name from Environment variable is fcitx.

2.  XIM_SERVERS on root window:

    **`xprop` not found.**

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    Environment variable QT_IM_MODULE is set to "fcitx" correctly.

2.  qt5 - `${QT_IM_MODULE}`:

    Environment variable QT_IM_MODULE is set to "fcitx" correctly.

3.  Qt IM module files:

    Found fcitx im module for Qt5: `/usr/lib/qt/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so`.
    Found fcitx qt module: `/usr/lib/fcitx/qt/libfcitx-quickphrase-editor5.so`.
    Found fcitx qt module: `/usr/lib/fcitx/qt/libfcitx-libpinyin-dictmanager.so`.
    **Cannot find fcitx input method module for Qt4.**

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    Environment variable GTK_IM_MODULE is set to "fcitx" correctly.

2.  `gtk-query-immodules`:

    1.  gtk 2:

        Found `gtk-query-immodules` for gtk `2.24.32` at `/usr/bin/gtk-query-immodules-2.0`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.32

        Found fcitx im modules for gtk `2.24.32`.

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        Found `gtk-query-immodules` for gtk `3.24.10` at `/usr/bin/gtk-query-immodules-3.0`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.24.10

        **Failed to find fcitx in the output of `/usr/bin/gtk-query-immodules-3.0`**

        **Cannot find fcitx im module for gtk 3.**

3.  Gtk IM module cache:

    1.  gtk 2:

        Found immodules cache for gtk `2.24.32` at `/usr/lib/gtk-2.0/2.10.0/immodules.cache`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.32

        Found fcitx im modules for gtk `2.24.32`.

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        Found immodules cache for gtk `3.24.10` at `/usr/lib/gtk-3.0/3.0.0/immodules.cache`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.24.10

        **Failed to find fcitx in immodule cache at `/usr/lib/gtk-3.0/3.0.0/immodules.cache`**

        **Cannot find fcitx im module for gtk 3 in cache.**

4.  Gtk IM module files:

    1.  gtk 2:

        All found Gtk 2 immodule files exist.

    2.  gtk 3:

        All found Gtk 3 immodule files exist.

# Configuration:
## Fcitx Addons:
1.  Addon Config Dir:

    Found fcitx addon config directory: `/usr/share/fcitx/addon`.

2.  Addon List:

    1.  Found 30 enabled addons:

            fcitx-autoeng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-cloudpinyin
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-googlepinyin
            fcitx-imselector
            fcitx-ipc
            fcitx-ipcportal
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-libpinyin
            fcitx-mozc
            fcitx-notificationitem
            fcitx-pinyin
            fcitx-pinyin-enhance
            fcitx-punc
            fcitx-quickphrase
            fcitx-remote
            fcitx-spell
            fcitx-table
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  Found 1 disabled addons:

            fcitx-qw

3.  Addon Libraries:

    All libraries for all addons are found.

4.  User Interface:

    Found 2 enabled user interface addons:

        fcitx-classic-ui
        fcitx-kimpanel-ui

    Kimpanel process:

          879 /usr/bin/gnome-shell

## Input Methods:
1.  Found 6 enabled input methods:

        fcitx-keyboard-us
        pinyin-libpinyin
        shuangpin-libpinyin
        zhuyin-libpinyin
        googlepinyin
        sunpinyin

2.  Default input methods:

    You have a keyboard input method "fcitx-keyboard-us" correctly added as your default input method.

# Log:
1.  `date`:

        Wed 21 Aug 2019 12:42:48 AM EDT

2.  `~/.config/fcitx/log/`:

        total 4
        -rw-r--r-- 1 reflynn reflynn 633 Aug 21 00:06 crash.log

3.  `~/.config/fcitx/log/crash.log`:

        =========================
        FCITX 4.2.9.5 -- Get Signal No.: 11
        Date: try "date -d @1566360362" if you are using GNU date ***
        ProcessID: 7644
        fcitx(+0x17be)[0x55c87f0587be]
        /usr/lib/libc.so.6(+0x3a7e0)[0x7fa4967cf7e0]
        /usr/lib/libdbus-1.so.3(dbus_watch_get_enabled+0x0)[0x7fa4963efea0]
        /usr/lib/fcitx/fcitx-dbus.so(+0x231a)[0x7fa4969f331a]
        /usr/lib/fcitx/fcitx-dbus.so(+0x24f5)[0x7fa4969f34f5]
        /usr/lib/libfcitx-core.so.0(+0x963a)[0x7fa4969b063a]
        /usr/lib/libfcitx-core.so.0(FcitxInstanceRun+0x57)[0x7fa4969b0e07]
        fcitx(+0x113b)[0x55c87f05813b]
        /usr/lib/libc.so.6(__libc_start_main+0xf3)[0x7fa4967bbee3]
        fcitx(+0x11be)[0x55c87f0581be]

Someone please help? Been googling for hours and I'm about ready to throw in the towel and switch to another desktop environment at this point.

Offline

#2 2019-08-21 07:42:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,771

Re: fcitx running but not functional in Gnome

If you aren't running GNOME on xorg I find it highly unlikely for this to work, so you should ensure you are starting a xorg, as opposed to a default wayland session.

Offline

#3 2019-08-21 11:33:37

seth
Member
Registered: 2012-09-03
Posts: 12,895

Re: fcitx running but not functional in Gnome

https://github.com/fcitx/fcitx/issues/230 (chinese)

edit: fixed link/stray token

Last edited by seth (2019-08-22 05:28:42)

Offline

#4 2019-08-21 12:33:43

Omar007
Member
Registered: 2015-04-09
Posts: 333

Re: fcitx running but not functional in Gnome

Alternatively, you could check out IBus instead of fcitx. Gnome should have full support for that on both Xorg and Wayland.

Offline

#5 2019-08-21 22:45:24

21violins
Member
Registered: 2017-07-15
Posts: 7

Re: fcitx running but not functional in Gnome

V1del wrote:

If you aren't running GNOME on xorg I find it highly unlikely for this to work, so you should ensure you are starting a xorg, as opposed to a default wayland session.

I am aware of this and have double checked that I am using X11 and not Wayland. @Seth: appreciate the link but my problem isn't Wayland smile

Omar007 wrote:

Alternatively, you could check out IBus instead of fcitx. Gnome should have full support for that on both Xorg and Wayland.

IBus has terrible support for traditional Chinese characters, else I would use it. I appreciate the suggestion though.

If anyone has any idea what might be going wrong, please let me know.... otherwise it looks like it's gonna be a Gnome uninstall for me.

EDIT/UPDATE: I decided to try out IBus anyways....and I have a very similar problem. IBus is running but will not allow me to input Chinese (I'll be in Chinese input mode but it'll only type English), with the exception of bopomofo input modes, which will let me type. I'm not too keen on learning the very unintuitive bopomofo layout and would very much prefer to have Pinyin work. Anyone have any ideas? (I have already generated Taiwan and China UTF-8 locales, by the way.)

Last edited by 21violins (2019-08-22 00:37:10)

Offline

#6 2019-08-22 05:34:34

seth
Member
Registered: 2012-09-03
Posts: 12,895

Re: fcitx running but not functional in Gnome

Because of

        fcitx(+0x17be)[0x55c87f0587be]
        /usr/lib/libc.so.6(+0x3a7e0)[0x7fa4967cf7e0]
        /usr/lib/libdbus-1.so.3(dbus_watch_get_enabled+0x0)[0x7fa4963efea0]
        /usr/lib/fcitx/fcitx-dbus.so(+0x231a)[0x7fa4969f331a]
        /usr/lib/fcitx/fcitx-dbus.so(+0x24f5)[0x7fa4969f34f5]
        /usr/lib/libfcitx-core.so.0(+0x963a)[0x7fa4969b063a]
        /usr/lib/libfcitx-core.so.0(FcitxInstanceRun+0x57)[0x7fa4969b0e07]
        fcitx(+0x113b)[0x55c87f05813b]
        /usr/lib/libc.so.6(__libc_start_main+0xf3)[0x7fa4967bbee3]
        fcitx(+0x11be)[0x55c87f0581be]

a) did you reboot after the last update?
b) did you try downgrading dbus?

Also: did your setup work before and is this actually isolated to GNOME?

Offline

#7 2019-11-08 12:19:45

aliyuchang33
Member
Registered: 2018-11-03
Posts: 4

Re: fcitx running but not functional in Gnome

Seems like it also occurred on my computer

FCITX 4.2.9.5 -- Get Signal No.: 11
Date: try "date -d @1573215136" if you are using GNU date ***
ProcessID: 96651
fcitx(+0x17be)[0x55d075cb07be]
/usr/lib/libc.so.6(+0x3bfb0)[0x7f75b246dfb0]
/usr/lib/libc.so.6(+0xa7ff1)[0x7f75b24d9ff1]
/usr/lib/fcitx/fcitx-cloudpinyin.so(+0x6254)[0x7f75ae576254]
/usr/lib/fcitx/fcitx-cloudpinyin.so(+0x3472)[0x7f75ae573472]
/usr/lib/libfcitx-core.so.0(+0x963a)[0x7f75b265263a]
/usr/lib/libfcitx-core.so.0(FcitxInstanceRun+0x57)[0x7f75b2652e07]
fcitx(+0x113b)[0x55d075cb013b]
/usr/lib/libc.so.6(__libc_start_main+0xf3)[0x7f75b2459153]
fcitx(+0x11be)[0x55d075cb01be]

plasma 5.17.2-1,  glibc 2.30-2,  fcitx 4.2.9.6-2

Offline

#8 2019-11-08 12:38:35

seth
Member
Registered: 2012-09-03
Posts: 12,895

Re: fcitx running but not functional in Gnome

That's not the sama backtrace at all… it crashes in https://www.archlinux.org/packages/comm … oudpinyin/

Offline

Board footer

Powered by FluxBB