You are not logged in.

#1 2019-08-27 19:57:06

VesterDe
Member
Registered: 2018-08-28
Posts: 3

HDMI not detected as possible output for audio

Hello there,

I can't seem to convince my laptop my HDMI port exists for the purpose of audio...

Audio otherwise works just fine, headphones work, speakers work etc... But the HDMI port is simply not available as an output option (via pavucontrol, for instance).

Note also that video works via HDMI, as soon as I plug it in my desktop is on the other screen, so it's just audio.

I ran alsa-info.sh and here's my output: http://alsa-project.org/db/?f=db91b8810 … f8913ce2ee

Here's lsmod | grep snd

snd_sof_intel_hda_common    73728  1 sof_pci_dev
snd_sof_intel_hda      20480  1 snd_sof_intel_hda_common
snd_sof_intel_byt      28672  1 sof_pci_dev
snd_sof_intel_ipc      20480  1 snd_sof_intel_byt
snd_sof               118784  4 snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_intel_ipc,sof_pci_dev
snd_sof_xtensa_dsp     16384  1 sof_pci_dev
snd_soc_skl           118784  0
snd_soc_hdac_hda       24576  2 snd_sof_intel_hda_common,snd_soc_skl
snd_hda_ext_core       36864  4 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_soc_skl_ipc        73728  1 snd_soc_skl
snd_soc_sst_ipc        20480  1 snd_soc_skl_ipc
snd_soc_sst_dsp        40960  1 snd_soc_skl_ipc
snd_soc_acpi_intel_match    28672  3 snd_sof_intel_hda_common,sof_pci_dev,snd_soc_skl
snd_soc_acpi           16384  3 snd_soc_acpi_intel_match,sof_pci_dev,snd_soc_skl
snd_soc_core          290816  4 snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl
snd_compress           28672  1 snd_soc_core
snd_hda_codec_realtek   126976  1
ac97_bus               16384  1 snd_soc_core
snd_hda_codec_generic    94208  1 snd_hda_codec_realtek
snd_pcm_dmaengine      16384  1 snd_soc_core
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_intel          53248  6
snd_hda_codec         159744  4 snd_hda_codec_generic,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
snd_hda_core          102400  9 snd_hda_codec_generic,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_hwdep              20480  1 snd_hda_codec
snd_pcm               135168  11 snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
snd_timer              40960  1 snd_pcm
snd                   110592  19 snd_hda_codec_generic,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
soundcore              16384  1 snd

Here's lspci -nn |grep -i audio

00:1f.3 Audio device [0403]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)

And finally, cat /proc/asound/card0/codec* | grep Codec
says this

Codec: Realtek ALC295

If there's any other info I can provide, let me know.

And many thanks to anyone taking the time to help.

Offline

#2 2019-08-27 22:51:00

theodore
Member
Registered: 2008-09-09
Posts: 104

Re: HDMI not detected as possible output for audio

Did you test this section https://wiki.archlinux.org/index.php/Ad … s_not_work in the wiki?

Also try to see if you get any help from this thread https://bbs.archlinux.org/viewtopic.php?id=234683 and possibly provide the output from the commands mentioned there.

Offline

Board footer

Powered by FluxBB