You are not logged in.

#1 2019-08-29 10:13:00

Blackmine57
Member
Registered: 2019-08-29
Posts: 3

[solved] Touchpad doesn't works

Hey !
First I'm sorry if my English is bad hmm

I installed Archlinux on my HP Probook x360 g1 11 EE (I think It's not useless to specify it because he's known to (I don't know if it's the good word hmm) to block the installation of Grub, I needed to install Windows next to Archlinux for use Windows boot manager to start rEFInd, without Windows Boot Manager it says I haven't OS, and I'm not the only person who have a problem with this PC).
So, my touchpad doesn't works on Archlinux, but it work on Windows / bios.
I've already install xf86-input-synaptics and copy it to /etc/X11/xorg.conf but it doesn't do anything.
Here's the result of

dmesg | grep -i Synaptics

[    5.900249] psmouse serio1: elantech: Synaptics capabilities query result 0x10, 0x15, 0x0c. 

Of

lsusb

:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 04f2:b56d Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and of

xinput

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN1001:00 04F3:22D6                     id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ HP Wide Vision HD: HP Wide Visi           id=9    [slave  keyboard (3)]
    ↳ ELAN1001:00 04F3:22D6                     id=11   [slave  keyboard (3)]
    ↳ Intel Virtual Button driver               id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                       id=14   [slave  keyboard (3)]
    ↳ HP WMI hotkeys               

One's said to me to add

i8042.noloop i8042.nomux i8042.nopnp i8042.reset

in rEFInds 'settings, so my /boot/refind_linux.conf is

"Boot with standard options" "ro root=PARTUUID=(l'uuid) rw quiet splash i8042.reset i8042.nomux i8042.nopnp i8042.noloop"

And the Archlinux part of /boot/EFI/refind/refind/refind.conf

menuentry "Arch Linux" {
    icon     /EFI/refind/icons/os_arch.png
    volume   "Arch Linux"
    loader   /boot/vmlinuz-linux
    initrd   /boot/initramfs-linux.img
    options  "root=/dev/sda1 rw quiet splash i8042.reset i8042.nomux i8042.nopnp i8042.noloop"
    submenuentry "Boot using fallback initramfs" {
        initrd /boot/initramfs-linux-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "systemd.unit=multi-user.target"
    }
    disabled
}

PS : I can use a mouse and my touchscreen, but I need the touchpad, it's not useless tongue
PPS : When I go to the touchpad settings, it says I haven't any touchpad.

If you need more things don't hesitate to ask them to me smile
Thanks !

Have a good day, or Have a nice day, I don't know x)

Last edited by Blackmine57 (2019-08-29 11:19:07)

Offline

#2 2019-08-29 10:44:03

MattMatt2
Member
Registered: 2019-03-11
Posts: 8

Re: [solved] Touchpad doesn't works

First of all, please note that xf86-input-synaptics is no longer actively developed . You should use libinput instead. Also, you can try to reload the psmouse module with proto=imps:

# modprobe -r psmouse
# modprobe psmouse proto=imps

This should make it work again, but without multitouch gestures, sadly sad. I've got the same problem, I'll insert a link your message into my post and vice-versa to avoid having two same subjects.

PS: Are you using loRdi? If so, you can install GRUB without any problem. This guide can help you (worked for me, even if now I rather check the wiki).

Offline

#3 2019-08-29 11:00:34

Blackmine57
Member
Registered: 2019-08-29
Posts: 3

Re: [solved] Touchpad doesn't works

Oooh my bad, thank you very much smile It's work big_smile I feel... stupid hmm
And yes I used loRdi, but when I executed "efibootmgr" I always had an error (i don't remember it), but when I want to install ubuntu / lubuntu [...] the install always crash at the grub installation tongue
On other PC I never have any problems, it's only on this PC.
Do you use the same PC ?
And thanks smile Again <3


EDIT : It's work but it's "stop to work" after reboot x) I'm going to create a script for execute command after starting x)

Last edited by Blackmine57 (2019-08-29 11:18:54)

Offline

#4 2019-08-29 11:50:25

MattMatt2
Member
Registered: 2019-03-11
Posts: 8

Re: [solved] Touchpad doesn't works

Yes, I use it as well smile (but with only arch). Don't think my solution is a real solution, it's just a workaround before I get a real solution. And don't create a startup script. It's a dirty solution. The best is to tell the kernel to load module psmouse with proto=imps instead of without. So you need to create a file in /etc/modprobe.d/ called psmouse.conf and write inside of it "options psmouse proto=imps":

sudo echo 'options psmouse proto=imps' > /etc/modprobe.d/psmouse.conf

Then you are done wink
EDIT:Corrected the error optionS instead of option. Thanks.

Last edited by MattMatt2 (2019-08-29 12:32:55)

Offline

#5 2019-08-29 12:08:28

Blackmine57
Member
Registered: 2019-08-29
Posts: 3

Re: [solved] Touchpad doesn't works

Oh okay smile gg x)
Just one thing : it's optionS x)
Thanks ! big_smile
Have a good day smile

Offline

#6 2019-08-30 16:41:58

MattMatt2
Member
Registered: 2019-03-11
Posts: 8

Re: [solved] Touchpad doesn't works

Creating file /etc/modprobe.d/elan.conf with "elantech_smbus=0 synaptics_intertouch=0" restored everything for me (now my touchpad is recognized by KDE system configurator, I've got multitouch and my old configuration back), making my workaround deprecated. You can remove it smile
https://bugs.archlinux.org/task/63525

Offline

Board footer

Powered by FluxBB