You are not logged in.

#1 2019-08-29 15:02:30

Raymo111
Member
Registered: 2019-08-27
Posts: 13

Fingerprint reader on HP Envy x360 not being recognized.

So I found this thread on the hp forum where some guy had the same issue but with a Spectre instead. I ran his script:

#!/bin/bash

# Print DMAR info from dmesg 
sudo dmesg | grep -i dmar


# lspci: show the device from dmesg
echo -e "\n\n"
lspci -vv -s "00:1e.3"


# Search the ACPI device with SPI in it's path
echo -e "\n\n"
for i in `ls /sys/bus/acpi/devices`;
do 
        cd /sys/bus/acpi/devices/$i;
                grep -q -i spi path 2> /dev/null; 
                        if [ $? -eq 0 ]; 
                                then 
                                                echo ====================================; 
                                                                echo "/sys/bus/acpi/devices/$i"; 
                                                                                cat path; 
                                                                                        fi; 
                                                                                        done

And it gave me:

00:1e.3 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO SPI Controller #1 (rev 21)
        Subsystem: Hewlett-Packard Company Sunrise Point-LP Serial IO SPI Controller
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin D routed to IRQ 23
        Region 0: Memory at a4338000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: intel-lpss
lspci: Unable to load libkmod resources: error -12




====================================
/sys/bus/acpi/devices/device:73
\_SB_.PCI0.SPI1
====================================
/sys/bus/acpi/devices/INT3440:00
\_SB_.PCI0.SPI0
====================================
/sys/bus/acpi/devices/SYNA8007:00
\_SB_.PCI0.SPI1.FPNT

meaning my fingerprint reader is connected via PCI.

So all the stuff I could find online deals with usb-connected fingerprint readers, including the wiki. I tried just installing fprintd and running fprintd-enroll but I get list_devices failed: No devices available.

How do I set it up and use it?

Offline

#2 2019-09-06 01:21:38

Swiggles
Member
Registered: 2014-08-02
Posts: 130

Re: Fingerprint reader on HP Envy x360 not being recognized.

Unfortunately the short answer is that it won't work.

Currently there are no drivers available for any of these sensors, because the protocol is still not fully understood and all traffic is encrypted. The difference to standard fingerprint readers is that they do not provide an image, but instead they rather function like smart cards where the system receives an authorization token. So as far as fprintd is concerned it is not even in the scope of the software to get these devices working (don't quote me on this). At least this is the gist of what I learned while trying to get my very similar device working.

Sadly Synaptics wasn't great with their Linux support in the past so I wouldn't hold my breath for any support from that side and so far all topics regarding this sensor family were a dead end.

This does not mean there are no serious attempts to get this device type running, i.e. Validity90 is an interesting project working on very similar devices.

Offline

Board footer

Powered by FluxBB