You are not logged in.

#1 2019-08-31 06:54:50

silnar
Member
Registered: 2011-11-03
Posts: 7

AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

I'm trying to run AMD 5700 XT on ArchLinux, but I always end with a freeze after "Loading initial ramdisk".

I followed tips found in the following places:
- https://wiki.archlinux.org/index.php/AMDGPU
- https://bbs.archlinux.org/viewtopic.php?id=248664
- https://www.reddit.com/r/linux_gaming/c … _a_little/

I've done the following things:

  1. Updated the whole system

    sudo pacman -Syu
  2. Installed the following packages:

    local/llvm-git 10.0.0_r325376.70e158e09e9-1 (mesagit)
    local/lib32-llvm-git 10.0.0_r325130.dc5f805d31f-1 (mesagit)
    
    local/mesa-git 1:19.3.0_devel.114849.0142dcb990e-1 (mesagit)
    local/lib32-mesa-git 1:19.3.0_devel.114849.0142dcb990e-1 (mesagit)
    
    local/vulkan-radeon-git 1:19.3.0_devel.114849.0142dcb990e-1 (mesagit)
    local/lib32-vulkan-radeon-git 1:19.3.0_devel.114849.0142dcb990e-1 (mesagit)
    
    local/xf86-video-amdgpu-git 510.e6fce59-1 (xorg-drivers)
    
    local/mesa-demos 8.4.0-1
  3. Set correct module order in mkinitcpio.conf

    MODULES=(amdgpu radeon)
  4. Set module parameters in modeprobe.d

  5. Installed amdgpu firmware.

    I've tried both:
    - from ~agd5f
    - and from RPM

  6. Tried different kernels:

    local/linux 5.2.11.arch1-1 (base)
    local/linux-mainline 5.3rc6-1
    local/linux-amd-staging-drm-next-git 5.4.857545.b4d857ded1c5-1

I also tried to enable any kind of kernel debugging using methods from this site.

Nothing worked. After seeing 'Loading initial ramdisk' message I need to restart my computer.

What else can I check ?

Last edited by silnar (2019-09-04 20:22:43)

Offline

#2 2019-09-01 07:13:33

gabmus
Member
Registered: 2015-10-11
Posts: 12

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

I'm pretty sure the radeon driver is the one for older cards and you shouldn't use it. I have a working 5700XT and I'm not using it, so I think it's worth a shot.

Offline

#3 2019-09-01 10:50:41

silnar
Member
Registered: 2011-11-03
Posts: 7

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

I found your Early adopter experience with the new Radeon RX 5700XT on Arch Linux article and:
- installed some additional packages like amdvlk
- installed linux-git
- used your linux-firmware-agd5f-radeon-navi10 firmware package
- and updated everything else

I also removed radeon from mkinitcpio modules configuration.

My current configuration is:

GPU packages:
amdvlk 2019.Q3.5-1
clang-git 10.0.0_r325795.7238353da24-1
libclc-git 587.201908311514-1
libdrm-git 2.4.99.r16.g14922551-1
llvm-git 10.0.0_r325795.7238353da24-1
lib32-llvm-git 10.0.0_r325800.a6bef738bf1-1
llvm-libs-git 10.0.0_r325795.7238353da24-1
mesa-git 1:19.3.0_devel.114992.3664a6600eb-1
lib32-mesa-git 1:19.3.0_devel.114992.3664a6600eb-1
opencl-mesa-git 1:19.3.0_devel.114992.3664a6600eb-1
vulkan-mesa-layer-git 1:19.3.0_devel.114992.3664a6600eb-1
vulkan-radeon-git 1:19.3.0_devel.114992.3664a6600eb-1
lib32-vulkan-radeon-git 1:19.3.0_devel.114992.3664a6600eb-1
xf86-video-amdgpu-git 510.e6fce59-1
linux-amd-staging-drm-next-git 5.4.857604.9c9284f9cee9-1
linux-firmware-agd5f-radeon-navi10 2019.08.26.14.36-1

Firmware packages:
linux-firmware-agd5f-radeon-navi10 2019.08.26.14.36-1

mkinicpio.conf - modules config:
MODULES=(amdgpu)

Kernels:
linux 5.2.11.arch1-1
linux-lts 4.19.69-1
linux-mainline 5.3rc6-1
linux-git 5.3rc6.r240.geea173097dfb-1
linux-amd-staging-drm-next-git 5.4.857604.9c9284f9cee9-1

I tried to run all above kernels but every of them is freezing after 'Loading initial ramdisk'.

I also tried 'module_blacklist=radeon' - didn't help.

Only when I add 'acpi=off' computer restarts after 'Loading initial ramdisk' big_smile

Offline

#4 2019-09-01 13:19:02

gabmus
Member
Registered: 2015-10-11
Posts: 12

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

Does your cpu have an integrated gpu? If so you should try booting without the dedicated one.  In my experience errors solved with acpi=off have more to do with something else in the system. You should also try to update your bios.

Offline

#5 2019-09-01 20:31:04

silnar
Member
Registered: 2011-11-03
Posts: 7

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

I have


CPU has integrated gpu.

I have the newest version of BIOS (ver. P4.10 from 2019.08.21)

When I set 'Primary Graphics Adapter' in Chipset configuration to:

  • 'Onboard' and use 'linux' kernel everything works ok,

  • 'PCI Express' and use 'linux-git' or 'linux-amd-staging-drm-next-git' kernel, it freezes during boot.
    (According to this thread I'm disabling integrated gpu this way.
    'Primary Graphics Adapter' is set to 'PCI Express', 'Share memory' is set to 'Auto' and 'IGPU Multi-Monitor' is disabled.)

I also tried to boot with 'module_blacklist=i915' kernel parameter with no success.

Offline

#6 2019-09-02 07:21:22

gabmus
Member
Registered: 2015-10-11
Posts: 12

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

In the past I've had some issues with the igpu preventing my system from booting. Although this doesn't look 100% like it, maybe try restoring the bios to default.
Also, I'm not sure if it could be related, but is your install uefi or legacy? What about your bootloader? Are you using GRUB or something else?

Offline

#7 2019-09-02 19:06:53

silnar
Member
Registered: 2011-11-03
Posts: 7

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

I've restored bios to default (via 'Clear CMOS' button), but it didn't help.

It seems to be uefi.
('/sys/firmware/efi' directory exists, and 'efivar --list' returns list of variables)

I'm using GRUB.

Offline

#8 2019-09-03 15:17:53

gabmus
Member
Registered: 2015-10-11
Posts: 12

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

Have you tried removing the 5700XT from your PC? Does it boot this way?

Offline

#9 2019-09-04 06:40:36

silnar
Member
Registered: 2011-11-03
Posts: 7

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

Well, not in the last week, but earlier I was working without any external GPU card on this PC for at least a year and there was no problem.
I also had GTX 1060 for a couple of months and it was also working fine.

I don't remove GPU, because I thought that setting 'Primary Graphics Adapter' to 'Onboard' does similar thing.

Additionaly when I set 'Primary Graphics Adapter' to 'Onboard' everything works fine.
Then RX5700XT is even visible in 'lspci', but I think it's not used.

I tried to boot current ArchLinux, Ubuntu and Sysrescuecd from pendrive, but
- every of them freezed when 'Primary Graphics Adapter' was set to 'PCI Express'
- and worked ok when it was set to 'Onboard'

I wonder how GRUB UI  is able to use the AMD card to show itself, and why kernel can't do the same...

Offline

#10 2019-09-04 08:38:49

gabmus
Member
Registered: 2015-10-11
Posts: 12

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

I'd install Arch fresh at this point. I do have a working 5700XT reference card from Sapphire, and apart from needing some bleeding edge software as I already explained, I didn't have any problems.

Anyway, GRUB doesn't really use the GPU, it just draws to the raw frame buffer as far as I know.

Offline

#11 2019-09-04 20:16:46

Pse
Member
Registered: 2008-03-15
Posts: 393

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

Are you perhaps running the card in the unsupported PCI-E 4 mode on an older chipset (like B450 or X470)? Some people have reported stability issues. Try setting the card to PCI-E 3 and see what happens. On X570 this should work fine.

Offline

#12 2019-09-04 20:21:43

silnar
Member
Registered: 2011-11-03
Posts: 7

Re: AMD 5700 XT freeze during loading inital ramdisk. [SOLVED]

Finally, I found a solution.

I thought about your Arch reinstall idea, but I couldn't convince myself that it will change anything.
(mainly because I had everything updated)
So I started reading Arch installation manual and noticed that there is this bootloader install step.
And one thing caught my attention - I have never updated Grub after Arch installation.

So I thought I will reinstall it:

# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch

And it worked !!! smile

I believe there was some old/broken uefi code installed in /boot/efi that was never updated.

Funny thing is that my Arch, Ubuntu and SysrescueCD usb installation pendrive was also freezing during boot.
I've created it using multibootusb and now I think it installed some old/broken uefi code on the pendrive too.

Thanks for help smile

Offline

Board footer

Powered by FluxBB