You are not logged in.

#1 2019-09-05 16:10:55

stefano
Member
Registered: 2011-04-09
Posts: 144

Transmission-daemon times out at start

I am having trouble getting the transmission-daemon  to start. It times out with no helpful messages I can see:

stefano@polus ~]$ sudo systemctl start transmission
[it hangs for a few minutes, then:]
Job for transmission.service failed because a timeout was exceeded.
See "systemctl status transmission.service" and "journalctl -xe" for details.

The output from systemctl status was not very informative:

[stefano@polus ~]$ systemctl status transmission
 transmission.service - Transmission BitTorrent Daemon
   Loaded: loaded (/usr/lib/systemd/system/transmission.service; enabled; vendor preset: disabled)
   Active: failed (Result: timeout) since Thu 2019-09-05 10:52:23 CDT; 5min ago
  Process: 23796 ExecStart=/usr/bin/transmission-daemon -f --log-error (code=exited, status=0/SUCCESS)
 Main PID: 23796 (code=exited, status=0/SUCCESS)

journalctl had a bit more info, but I don't know what to make of it:

Sep 05 10:45:30 polus systemd[1]: Starting Transmission BitTorrent Daemon...
-- Subject: A start job for unit transmission.service has begun execution
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- A start job for unit transmission.service has begun execution.
-- 
-- The job identifier is 561.
Sep 05 10:45:30 polus systemd[1]: transmission.service: Got notification message from PID 23766, but reception only permitted for main PID 23765
Sep 05 10:47:00 polus systemd[1]: transmission.service: State 'stop-sigterm' timed out. Killing.
Sep 05 10:47:00 polus systemd[1]: transmission.service: Killing process 23766 (transmission-da) with signal SIGKILL.
Sep 05 10:47:00 polus systemd[1]: transmission.service: Killing process 23767 (transmission-da) with signal SIGKILL.
Sep 05 10:47:00 polus systemd[1]: transmission.service: Killing process 23768 (transmission-da) with signal SIGKILL.
Sep 05 10:47:00 polus systemd[1]: transmission.service: Killing process 23769 (transmission-da) with signal SIGKILL.
Sep 05 10:47:01 polus systemd[1]: transmission.service: Failed with result 'protocol'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- The unit transmission.service has entered the 'failed' state with result 'protocol'.

I have no idea why there are two processes involved (PIDs 23766 and 23765, I guess it's how the daemon operates. But why this error? I have using transmission for years and never encountered this problem.

Help is appreciated.




BTW, I am using the latest transmission-cli package:

[stefano@polus ~]$ pacman -Qi transmission-cli
Name            : transmission-cli
Version         : 2.94-2
Description     : Fast, easy, and free BitTorrent client (CLI tools, daemon and web client)
Architecture    : x86_64
URL             : http://www.transmissionbt.com/
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : curl  libevent  systemd
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 3.93 MiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Mon 05 Aug 2019 11:03:45 PM CDT
Install Date    : Sun 25 Aug 2019 09:44:39 AM CDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

and the default transmission service file:

[stefano@polus ~]$ less /usr/lib/systemd/system/transmission.service

[Unit]
Description=Transmission BitTorrent Daemon
After=network.target

[Service]
User=transmission
Type=notify
ExecStart=/usr/bin/transmission-daemon  -f --log-error
ExecReload=/bin/kill -s HUP $MAINPID

[Install]
WantedBy=multi-user.target

Offline

#2 2019-09-05 16:38:23

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,288

Re: Transmission-daemon times out at start

Do things work if you start it manually ?

$ transmission-daemon 

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2019-09-05 17:21:53

stefano
Member
Registered: 2011-04-09
Posts: 144

Re: Transmission-daemon times out at start

Lone_Wolf wrote:

Do things work if you start it manually ?

$ transmission-daemon 

Yes, it does.

I had to fiddle around a bit with the settings file to allow remote access (the daemon runs on a headless server), but I was able to start the daemon and connect to it via the web interface. As a stopgap solution I could proceed this way, if only  I could find a way to start it with the same user/privileges/torrents etc. of the transmission user, that the daemon normally runs under when started as a service. I tried

transmission-daemon -u transmission

but that did not seem to work. The daemon still started as my user:

[stefano@polus ~]$ transmission-daemon --username transmission
[stefano@polus ~]$ ps aux | grep transmission
stefano  24034  0.6  0.1 323668  6552 ?        Ssl  12:15   0:00 transmission-daemon --username transmission

At any rate, fixing the original problems seems a more worthy endeavour...

Offline

#4 2019-09-05 18:50:31

seth
Member
Registered: 2012-09-03
Posts: 12,674

Re: Transmission-daemon times out at start

-username is for client authentication, what about

sudo -u transmission transmission-daemon

Offline

#5 2019-09-05 20:53:10

stefano
Member
Registered: 2011-04-09
Posts: 144

Re: Transmission-daemon times out at start

seth wrote:

-username is for client authentication, what about

sudo -u transmission transmission-daemon

Ah, right, that works, silly me.

Any suggestions on how to fix the systemd service problem?

Offline

#6 2019-09-05 21:02:12

stefano
Member
Registered: 2011-04-09
Posts: 144

Re: Transmission-daemon times out at start

Actually, I was too rash. Even when started directly from the command line, the daemon eventually times out it seems.
It does not crash, but it becomes unresponsive after a few minutes.

Offline

#7 2019-09-05 21:04:25

seth
Member
Registered: 2012-09-03
Posts: 12,674

Re: Transmission-daemon times out at start

Check whether there's a stale process:

ps aux | grep transmission

and attempt to launch it in foreground and w/ error log

sudo -u transmission transmission-daemon  -f --log-error

Offline

#8 2019-09-06 20:50:27

stefano
Member
Registered: 2011-04-09
Posts: 144

Re: Transmission-daemon times out at start

Well the problem has disappeared, even though I did not change anything in the configuration. I am starting to think there may have been problems upstream---with the servers transmission gets its bootstrap from.

Offline

Board footer

Powered by FluxBB