You are not logged in.

#1 2019-09-07 19:38:44

krovisser
Member
Registered: 2013-04-18
Posts: 25

Xfwm high CPU usage, slow to change focus

Hello,

5.2.11-arch1-1-ARCH x86_64 GNU/Linux

After an update I find that the longer my machine stays running, the slower and slower `xfwm` becomes. Seems to bottom out at around 2-3 seconds to switch windows. While the application within that window responds fine. Eg., I'll have a 10 tab Firefox window open, and a xfce4-terminal. Just clicking, or alt-tabbing, between them takes 2-3 seconds. But I can scroll and change tabs in Firefox without any delay, or type in the terminal without any delay like it would if it were a kernel/hardware issue. Sometimes, it never changes focus and both windows will be active/selected in the taskbar but the one I tried to focus does not come to the front. Retrying fixes it.

I've tried disabling the compositor but it doesn't improve.

I've got a list of applications updated since around the time *I think* this started happening.

[2019-09-02 12:46] [PACMAN] Running 'pacman -Syu'
[2019-09-02 12:46] [PACMAN] synchronizing package lists
[2019-09-02 12:46] [PACMAN] starting full system upgrade
[2019-09-02 12:54] [ALPM] transaction started
[2019-09-02 12:54] [ALPM] upgraded linux-firmware (20190717.bf13a71-1 -> 20190815.07b925b-1)
[2019-09-02 12:55] [ALPM] upgraded linux (5.2.8.arch1-1 -> 5.2.11.arch1-1)
[2019-09-02 12:56] [ALPM] upgraded xf86-input-libinput (0.28.2-1 -> 0.29.0-1)
[2019-09-02 12:56] [ALPM] upgraded xf86-video-intel (1:2.99.917+865+g60022507-1 -> 1:2.99.917+870+g6f4972d5-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-appfinder (4.12.0-5 -> 4.14.0-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-panel (4.12.2-1 -> 4.14.0-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-battery-plugin (1.1.2-1 -> 1.1.3-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-clipman-plugin (1.4.3-1 -> 1.4.3-2)
[2019-09-02 12:56] [ALPM] upgraded xfce4-diskperf-plugin (2.6.1-2 -> 2.6.2-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-fsguard-plugin (1.1.0-2 -> 1.1.1-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-genmon-plugin (4.0.1-1 -> 4.0.2-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-mpc-plugin (0.5.1-1 -> 0.5.2-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-netload-plugin (1.3.1-2 -> 1.3.2-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-notes-plugin (1.8.1-3 -> 1.8.1-4)
[2019-09-02 12:56] [ALPM] upgraded xfce4-notifyd (0.4.4-1 -> 0.4.4-2)
[2019-09-02 12:56] [ALPM] upgraded xfce4-power-manager (1.6.4-1 -> 1.6.5-2)
[2019-09-02 12:56] [ALPM] upgraded xfce4-screenshooter (1.9.5-1 -> 1.9.6-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-session (4.12.1-11 -> 4.14.0-2)
[2019-09-02 12:56] [ALPM] upgraded xfce4-settings (4.12.4-2 -> 4.14.1-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-smartbookmark-plugin (0.5.0-2 -> 0.5.1-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-systemload-plugin (1.2.2-1 -> 1.2.3-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-terminal (0.8.8-1 -> 0.8.8-2)
[2019-09-02 12:56] [ALPM] upgraded xfce4-time-out-plugin (1.0.2-3 -> 1.0.3-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-wavelan-plugin (0.6.0-2 -> 0.6.1-1)
[2019-09-02 12:56] [ALPM] upgraded xfce4-xkb-plugin (0.8.1-1 -> 0.8.1-2)
[2019-09-02 12:56] [ALPM] upgraded xfdesktop (4.14.0-1 -> 4.14.1-2)
[2019-09-02 12:56] [ALPM] installed libxpresent (1.0.0-1)
[2019-09-02 12:56] [ALPM] upgraded xfwm4 (4.12.5-1 -> 4.14.0-1)
[2019-09-02 12:56] [ALPM] upgraded xorg-xrandr (1.5.0-2 -> 1.5.1-1)

Xfwm also seems to be taking a lot of CPU time (20-25% when moving a window around). If I wanted to try the previous version of xfwm, can I single it out or do I need to downgrade everything in XFCE?

Last edited by krovisser (2019-10-08 17:54:15)

Offline

#2 2019-09-07 19:44:29

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

Side note, since that update conky has also been reporting negative amounts of memory usage:

https://i.imgur.com/89Vl92S.png

Last edited by jasonwryan (2019-09-07 19:45:26)

Offline

#3 2019-09-07 19:45:52

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,042
Website

Re: Xfwm high CPU usage, slow to change focus

Read the Code of Conduct and only post thumbnails http://wiki.archlinux.org/index.php/Cod … s_and_code

Moving to NC...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#4 2019-09-07 20:39:12

archimboldo
Member
Registered: 2016-03-07
Posts: 147

Re: Xfwm high CPU usage, slow to change focus

krovisser wrote:

Side note, since that update conky has also been reporting negative amounts of memory usage:

https://i.imgur.com/89Vl92S.png

Read
https://bbs.archlinux.org/viewtopic.php?id=247883

Last edited by archimboldo (2019-09-07 20:39:33)


Rules for problems.
Everyone has problems. Animals have problems. And buildings. And cats, and trees.
Problems are your friends. Treat them well.

Offline

#5 2019-09-14 16:28:47

qptain Nemo
Member
Registered: 2019-09-14
Posts: 1

Re: Xfwm high CPU usage, slow to change focus

All I can tell you is I turned off xfwm built-in compositing and switched back to compton and it seems like the right decision. Things seem way more responsive now and that lag upon switching appears to be gone.

Offline

#6 2019-09-15 21:10:50

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

If I `pkill xfwm4` it speeds up immediately. Just slows more and more down and eats up more and more processor as it goes along. Memory usage is nominal, however.

I searched a bit and found this bug, but it's not exactly the same issue.

Offline

#7 2019-09-15 23:42:20

toz
Member
Registered: 2011-10-28
Posts: 415

Re: Xfwm high CPU usage, slow to change focus

krovisser wrote:

I searched a bit and found this bug, but it's not exactly the same issue.

Did you try the different vblank modes? Did they make a difference?

Offline

#8 2019-09-16 02:17:43

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

I tried `xpresent`, it did not make any discernible difference. I will try the others.

EDIT: xpresent

Last edited by krovisser (2019-09-16 16:37:34)

Offline

#9 2019-09-16 10:53:03

toz
Member
Registered: 2011-10-28
Posts: 415

Re: Xfwm high CPU usage, slow to change focus

krovisser wrote:

I tried `present`, it did not make any discernible difference. I will try the others.

The proper value is "xpresent" for that vblank mode. (note the 'x')

Last edited by toz (2019-09-16 10:53:37)

Offline

#10 2019-09-16 15:38:16

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

Sorry, yes, `xpresent`, I was going off of memory.

I've also noticed that at some point during this "slow degradation", I am no longer able to drag windows from one workspace to another by trying to drag a window beyond a workspace's edge. After killing xfwm4 and letting it restart, it works again. I will try and be a bit more scientific when I get a chance.

Offline

#11 2019-09-26 17:35:01

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

So I tried all 3: xpresent, glx, and off. The problem eventually appears with all of them.

When I get a chance I'll see if I can profile xfwm and distinguish when the sluggishness occurs.

Offline

#12 2019-09-26 18:23:50

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,580

Re: Xfwm high CPU usage, slow to change focus

Try removing xf86-video-intel, quite a few reports noting similar issues with it.

Offline

#13 2019-09-27 19:16:57

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

Removed xf86-video-intel, no effect. Still slows down.

I did reinstall it and added

Option "DRI" "2"

to an

/etc/X11/xorg.conf.d/20-intel.conf

Since DRI 3 is now the default. Will see.

Last edited by krovisser (2019-09-27 19:17:33)

Offline

#14 2019-10-02 16:26:40

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

Changing the DRI version (or whatever) to 2, from 3, seems to have fixed it. Thanks!

Last edited by krovisser (2019-10-04 14:50:09)

Offline

#15 2019-10-04 14:51:06

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

I spoke too soon. Seems to last longer but today after leaving it on all night xfwm4 was pinned at 25% CPU and real slow to move windows around with.

Offline

#16 2019-10-08 02:40:27

krovisser
Member
Registered: 2013-04-18
Posts: 25

Re: Xfwm high CPU usage, slow to change focus

Been looking into this. Found this forum post on XFCE4's website. One poster says:

The delay and high CPU consumption also happens to me with the default theme of Manajaro 18. But if you switch to Adwaita it works fine.

So I am trying a new theme.

I also found another post on xfce4.org that mentions this bug report that sounds like my issue!

Last edited by krovisser (2019-10-08 02:44:26)

Offline

Board footer

Powered by FluxBB