You are not logged in.

#1 2019-09-13 20:18:26

br4no
Member
Registered: 2019-09-12
Posts: 2

nmcli: no secrets were provided

Hello everyone!

I've recently finished a fresh new installation of archlinux + gnome. I only quite hardly remember how to setup everything around since I installed arch for the last time aprox 7 yeas ago... I came to exactly this problem, at least according to the nmcli log:

Error: Connection activation failed: (7) Secrets were required, but not provided.

I have only network manager installed, no other services to fight with.

In my case I've found the solution myself. The only thing I did is that I went to my router settings and changed SSID name from "Kralicek" to "kralicek" and voila I can connect. So, in my case the SSID cannot contain (or start with) upper case letter. I have tried also completelly different names which were starting with upper case. None of them worked and it always returned the above error. Whatever SSID starting with lower case works......

I hope that maybe I may save someones time by posting this comment even when the cause might be always different...

Can anybody explain why the naming can be an issue?

Thanks,
Bye

Offline

#2 2019-09-13 20:39:53

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,862
Website

Re: nmcli: no secrets were provided

Don't hijack threads.

https://wiki.archlinux.org/index.php/Co … _hijacking, my bad, I may have misjudged this.

Splitting from https://bbs.archlinux.org/viewtopic.php?id=248406.

Last edited by WorMzy (2019-09-14 09:04:10)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

#3 2019-09-14 06:52:05

seth
Member
Registered: 2012-09-03
Posts: 15,681

Re: nmcli: no secrets were provided

That's not exactly a hijck,

In my case I've found the solution myself. The only thing I did is that I went to my router settings and changed SSID name from "Kralicek" to "kralicek" and voila I can connect. So, in my case the SSID cannot contain (or start with) upper case letter. I have tried also completelly different names which were starting with upper case. None of them worked and it always returned the above error. Whatever SSID starting with lower case works......

and from the other thread:

8月 13 13:14:12 Arch NetworkManager[3228]: <info>  [1565673252.0772] Config: added 'ssid' value 'Lawrence-lyra'

so the pattern fits.

There're no such limits to the SSID though, it's "limited" to 32 completely random bytes so if they're affected by such limitation, that'd be a NM bug,

However, the other thread doesn't really fit the provided problem description (notably the error message), but if NM has random issues w/ non-trivial SSIDs this might still be worth a shot.

Offline

#4 2019-09-14 09:03:34

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,862
Website

Re: nmcli: no secrets were provided

You may be right, perhaps I was too quick to brand it a hijack attempt. However, I stand by the split.

I'll include a link to this topic in the original topic and retract my hijack label. Sorry for misjudging your intent, br4no.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

Board footer

Powered by FluxBB