You are not logged in.

#1 2019-09-15 01:54:34

Registered: 2019-09-15
Posts: 1

[Solved] lsblk, fdisk, parted not showing hard drive at all

I recently had the drive in my laptop die, so I bought a WD Blue SN500 NVMe SSD to replace it.  Windows installed fine, but when I booted my live usb to start the arch install process, I found that the drive wasn't being detected at all. 

for example, lsblk gives

loop0    7:0    0 509.6M  1 loop /run/archiso/sfs/airootfs
sda      8:0    1   15G  0 disk
└─sda1   8:1    1   15G  0 part /run/archiso/bootmnt

and there's only one drive listed in /dev/disk/by-uuid/ (and /by-label/, etc) which corresponds, again, to the live usb.  I booted back into windows and downloaded Western Digital's tool to update the firmware, which confirmed that it's up to date.  The drive is supposed to support kernel 4.14 and newer, so I'm at a loss as to what the problem is.

Edit: I found this topic that suggested switching the BIOS settings from Raid to AHCI.  That worked in that the live usb detected the drive, but it also broke my windows install.  Going back to raid, setting windows to boot into safe mode, switching to AHCI, booting windows in safe mode, and then rebooting windows normally fixed the problem.

Last edited by LittleBobbyTables (2019-09-15 04:39:45)


Board footer

Powered by FluxBB