You are not logged in.

#1 2019-09-18 19:14:11

ayhon
Member
Registered: 2019-06-10
Posts: 7

Perpetual "Establishing connection to PulseAudio. Please wait..."

When openning pavucontrol, it stays in a permanent "Establishing connection to PulseAudio. Please wait..."

In my original install, I had plasma installed. Pavucontrol worked under plasma. However, now that I switched to i3, it isn't working anymore.
I managed to fix it by going back to only alsa, but after trying to make bluetooth work (installed bluez, blueberry and enabled bluetooth) I needed a "protocol" to connect things from blueberry. This brought me back to installing puleseaudio for pulseaudio-bluetooth. Now I can connect to my devices, but sound isn't working anymore.

I think that at this point, it's just a matter of fixing pulseaudio. So I come to the forums to ask where could I begin.

Offline

#2 2019-09-19 07:15:17

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,168

Re: Perpetual "Establishing connection to PulseAudio. Please wait..."

How exactly did you "switch to i3" ? If you use startx, you must ensure your user session is properly initialized so that the relevant user services starting pulse can invoke pulse. note the blue note boxes if you actually did that correctly (post your .xinitrc in doubt) you could also enforce it with a

systemctl --user enable pulseaudio

Offline

#3 2019-09-19 07:33:12

ayhon
Member
Registered: 2019-06-10
Posts: 7

Re: Perpetual "Establishing connection to PulseAudio. Please wait..."

I switched to i3 with SDDM. I simply chose the session and hit enter. Here is my .xinitrc

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"
fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
        [ -x "$f" ] && . "$f"
    done
    unset f
fi

exec startkde

Should I just switch exec startkde with exec i3

Also, i tried systemctl enable --user pulseaudio, and it didn't work. On a whim, I decided to try with start instead of enable, and an error appeared that advised me to run systemctl --user status pulseaudio. Here is what I found

[ayhon@abaco ~]$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor prese>
   Active: failed (Result: exit-code) since Thu 2019-09-19 09:36:22 CEST; 12s ago
  Process: 2752 ExecStart=/usr/bin/pulseaudio --daemonize=no (code=exited, status=>
 Main PID: 2752 (code=exited, status=1/FAILURE)

Sep 19 09:36:22 abaco systemd[976]: Failed to start Sound Service.
Sep 19 09:36:22 abaco systemd[976]: pulseaudio.service: Service RestartSec=100ms e>
Sep 19 09:36:22 abaco systemd[976]: pulseaudio.service: Scheduled restart job, res>
Sep 19 09:36:22 abaco systemd[976]: Stopped Sound Service.
Sep 19 09:36:22 abaco systemd[976]: pulseaudio.service: Start request repeated too>
Sep 19 09:36:22 abaco systemd[976]: pulseaudio.service: Failed with result 'exit-c>
Sep 19 09:36:22 abaco systemd[976]: Failed to start Sound Service.
lines 1-13/13 (END)

Last edited by ayhon (2019-09-19 07:38:23)

Offline

#4 2019-09-19 07:55:01

ayhon
Member
Registered: 2019-06-10
Posts: 7

Re: Perpetual "Establishing connection to PulseAudio. Please wait..."

Also, when running systemctl enable --now pulseaudio I get the error:

[ayhon@abaco ~]$ systemctl enable --now pulseaudio
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-unit-files ====
Authentication is required to manage system service or unit files.
Authenticating as: root
Password: 
==== AUTHENTICATION COMPLETE ====
Failed to enable unit: Unit file pulseaudio.service does not exist.

Offline

#5 2019-09-19 08:18:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,168

Re: Perpetual "Establishing connection to PulseAudio. Please wait..."

SDDM sessions should be fine regardless, the other output shows that pulseaudio would actually try to start but something else on your system is broken.

aplay -lL
sudo fuser -v /dev/snd/*
systemctl --user mask pulseaudio.socket
systemctl --user stop pulseaudio
pulseaudio -vvvv 

Ignore the error in the last post, that is expected, pulseaudio is an --user and not a system service.

Last edited by V1del (2019-09-19 08:18:46)

Offline

#6 2019-09-19 09:14:40

ayhon
Member
Registered: 2019-06-10
Posts: 7

Re: Perpetual "Establishing connection to PulseAudio. Please wait..."

The output of those commands is as follows:

[ayhon@abaco ~]$ aplay -lL
null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
    HDA Intel PCH, ALC255 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=PCH,DEV=0
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
hdmi:CARD=PCH,DEV=1
    HDA Intel PCH, HDMI 1
    HDMI Audio Output
hdmi:CARD=PCH,DEV=2
    HDA Intel PCH, HDMI 2
    HDMI Audio Output
hdmi:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 3
    HDMI Audio Output
hdmi:CARD=PCH,DEV=4
    HDA Intel PCH, HDMI 4
    HDMI Audio Output
usbstream:CARD=PCH
    HDA Intel PCH
    USB Stream Output
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[ayhon@abaco ~]$ sudo fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  ayhon       999 F.... polybar
                     ayhon      1000 F.... pulseaudio
[ayhon@abaco ~]$ systemctl --user mask pulseaudio.socket
Created symlink /home/ayhon/.config/systemd/user/pulseaudio.socket → /dev/null.
[ayhon@abaco ~]$ systemctl --user stop pulseaudio
[ayhon@abaco ~]$ pulseaudio -vvvv
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 13.0-dirty
D: [pulseaudio] main.c: Compilation host: x86_64
D: [pulseaudio] main.c: Compilation CFLAGS: Not yet supported on meson
D: [pulseaudio] main.c: Running on host: Linux x86_64 5.2.14-arch2-1-ARCH #1 SMP PREEMPT Thu Sep 12 10:42:38 UTC 2019
D: [pulseaudio] main.c: Found 8 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Running from build tree: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: All asserts enabled.
I: [pulseaudio] main.c: Machine ID is c5bf3f27b3d9476d904801a865fef4e6.
I: [pulseaudio] main.c: Session ID is 2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/ayhon/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-13.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Offline

Board footer

Powered by FluxBB