You are not logged in.

#1 2019-10-12 10:58:54

Registered: 2008-11-14
Posts: 1,978

[SOLVED] Joypad not recognized unless steam is running.

Hi guys,
i'm facing a strange problem with my joypad.
I use a Triolinker adapter that allows me to connect PS2, dreamcast and Gamecube controllers to my PC.
Works flawlessly on linux and even support rumble.
Today, i tried to start "celeste" via lutris and epic game store, and it was unable to detect any controller.
Then, by pure luck, i started steam, then lutris, and the joypad started to work in "celeste" with full rumble support.
So the question is: "what does steam to fix controller support in "celeste", which is running outside it?"
I tried to emulate an xbox360 controller via userspace xboxdrv, mapped all the things, and i was able to make it work in "celeste", but no rumble support (tried --force-feedback option).

Anybody has an explaination? I basically would like to do what steam is doing, but without firing it up.


* Limbo (from Epic strore) does the same.
* It seems "desktop configuration" in steam controller configuration must not be "disabled"

Probably, by enabling a steam "desktop configuration", steam emulates keystrokes and so the controller worked in the game.
Anyway i solved by using
Now controller AND rumble works.

Last edited by kokoko3k (2019-10-13 07:39:00)


Board footer

Powered by FluxBB