You are not logged in.

#1 2019-10-12 12:56:33

bibinne
Member
Registered: 2018-11-01
Posts: 22

Mesa error

Hi,

By trying to solve the issue reported there: https://bbs.archlinux.org/viewtopic.php?id=249683
I now get a new issue with mesa, which might be the reason of the previous one (i hope as the problem is with latest mesa) :

pacman -U mesa-19.1.7-1-x86_64.pkg.tar.xz lib32-mesa-19.1.7-1-x86_64.pkg.tar.xz libva-mesa-driver-19.1.7-1-x86_64.pkg.tar.xz vulkan-radeon-19.1.7-1-x86_64.pkg.tar.xz
chargement des paquets…
avertissement : retourne à la version antérieure du paquet mesa (19.2.1-1 => 19.1.7-1)
avertissement : retourne à la version antérieure du paquet lib32-mesa (19.2.1-1 => 19.1.7-1)
avertissement : retourne à la version antérieure du paquet libva-mesa-driver (19.2.1-1 => 19.1.7-1)
avertissement : retourne à la version antérieure du paquet vulkan-radeon (19.2.1-1 => 19.1.7-1)
résolution des dépendances…

recherche des conflits entre paquets…
avertissement : cycle de dépendances détecté :
avertissement : libglvnd sera installé avant sa dépendance mesa
avertissement : cycle de dépendances détecté :
avertissement : lib32-libglvnd sera installé avant sa dépendance lib32-mesa

Paquets (6) lib32-libglvnd-1.2.0-2  libglvnd-1.2.0-2  lib32-mesa-19.1.7-1  libva-mesa-driver-19.1.7-1  mesa-19.1.7-1  vulkan-radeon-19.1.7-1

Taille totale installée :    142,14 MiB
Taille de mise à jour nette :  -18,81 MiB

:: Procéder à l’installation ? [O/n] 
(6/6) vérification des clés dans le trousseau                                                                                                  [#######################################################################################] 100%
(3/6) vérification de l’intégrité des paquets                                                                                                  [#######################################################################################] 100%
(3/6) chargement des fichiers des paquets                                                                                                      [#######################################################################################] 100%
(6/6) analyse des conflits entre fichiers                                                                                                      [#######################################################################################] 100%
erreur : la validation de la transaction a échoué (conflit de fichiers)
/usr/lib/pkgconfig/egl.pc est présent à la fois dans « libglvnd » et « mesa »
/usr/lib/pkgconfig/gl.pc est présent à la fois dans « libglvnd » et « mesa »
/usr/lib/pkgconfig/glesv2.pc est présent à la fois dans « libglvnd » et « mesa »
/usr/lib32/pkgconfig/egl.pc est présent à la fois dans « lib32-libglvnd » et « lib32-mesa »
/usr/lib32/pkgconfig/gl.pc est présent à la fois dans « lib32-libglvnd » et « lib32-mesa »
/usr/lib32/pkgconfig/glesv2.pc est présent à la fois dans « lib32-libglvnd » et « lib32-mesa »
Des erreurs se sont produites, aucun paquet n’a été mis à jour.

I think i f* my mesa installation... Any idea how to fix it ?

Bibi

Offline

#2 2019-10-12 13:36:44

SyndromeDayna
Member
Registered: 2019-07-13
Posts: 11

Re: Mesa error

mesa 19.2.1 requires libglvnd 1.2.0 or higher
mesa 19.1.7 requires libglvnd 1.1.1 or lower

you should downgrade mesa and libglvnd simultaneously

Offline

#3 2019-10-12 20:47:57

bibinne
Member
Registered: 2018-11-01
Posts: 22

Re: Mesa error

Thanks, it  did work.
Back to my first issue.
Bibi.

Offline

Board footer

Powered by FluxBB