You are not logged in.

#1 2019-10-24 08:37:21

iamzimy
Member
Registered: 2019-10-24
Posts: 7

[SOLVED] KDE Plasma Discover "Please verify internet connectivity"

Hi, I've just installed freshly new arch with kde plasma. Everything went well, but the problem is there is an error displayed on the "Featured" section in Discover. "Unable to load applications. Please verify Internet connectivity". Note that my internet works fine. I've installed arch with kde before and everything was okay, then I install on another laptop and this problem appears.

Last edited by iamzimy (2021-01-31 04:31:54)

Offline

#2 2019-10-30 07:16:10

jhango
Member
From: PH
Registered: 2018-05-24
Posts: 4
Website

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

Same here i just installed packagekit-qt5
problem solve


I Love Arch Linux

Offline

#3 2019-12-17 18:24:36

dderder
Member
Registered: 2019-12-17
Posts: 2

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

I have the same problem and packagekit-qt5 is installed. I've just reinstalled both packagekit-qt5 and discover but that doesn't help.
Discover shows all the installed packages and updates whenever I install stuff in pacman but I can't search in Discover and the home section also shows "Featured - Unable to load applications. Please verify your internet connectivity."

Wifi is working connected though.

Discover also shows updates and let's run updates from it's GUI. Very weird.

Last edited by dderder (2019-12-17 18:26:40)

Offline

#4 2020-01-07 09:46:42

NotACardboardBox
Member
Registered: 2020-01-07
Posts: 1

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

I have the same problem! i've just done a completely fresh install of Arch and followed the install guide to the letter (as I've done a couple times before), but this time Discover shows no results, and the same thing with updates / features page is happening to me too!

This is the output when I run it via console if that helps

invalid kns backend! "/usr/share/knsrcfiles/ksysguard.knsrc" because: "Config group not found! Check your KNS3 installation."
adding empty sources model QStandardItemModel(0x5617d106bc90)
no packages for "org.kde.plasma.quicklaunch"
no packages for "org.kde.plasma.weather"
no packages for "org.kde.plasma.systemmonitor.memory"
no packages for "org.kde.desktopcontainment"
no packages for "org.kde.plasma.networkmanagement"
no packages for "org.kde.plasma.systemloadviewer"
no packages for "org.kde.plasma.webbrowser"
no packages for "org.kde.plasma.clipboard"
no packages for "org.kde.plasma.pager"
no packages for "org.kde.plasmoidviewer"
no packages for "org.kde.plasma.showActivityManager"
no packages for "org.kde.plasma.notes"
no packages for "org.kde.plasma.trash"
no packages for "org.kde.plasma.comic"
no packages for "org.kde.plasma.windowlist"
no packages for "org.kde.plasma.battery"
no packages for "org.kde.hunyango"
no packages for "org.kde.haenau"
no packages for "org.kde.plasma.lock_logout"
no packages for "org.kde.plasma.keyboardindicator"
no packages for "org.kde.paneltoolbox"
no packages for "org.kde.plasma.grouping"
no packages for "org.kde.plasma.analogclock"
no packages for "org.kde.plasma.folder"
no packages for "org.kde.color"
no packages for "org.kde.image"
no packages for "org.kde.plasma.bluetooth"
no packages for "org.kde.plasma.systemmonitor.diskusage"
no packages for "org.kde.plasma.showdesktop"
no packages for "org.kde.plasma.diskquota"
no packages for "org.kde.plasma.themeexplorer"
no packages for "org.kde.plasma.systemtray"
no packages for "org.kde.plasma.calendar"
no packages for "org.kde.plasma.lookandfeelexplorer"
no packages for "org.gnome.cantarell"
no packages for "org.kde.plasma.systemmonitor.diskactivity"
no packages for "org.freedesktop.appstream.cli"
no packages for "org.kde.breezedark.desktop"
no packages for "org.kde.plasma.userswitcher"
no packages for "org.kde.plasma.systemmonitor.net"
no packages for "org.kde.plasma.desktop.emptyPanel"
no packages for "org.kde.desktoptoolbox"
no packages for "org.kde.plasma.fuzzyclock"
no packages for "org.kde.plasma.kicker"
no packages for "org.kde.plasma_applet_dict"
no packages for "org.kde.plasma.activitypager"
no packages for "org.kde.plasma.colorpicker"
no packages for "org.kde.plasma.cuttlefish"
no packages for "org.kde.plasmashell"
no packages for "org.kde.plasma.fifteenpuzzle"
no packages for "org.kde.plasma.timer"
no packages for "org.kde.kscreen"
no packages for "org.kde.milou"
no packages for "org.kde.plasma.mediacontroller"
no packages for "org.kde.plasma.konsoleprofiles"
no packages for "org.kde.discover.packagekit"
no packages for "org.kde.breeze.desktop"
no packages for "org.kde.plasma.quickshare"
no packages for "org.kde.plasma.mediaframe"
no packages for "org.kde.plasma.systemmonitor.cpu"
no packages for "org.kde.plasma.activitybar"
no packages for "org.kde.potd"
no packages for "org.kde.slideshow"
no packages for "org.kde.plasma.icontasks"
no packages for "org.kde.kinfocenter"
no packages for "org.kde.plasma.taskmanager"
no packages for "org.kde.plasma.digitalclock"
no packages for "org.kde.plasma.desktop.appmenubar"
no packages for "org.kde.plasma.volume"
no packages for "org.freedesktop.fwupd"
no packages for "org.kde.plasma.desktop.defaultPanel"
no packages for "org.kde.plasma.kickerdash"
no packages for "org.kde.plasma.calculator"
no packages for "org.kde.plasma.appmenu"
no packages for "org.kde.discover.flatpak"
no packages for "org.kde.plasmoidviewershell"
no packages for "org.kde.plasma.notifications"
no packages for "org.kde.plasma.devicenotifier"
no packages for "org.kde.plasma.binaryclock"
no packages for "org.kde.plasma.desktop"
no packages for "org.kde.plasma.kimpanel"
no packages for "org.kde.plasma.kickoff"
no packages for "org.kde.plasma.vault"
no packages for "org.kde.plasma.minimizeall"
empty appstream db
org.kde.plasma.libdiscover: Couldn't find a category for  "fwupd-backend"
took really long to fetch KNSBackend(0x5617d0f93ff0, name = "/usr/share/knsrcfiles/discover_ktexteditor_codesnippets_core.knsrc")
took really long to fetch KNSBackend(0x5617d0fdafc0, name = "/usr/share/knsrcfiles/plasma-themes.knsrc")
took really long to fetch KNSBackend(0x5617d0fe9a10, name = "/usr/share/knsrcfiles/emoticons.knsrc")
took really long to fetch KNSBackend(0x5617d0fe0320, name = "/usr/share/knsrcfiles/kwineffect.knsrc")
took really long to fetch KNSBackend(0x5617d0fe7f90, name = "/usr/share/knsrcfiles/sddmtheme.knsrc")
took really long to fetch KNSBackend(0x5617d0fe4db0, name = "/usr/share/knsrcfiles/kwinscripts.knsrc")
took really long to fetch KNSBackend(0x5617d0ff7e50, name = "/usr/share/knsrcfiles/wallpaper.knsrc")
took really long to fetch KNSBackend(0x5617d0ff1fa0, name = "/usr/share/knsrcfiles/ksplash.knsrc")
took really long to fetch KNSBackend(0x5617d0fee9c0, name = "/usr/share/knsrcfiles/xcursor.knsrc")
took really long to fetch KNSBackend(0x5617d1003dd0, name = "/usr/share/knsrcfiles/auror
took really long to fetch KNSBackend(0x5617d0ff70b0, name = "/usr/share/knsrcfiles/kwins
took really long to fetch KNSBackend(0x5617d100d330, name = "/usr/share/knsrcfiles/konso
took really long to fetch KNSBackend(0x5617d1008fa0, name = "/usr/share/knsrcfiles/wallp
took really long to fetch KNSBackend(0x5617d10094c0, name = "/usr/share/knsrcfiles/comic
took really long to fetch KNSBackend(0x5617d10061a0, name = "/usr/share/knsrcfiles/plasm
took really long to fetch KNSBackend(0x5617d0ffb6e0, name = "/usr/share/knsrcfiles/icons
took really long to fetch KNSBackend(0x5617d1000b70, name = "/usr/share/knsrcfiles/looka
took really long to fetch KNSBackend(0x5617d0ffb790, name = "/usr/share/knsrcfiles/windo
took really long to fetch KNSBackend(0x5617d0ffd9c0, name = "/usr/share/knsrcfiles/color
<Unknown File>:7: TypeError: Cannot read property 'contentX' of null
file:///usr/lib/qt/qml/org/kde/kirigami.2/templates/private/ScrollView.qml:95:5: QML QQuickItem: ScrollBar must be attached to a Flickable or ScrollView
<Unknown File>:7: TypeError: Cannot read property 'contentX' of null

Offline

#5 2020-01-08 12:43:44

thibdb13
Member
From: Mechelen - Belgium
Registered: 2005-10-11
Posts: 114

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

Maybe you could try to create this file: /etc/NetworkManager/conf.d/dhcp-client.conf and put this in its content:
[main]
dhcp=dhclient (or dhcpcd)

See also:https://wiki.archlinux.org/index.php/NetworkManager#DHCP_client

Offline

#6 2020-02-08 03:44:28

WaV
Member
Registered: 2020-02-08
Posts: 2

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

Registered an account today just to follow this thread. I am experiencing this same issue on a fresh install I did yesterday. As other users have stated, I also can confirm packagekit-qt5 is installed on my system. Updates work just fine, but I cannot view featured applications.

Offline

#7 2020-02-09 01:49:24

WaV
Member
Registered: 2020-02-08
Posts: 2

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

I have found a resolution.... somewhat. I decided to install the kde-applications package group to see what it had to offer. It is a bit bloated, however, and adds more than 150 packages to the system.

So, if you look through the packages within the package group on Arch’s website, you’ll probably find what you need to get discover working as expected. Unfortunately I don’t know which package (or packages) it was because I installed everything.

Offline

#8 2020-04-20 17:21:32

gaylordlevy
Member
Registered: 2020-04-20
Posts: 1

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

I was having the exact same problem and I gave up;  however (when I wasn't looking for it)  I found the solution (at least in my setup) in a youtube video... just have to re-install the "appstream" package, which "appstream-qt" is dependent on, which "discover" is dependent on

Offline

#9 2020-07-06 20:25:11

enigmatic_jihad
Member
Registered: 2020-04-14
Posts: 26

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

I was fetching the same problem after a fresh install of KDE plasma. After a lot of digging in, I found the solution, but I don't know which package is specifically solving the problem. In the first hand install or reinstall the packagekit and packagekit-qt5. See if that solves the problem. If not, try install or reinstall the appstream and appstream-qt package. See if that solves the problem. Remember you need to restart your system after install or reinstalling these package.

That should fix the problem, And yet if the problem is not fixed, just install the whole 'plasma' group and 'kde-applications'. This will definitely fix the issue.

Last edited by enigmatic_jihad (2020-07-06 20:25:53)

Offline

#10 2021-07-23 18:50:16

projjalm
Member
Registered: 2021-07-23
Posts: 1

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

I actually found the correct solution to the above problem. installing none of the packages worked for me (But still, install them to clear any dependencies). What actually worked for me was installing the apper package of kde, its a software manager, which is required for plasma-discover to work properly. Hope this helps smile

Offline

#11 2021-08-22 04:07:42

KingShark
Member
Registered: 2021-08-22
Posts: 1

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

gaylordlevy wrote:

I was having the exact same problem and I gave up;  however (when I wasn't looking for it)  I found the solution (at least in my setup) in a youtube video... just have to re-install the "appstream" package, which "appstream-qt" is dependent on, which "discover" is dependent on

this resolved the issue on my machine

Offline

#12 2021-08-24 12:52:19

tsbarnes
Member
Registered: 2021-02-17
Posts: 11

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

Just wanted to note for anyone still having this issue that it can be caused by adding an OpenDesktop.org account to KDE Online Accounts. The only solution I know of is to not use the OpenDesktop.org accounts in KDE Online Accounts.

Offline

#13 2021-08-25 03:34:32

Superadmin
Member
Registered: 2021-08-22
Posts: 92

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

WaV wrote:

I   It is a bit bloated, however, and adds more than 150 packages to the system.

So, if you look through the packages within the package group on Arch’s website, you’ll probably find what you need to get discover working as expected. Unfortunately I don’t know which package (or packages) it was because I installed everything.

Last edited by Superadmin (2021-08-28 03:50:00)

Offline

#14 2021-08-25 07:23:27

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,950

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

Superadmin wrote:
WaV wrote:

I   It is a bit bloated, however, and adds more than 150 packages to the system.

So, if you look through the packages within the package group on Arch’s website, you’ll probably find what you need to get discover working as expected. Unfortunately I don’t know which package (or packages) it was because I installed everything.

From the Newbie Corner
Hi there
I too installed everything(kde-application) and am now frustrated with the bloated applications
When I tried to uninstall the kde-application
I could not... It pulled out a dependency which I have no idea of
I would like to install kde application on the basis of the preferences I have
Can you help me remove this bloated softwares?

This is completely off topic here. Please open a new thread in Newbie Corner

Offline

#15 2021-08-25 20:14:04

WellWellWell
Member
Registered: 2021-08-22
Posts: 14

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

gaylordlevy wrote:

I was having the exact same problem and I gave up;  however (when I wasn't looking for it)  I found the solution (at least in my setup) in a youtube video... just have to re-install the "appstream" package, which "appstream-qt" is dependent on, which "discover" is dependent on

This fixed it for me as well.  Thank you!

Offline

#16 2021-09-19 06:52:52

glaumar
Member
Registered: 2021-09-19
Posts: 1

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

gaylordlevy wrote:

I was having the exact same problem and I gave up;  however (when I wasn't looking for it)  I found the solution (at least in my setup) in a youtube video... just have to re-install the "appstream" package, which "appstream-qt" is dependent on, which "discover" is dependent on

Thanks, it worked for me

Offline

#17 2021-09-29 06:31:44

scardracs
Member
Registered: 2021-09-29
Posts: 1

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

Just to make a point: both appstream-qt AND packagekit-qt5 must be installed in order to make discover working. Using archinstall you'll have only appstream installed but no packagekit.

Offline

#18 2022-03-07 05:51:28

rstrawsb
Member
Registered: 2022-03-07
Posts: 1

Re: [SOLVED] KDE Plasma Discover "Please verify internet connectivity"

gaylordlevy wrote:

I was having the exact same problem and I gave up;  however (when I wasn't looking for it)  I found the solution (at least in my setup) in a youtube video... just have to re-install the "appstream" package, which "appstream-qt" is dependent on, which "discover" is dependent on


Thanks for answering this!  Save me time for sure.

Offline

Board footer

Powered by FluxBB