You are not logged in.

#1 2019-10-29 14:55:23

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,857

autofs 5.1.6 package is missing service files

[15:54:12]  cd ~
koko@Gozer# systemctl restart autofs
Failed to restart autofs.service: Unit autofs.service not found.

[15:54:19]  cd ~
koko@Gozer# pacman -Ql autofs|grep '.service'

[15:54:19]  cd ~
koko@Gozer# pacman -Ql autofs
autofs /etc/
autofs /etc/autofs/
autofs /etc/autofs/auto.master.d/
autofs /usr/
autofs /usr/bin/
autofs /usr/bin/automount
autofs /usr/lib/
autofs /usr/lib/autofs/
autofs /usr/lib/autofs/lookup_dir.so
autofs /usr/lib/autofs/lookup_file.so
autofs /usr/lib/autofs/lookup_files.so
autofs /usr/lib/autofs/lookup_hosts.so
autofs /usr/lib/autofs/lookup_ldap.so
autofs /usr/lib/autofs/lookup_ldaps.so
autofs /usr/lib/autofs/lookup_multi.so
autofs /usr/lib/autofs/lookup_nis.so
autofs /usr/lib/autofs/lookup_nisplus.so
autofs /usr/lib/autofs/lookup_program.so
autofs /usr/lib/autofs/lookup_sss.so
autofs /usr/lib/autofs/lookup_userhome.so
autofs /usr/lib/autofs/lookup_yp.so
autofs /usr/lib/autofs/mount_afs.so
autofs /usr/lib/autofs/mount_autofs.so
autofs /usr/lib/autofs/mount_bind.so
autofs /usr/lib/autofs/mount_changer.so
autofs /usr/lib/autofs/mount_ext2.so
autofs /usr/lib/autofs/mount_ext3.so
autofs /usr/lib/autofs/mount_ext4.so
autofs /usr/lib/autofs/mount_generic.so
autofs /usr/lib/autofs/mount_nfs.so
autofs /usr/lib/autofs/mount_nfs4.so
autofs /usr/lib/autofs/parse_amd.so
autofs /usr/lib/autofs/parse_sun.so
autofs /usr/share/
autofs /usr/share/man/
autofs /usr/share/man/man5/
autofs /usr/share/man/man5/auto.master.5.gz
autofs /usr/share/man/man5/autofs.5.gz
autofs /usr/share/man/man5/autofs.conf.5.gz
autofs /usr/share/man/man5/autofs_ldap_auth.conf.5.gz
autofs /usr/share/man/man8/
autofs /usr/share/man/man8/autofs.8.gz
autofs /usr/share/man/man8/automount.8.gz

Am i missing something or it is just a packaging bug?

reverting to 5.1.4 seems to fix it.

Last edited by kokoko3k (2019-10-29 14:57:08)

Offline

#2 2019-10-29 16:26:28

jean_no
Member
Registered: 2007-09-18
Posts: 46

Re: autofs 5.1.6 package is missing service files

Offline

#3 2019-10-29 19:05:54

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,857

Re: autofs 5.1.6 package is missing service files

Thanks, somehow i missed it.

Offline

#4 2019-10-31 17:04:21

stefguy
Member
Registered: 2018-07-13
Posts: 4

Re: autofs 5.1.6 package is missing service files

it's not just the systemd service file, the package also misses everything unter /etc/autofs. when upgrading, all files which were previously there, are gone (if unchanged), the changed ones get copied to .pacsave.

When downgrading, you have to copy the .pacsaves back!

just my 2c .. stef

Offline

#5 2019-10-31 17:32:50

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,857

Re: autofs 5.1.6 package is missing service files

You're right, i did that.

Offline

Board footer

Powered by FluxBB