You are not logged in.

#1 2019-11-04 13:54:35

sphere101
Member
Registered: 2017-08-04
Posts: 15

Zpool not coming online after reboot

Good morning fellow users,
I recently have come across some odd behavior with zfs/zpool, before my zpool would come online after reboot now they do not and I have to manually import it.

root@thor ~]# zpool import
   pool: zfshomenas
     id: 14249932447033997222
  state: ONLINE
action: The pool can be imported using its name or numeric identifier.
config:

    zfshomenas  ONLINE
      raidz1-0  ONLINE
        sda1    ONLINE
        sdb1    ONLINE
        sdc1    ONLINE
        sdd1    ONLINE
[root@thor ~]# zpool import zfshomenas
[root@thor ~]# df -h
Filesystem                Size  Used Avail Use% Mounted on
dev                        24G     0   24G   0% /dev
run                        24G  1.3M   24G   1% /run
/dev/mapper/archvol-root   98G   64G   30G  69% /
tmpfs                      24G   41M   24G   1% /dev/shm
tmpfs                      24G     0   24G   0% /sys/fs/cgroup
tmpfs                      24G  7.5M   24G   1% /tmp
/dev/mapper/archvol-home  195G  110G   76G  60% /home
/dev/nvme0n1p2             96M   42M   55M  43% /boot/efi
tmpfs                     4.8G   16K  4.8G   1% /run/user/1000
zfshomenas/data            21T  5.6T   15T  28% /data
zfshomenas                 15T  256K   15T   1% /zfs
[root@thor ~]# systemctl status zfs-import-scan.service
● zfs-import-scan.service - Import ZFS pools by device scanning
   Loaded: loaded (/usr/lib/systemd/system/zfs-import-scan.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:zpool(8)

Not sure if this is a configuration issue or a bug from a recent upgrade, any thoughts??
Thank you.

Last edited by sphere101 (2019-11-05 00:48:50)

Offline

#2 2019-11-04 23:27:33

sphere101
Member
Registered: 2017-08-04
Posts: 15

Re: Zpool not coming online after reboot

Additional notes, looks like the import-cache service failed complaining about a drive but they are all online.. Running scrub


[root@thor ~]# systemctl status zfs-import-cache
● zfs-import-cache.service - Import ZFS pools by cache file
   Loaded: loaded (/usr/lib/systemd/system/zfs-import-cache.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2019-11-04 07:23:34 CST; 9h ago
     Docs: man:zpool(8)
Main PID: 544 (code=exited, status=1/FAILURE)

Nov 04 07:23:34 thor systemd[1]: Starting Import ZFS pools by cache file...
Nov 04 07:23:34 thor zpool[544]: cannot import 'zfshomenas': one or more devices is currently unavailable
Nov 04 07:23:34 thor systemd[1]: zfs-import-cache.service: Main process exited, code=exited, status=1/FAILURE
Nov 04 07:23:34 thor systemd[1]: zfs-import-cache.service: Failed with result 'exit-code'.
Nov 04 07:23:34 thor systemd[1]: Failed to start Import ZFS pools by cache file.
[root@thor ~]# zpool list
NAME         SIZE  ALLOC   FREE  CKPOINT  EXPANDSZ   FRAG    CAP  DEDUP    HEALTH  ALTROOT
zfshomenas  29.1T  7.67T  21.4T        -         -     0%    26%  1.00x    ONLINE  -
[root@thor ~]# zpool list devices
cannot open 'devices': no such pool
[root@thor ~]# zpool list zfshonenas
cannot open 'zfshonenas': no such pool
[root@thor ~]# zpool list zfshomenas
NAME         SIZE  ALLOC   FREE  CKPOINT  EXPANDSZ   FRAG    CAP  DEDUP    HEALTH  ALTROOT
zfshomenas  29.1T  7.67T  21.4T        -         -     0%    26%  1.00x    ONLINE  -
[root@thor ~]# zpool list zfshomenas -v
NAME         SIZE  ALLOC   FREE  CKPOINT  EXPANDSZ   FRAG    CAP  DEDUP    HEALTH  ALTROOT
zfshomenas  29.1T  7.67T  21.4T        -         -     0%    26%  1.00x    ONLINE  -
  raidz1    29.1T  7.67T  21.4T        -         -     0%  26.3%      -  ONLINE 
    sda1        -      -      -        -         -      -      -      -  ONLINE 
    sdb1        -      -      -        -         -      -      -      -  ONLINE 
    sdc1        -      -      -        -         -      -      -      -  ONLINE 
    sdd1        -      -      -        -         -      -      -      -  ONLINE 
[root@thor ~]#
[root@thor ~]# zpool scrub

Last edited by sphere101 (2019-11-05 00:49:11)

Offline

#3 2019-11-04 23:33:49

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,788

Re: Zpool not coming online after reboot

Please edit your posts and use [ code ] tags when posting output. It makes the output much easier to read.

https://wiki.archlinux.org/index.php/Co … s_and_code
https://bbs.archlinux.org/help.php#bbcode

Offline

Board footer

Powered by FluxBB