You are not logged in.

#1 2019-11-06 10:15:44

DaNiMoTh
Member
Registered: 2006-06-10
Posts: 260

LTS kernel and userspace support

Hi all,

Are recent package upgrades compatible with older LTS kernels? In other words, can I maintain in my system the 4.14 LTS and performing 'pacman -Syu' once a week, with the confidence that all the newest userspace package will continue to work? I am worried since the LTS kernel version maintained in the Arch repos is the 4.19, while I'd like to maintain the usage of 4.14 (I am already using a 4.14 package maintained by me, so upgrading the system would not affect that package).

Thanks

Offline

#2 2019-11-06 10:22:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,798

Re: LTS kernel and userspace support

There's no absolute guarantee for that, generally yes, practically I know that e.g. recent Qt releases break on iirc 4.4 and earlier because they use a new renaming API not available on such an old kernel.

I'd assume that you should generally be alright as long as you use a kernel that still receives "some support" in some form. However there likely will eventually be user space that wants to make use of newer kernel functionalities without providing graceful fallbacks.

Offline

Board footer

Powered by FluxBB