You are not logged in.

#1 2019-11-09 10:52:25

apaz
Member
Registered: 2018-07-23
Posts: 28

Radeon RX 5700 XT: don't load module "amdgpu"

In the new PC with the new installation of Arch, I can't make AMD drivers work (I use amdgpu-pro for Davinci Resolve, but the same happens to me with the open ones).
X570 motherboard (try an MSI and an Asus), AMD 3700X processor, NVMe SSD and RX 5700 XT graphics card (but I also tried an Nvidia 2060 Super with the same problems), Dell UP2716D monitor via mDP.


Xorg.0.log
you see that the system works in Framebuffer mode, i.e. excluding the radeon. There is no trace of the amdgpu module, not even as "unloaded". The monitor is recognized by Edid. It also shows that AIGLX and DRI2 do not work and that DRI3 is loaded only in the final stages, but I do not know if they are important.

XrandR:
Can't open display 
glxinfo:
Error: unable to open display 

journalctl


Others information:

lspci -v | grep amdgpu:
Kernel driver in use: amdgpu
Kernel modules: amdgpu
 

lspci

The card is easily recognized as "Navi 10".

ls /usr/lib/xorg/modules/drivers
modesttins_drv.so 

I think there should also be "amdgpu_drv.so"

ls /usr/lib/xorg/modules/extensions
libglx.so 

I think there should be "libglx.so.xorg"

Adding or removing the "amdgpu" module from mkinitcpio.conf does not change anything, as does using the kernel parameters "amdgpu.dc=1" and "amdgpu.dpm=1". The module is not blacklisted.

I tried both letting the drivers configure by the system and creating a 10-amdgpu.conf, with various tests. But the result doesn't change.


PS: I tried to install OpenSUSE Tumbleweed and the open drivers work without any problems "Out of the Box" (but I didn't go into it in depth).

Offline

#2 2019-11-09 13:48:28

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,359

Re: Radeon RX 5700 XT: don't load module "amdgpu"

The journal doesn't show problems on hw / kernel level, the error seems to be in userspace.

I think there should also be "amdgpu_drv.so"

I think there should be "libglx.so.xorg"

$ pacman -F amdgpu_drv.so
$ pacman -F libglx.so.xorg

The output of those commands should give you a clue what you're missing.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2019-11-09 15:42:39

apaz
Member
Registered: 2018-07-23
Posts: 28

Re: Radeon RX 5700 XT: don't load module "amdgpu"

$ pacman -F amdgpu_drv.so
extra/xf86-video-amdgpu 19.1.0-1 (xorg drivers)
    usr/lib/xorg/modules/drivers/amdgpu_drv.so

It seems that it is specific to amdgpu open and so in my case it is right that it does not appear. Moreover, they are in version 19.1 while the amdgpu-pro are in version 19.30.

$ pacman -F libglx.so.xorg
...(nothing)...

I had found the workaround to rename "libglx.so" to "libglx.so.xorg" in the laptop with an old Nvidia, to fix a problem. So it has nothing to do with AMD and it's right that it doesn't give results.

There is a method to check where the amdgpu module provided by amdgpu-pro is; where should it be placed and how should it be recognized by the system?

Offline

#4 2019-11-09 20:09:30

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,359

Re: Radeon RX 5700 XT: don't load module "amdgpu"

Xorg and amdgpu-pro are 2 different projects, the version numbers follow different schemes.
You are correct that xf86-video-amdgpu is inetended for the mesa opensource drivers, not the amdgpu-pro drivers.

There is a method to check where the amdgpu module provided by amdgpu-pro is; where should it be placed and how should it be recognized by the system?

In archlinux PKGBUILDs/packages  take care of systemwide setup.

Re-reading this thread it does seem you want to use amdgpu-pro drivers.

You have build https://aur.archlinux.org/pkgbase/amdgpu-pro-installer/ ?

install amdgpu-pro-libgl and its dependencies .
reboot or restart X , post fresh Xorg log.




NOTE : You seem to lack understanding of the linux graphics stack, read https://www.reddit.com/r/archlinux/comm … m/djsc8at/ for a better understanding.

Last edited by Lone_Wolf (2019-11-09 20:10:25)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2019-11-09 22:37:09

apaz
Member
Registered: 2018-07-23
Posts: 28

Re: Radeon RX 5700 XT: don't load module "amdgpu"

Thanks for the link, I started to understand how the graphical stack of Linux works!
I have to use amdgpu-pro to use Davinci Resolve, I built a new PC to use it as a video editing workstation (no game). Until now I used a laptop with proprietary Nvidia drivers.
I have installed amdgpu-pro drivers from AUR several times, always with "makepkg -si", and installing all dependencies. Sometimes I reformatted the SSDs to make a new installation of Arch and drivers. Moreover, it seems to me that support for these proprietary drivers is over just today!
As you said, the graphics card and kernel module are recognized, so the problem is in user-space, but I don't know how to solve it at all. I don't even know what to look for and what to test to find a solution. The amdgpu-pro driver is there but is not used. So the framebuffer driver (and also Glamor) is used.
I've seen that the build of the driver creates a folder in /opt and inside there is also the relative "libglx.so". I tried to copy it in /usr/.../libglx.so, removing what was there (which probably was put by the driver, so I replaced the library with itself!); but the result does not change.

Xorg.0.log

Thank you for helping me.

Offline

#6 2019-11-11 11:57:34

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,359

Re: Radeon RX 5700 XT: don't load module "amdgpu"

I looked into the downloaded tarball and it includes what looks like a custom build mesa.
After archlinux started building mesa with libglvnd support, there have been reports that amdgpu-pro only worked with non-glvnd mesa builds.

The https://aur.archlinux.org/packages/mesa-noglvnd is at 18.3 but looks very similar to the extra mesa package (apart from glvnd part) so should be relatively easy to update.

You could try to update it to 19.2 , then replace extra libglvnd , extra mesa and sub packages by mesa-no-glvnd .

No idea if that will work, is Davinci Resolve the only possibility for you or are there alternatives ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2019-11-11 16:55:12

apaz
Member
Registered: 2018-07-23
Posts: 28

Re: Radeon RX 5700 XT: don't load module "amdgpu"

Thank you.
Unfortunately I am not able to modify the PKGBUILDs. Is it enough to change the entry "pkgver=18.3.2" to "pkgver=19.2.3"?
In addition this mesa-noglvnd also installs vulkan, opencl, vdpau and libva, which are incompatible with those installed by amdgpu-pro. Just delete the relevant sections from the PKGBUILD to not install them? And the sections on ATI drivers can/must I have to delete them? As you can see my skill is too low for such a job.

The main NLE software I use is Cinelerra GG, so I could do without using Davinci Resolve. But I built a new PC just to use Resolve's Color Correction tools and I'd hate to give it up. However, I also had problems with a Nvidia card (although I'm not sure they are the same: it suffered from the "six screen problem" and when I saw that I could not install KDE I changed the card without delving). In addition, during one of Arch's many installation attempts, I also tried the open amdgpu with the same result (but again I didn't go into it much). Finally, I tried to install another distro with the open drivers and it worked well.

Offline

#8 2019-11-12 12:47:30

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,359

Re: Radeon RX 5700 XT: don't load module "amdgpu"

I looked at updating aur mesa-noglvnd and felt it builds to much for the purpose of keeping packages depending on mesa happy,
Below is a PKGBUILD based on my aur mesa-git to build a very minimal mesa .


download or git clone my aur mesa-git package, copy the LICENSE file from it to a (new) mesa-for-amdgpu-pro folder.
copy the content below to a PKGBUILD file in the same folder.

Install devtools
run extra-x86_64-build from the mesa-for-amdgpu-pro folder to build in a clean chroot. (your user should have sudo rights to run pacman or this will fail)

You will get a checkpkg error at the end, but can ignore that error.

Install mesa-for-amdgpu-pro-19.2.3-1-x86_64.pkg.tar.xz with pacman -U .
You will get questions from pacman about conflicts, let pacman remove all conflicting packages.

In case that doesn't work , post the output.


# Maintainer: Lone_Wolf <lonewolf at xs4all dot nl>
# Contributor: Armin K. <krejzi at email dot com>
# Contributor: Kristian Klausen <klausenbusk@hotmail.com>
# Contributor: Egon Ashrafinia <e.ashrafinia@gmail.com>
# Contributor: Tavian Barnes <tavianator@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
# Contributor: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Thomas Dziedzic < gostrc at gmail >
# Contributor: Antti "Tera" Oja <antti.bofh@gmail.com>
# Contributor: Diego Jose <diegoxter1006@gmail.com>

pkgbase=mesa-for-amdgpu-pro
pkgname=('mesa-for-amdgpu-pro')
pkgdesc="an open-source implementation of the OpenGL specification, git version"
pkgver=19.2.3
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'xorgproto'
              'libxml2' 'libx11'  'elfutils'  'libxrandr'
              'libgcrypt'  'wayland' 'wayland-protocols' 'meson' 'ninja' 'llvm')
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
         'libunwind' 'wayland' 'llvm-libs')
optdepends=('opengl-man-pages: for the OpenGL API man pages')
provides=(mesa=$pkgver-$pkgrel opengl-driver)
conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau' 'libglvnd')
url="https://www.mesa3d.org"
license=('custom')
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
                'LICENSE')
md5sums=('7744fbc59d55bb9a54ac018250bf77dc'
         'SKIP'
         '5c65a0fe315dd347e09b1f2826a1df5a')
sha512sums=('a64a6b508c28a61b9f5a50f639d0cdca2546caa2118c2478100e3535961d76bf3877357d4a7ddd7dc1d3dfc617883c8ee188915523b003aed8db03e0d5e1c007'
            'SKIP'
            '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D'  # Emil Velikov <emil.l.velikov@gmail.com>
              '946D09B5E4C9845E63075FF1D961C596A7203456'  # Andres Gomez <tanty@igalia.com>
              'E3E8F480C52ADD73B278EE78E1ECBE07D7D70895'  # Juan Antonio Suárez Romero (Igalia, S.L.) <jasuarez@igalia.com>
              'A5CC9FEC93F2F837CB044912336909B6B25FADFA'  # Juan A. Suarez Romero <jasuarez@igalia.com>
              '71C4B75620BC75708B4BDB254C95FAAB3EB073EC') # Dylan Baker <dylan@pnwbakers.com>

prepare() {
    # although removing _build folder in build() function feels more natural,
    # that interferes with the spirit of makepkg --noextract
    if [  -d _build ]; then
        rm -rf _build
    fi
}

build () {
    meson setup mesa-$pkgver _build \
       -D b_ndebug=true \
       -D buildtype=plain \
       --wrap-mode=nofallback \
       -D prefix=/usr \
       -D sysconfdir=/etc \
       -D platforms=x11,wayland,drm,surfaceless \
       -D dri-drivers=[] \
       -D gallium-drivers=swrast \
       -D vulkan-drivers=[] \
       -D dri3=true \
       -D egl=false \
       -D gallium-extra-hud=false \
       -D gallium-nine=false \
       -D gallium-omx=disabled \
       -D gallium-va=false \
       -D gallium-vdpau=false \
       -D gallium-xa=false \
       -D gallium-xvmc=false \
       -D gbm=true \
       -D gles1=false \
       -D gles2=false \
       -D glvnd=false \
       -D glx=dri \
       -D libunwind=true \
       -D llvm=true \
       -D lmsensors=false \
       -D shared-glapi=true \
       -D gallium-opencl=disabled \
       -D valgrind=false \
       -D tools=[]
       
    meson configure _build
    ninja  -C _build
}

package_mesa-for-amdgpu-pro() {
    DESTDIR="${pkgdir}" ninja $NINJAFLAGS -C _build install

    install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE"
}

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#9 2019-11-12 20:20:10

apaz
Member
Registered: 2018-07-23
Posts: 28

Re: Radeon RX 5700 XT: don't load module "amdgpu"

The installation of mesa-for-amdgpu-pro has been successful, thanks to your precise instructions. I just had to import Dylan Baker's gpg key via key-server, because it wasn't there. In addition, "pacman -U" did not find any conflicts to resolve, perhaps because I had previously uninstalled "mesa" and "libglvnd" via "pacman-Rdd".
You could make it a package for AUR.

Unfortunately, the problem remains and a Xorg.0.log exactly the same as the previous ones is produced: after loading "glx" and "modesetting_drv" and recognizing the monitor, I get to the point where the module "fb" is loaded (which was not loaded previously) and from then on everything works in framebuffer excluding the graphics card that worked until then.

I think there are permission issues, which only come at an advanced stage of boot; but I don't know where to look. Or I don't know how to configure Refind well: this is the first time I use a UEFI system.

Now try a clean new installation of Arch using your mesa and your PKGBUILD.
Thank you because you made me understand and learn several new things.

Offline

#10 2019-11-12 22:07:51

skeevy420
Member
Registered: 2017-03-13
Posts: 35

Re: Radeon RX 5700 XT: don't load module "amdgpu"

You're going to want to use a Linux 5.4rc kernel (or amd-staging-drm-next) as well as mesa-git until Mesa 19.3 and Linux 5.4 are released in the repos.  That GPU isn't supported on 5.3 and earlier kernels as well as requires at least Mesa 19.3 (with an exception for distributions with full AMDGPU-Pro support).   

Note that while the versions are very similar, AMDGPU and AMDGPU-Pro aren't the same and Mesa just happens to have a similar version number as Pro right now (especially with 19.3 and 19.30)  (Mesa's at 20.0 running it from git).

Offline

#11 2019-11-13 12:00:14

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,359

Re: Radeon RX 5700 XT: don't load module "amdgpu"

Atm we don't know if mesa-for-amdgpu-pro is the correct/needed solution, so I won't be uploading it until that's clear.

Skeevy420 has valid points, https://wiki.archlinux.org/index.php/Navi_10 has more info.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#12 2019-11-13 13:45:11

skeevy420
Member
Registered: 2017-03-13
Posts: 35

Re: Radeon RX 5700 XT: don't load module "amdgpu"

Lone_Wolf wrote:

Atm we don't know if mesa-for-amdgpu-pro is the correct/needed solution, so I won't be uploading it until that's clear.

Skeevy420 has valid points, https://wiki.archlinux.org/index.php/Navi_10 has more info.

While that wiki page says 5.3 or newer, I assisted in an issue on GitHub for 5700 XTs where 5.3 wasn't enough.  I ended up pulling AMDGPU from amd-staging-drm-next into 5.3 and turning that into a 5.5-drm-next for 5.3 patch for that person.

That issuer mentioned the Xanmod 5.3 kernel worked, but not stock Arch 5.3, which made me look at the Xanmod sources where they include some 5.4 AMDGPU commits as kernel patches with their 5.3 kernel. 

That same 5700 XT user reported that 5.4RC6 was working for them w/o needing any patches.  That user was also using mesa-git, llvm-git, and xf86-video-amdgpu-git.

The wiki also says Mesa 19.2, but there were a lot of Navi10 commits during the 19.2.999 releases (Mesa 19.3-pre rc from git) which makes me want to recommend at least Mesa 19.3 rc over Mesa 19.2 for this particular issue.

Offline

#13 2019-11-13 20:35:50

apaz
Member
Registered: 2018-07-23
Posts: 28

Re: Radeon RX 5700 XT: don't load module "amdgpu"

Not being very competent, I think I'll make a new installation with amdgpu open and I'll wait for kernel 5.4 and mesa 19.3 to try amdgpu-pro.
But if you want some tests with linux-git and mesa-git, let me know. The fresh installations of Arch are for me the time to experiment with new things.
Thank you all.

Offline

#14 2019-11-13 21:25:00

SurlyCycler
Member
Registered: 2019-10-26
Posts: 9

Re: Radeon RX 5700 XT: don't load module "amdgpu"

i have a laptop with ryzen 5 with an amdgpu.

when i built my kernal linux-lts is had to install the amd-ucode and linux-firmware to get it to install correctly.

you should be able to set the resolution

Online

Board footer

Powered by FluxBB