You are not logged in.

#1 2019-11-11 18:39:47

Registered: 2019-11-10
Posts: 4

[SOLVED] Error opening encrypted drive


I'm getting the following error after I attempt to boot into Arch, after doing an encrypted logical volume for my root/home partition.

ERROR: device '/dev/mapper/root' not found. Skipping fsck.

It boots into a shell after booting arch with a minimal set of commands - rootfs.

I know this is because it either can't find the drive or can't open it. package lvm2 is installed and I configured mkinitcpio.conf and ran before installing the bootloader where I included in GRUB_CMDLINE_LINUX the cryptdevice kernel params with root mapping and verified this was included in the command line when running linux command in /boot/grub/grub.cfg

What other commands can I run to see what the problem is? Is there something I am missing? I thought I followed the whole wiki. I've done this in the past, and it normally asks me to decrypt the drive, but that isn't happening here.




Ah, it was because I had the mapping incorrect.

I followed System_configuration#cryptdevice and that works.

Last edited by vpetite (2019-11-11 19:07:11)


Board footer

Powered by FluxBB