You are not logged in.

#1 2019-11-16 16:10:48

juray
Member
Registered: 2012-01-12
Posts: 24

[SOLVED] PlatformIO does not work after last system upgrade

Hello,

after my system upgrade today, platformio has stopped working sad

When I'm trying to run simple pio command, I'm getting:

Traceback (most recent call last):
  File "/usr/bin/platformio", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3251, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3234, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3263, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'platformio==4.0.2' distribution was not found and is required by the application

Several python-* packages have been upgraded so I tried to run command

pacman -S $(pacman -Qqo /usr/lib/python3.8/)
$ pacman -Q | grep platform
platformio 4.0.2-1

... but it doesn't help.

Thank You for any help and suggestions what to do.

J.

Last edited by juray (2019-11-16 17:05:47)

Offline

#2 2019-11-16 16:18:45

a821
Member
From: My Location
Registered: 2012-10-31
Posts: 149

Re: [SOLVED] PlatformIO does not work after last system upgrade

PlatformIO is not an official package. Did you try rebuilding it?

Offline

#3 2019-11-16 16:22:27

juray
Member
Registered: 2012-01-12
Posts: 24

Re: [SOLVED] PlatformIO does not work after last system upgrade

yes I have tried rebuilding from aur but error remains. It looks like it is something with python-setuptools ... but I don't know .. I have tried to downgrade setuptools but it went even worse big_smile

Offline

#4 2019-11-16 16:31:09

ayekat
Member
Registered: 2011-01-17
Posts: 1,359
Website

Re: [SOLVED] PlatformIO does not work after last system upgrade

Check if /usr/lib/python3.7 still exists. If it does, all the packages installing files in there need a rebuild.

pacman -S $(pacman -Qqo /usr/lib/python3.8/)

I've seen this line thrown around on the forums lately, but I honestly fail to see what it's supposed to achieve…


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#5 2019-11-16 16:45:33

a821
Member
From: My Location
Registered: 2012-10-31
Posts: 149

Re: [SOLVED] PlatformIO does not work after last system upgrade

I just install PlatformIO from AUR and it works for me... Very likely you installed packages with `pip` in your system (never do that!). Follow ayekat advice and try to find python packages that need to be reinstalled (with pacman!)

Offline

#6 2019-11-16 16:56:47

juray
Member
Registered: 2012-01-12
Posts: 24

Re: [SOLVED] PlatformIO does not work after last system upgrade

So my dependencies are mixed between /usr/lib/python3.7/site-packages/ and /usr/lib/python3.8/site-packages/ ... it's a messs ...  for example python-click-5.1 has dependencies somewhere to deluge ... omg do i need to reinstall all of them?

Offline

#7 2019-11-16 17:03:35

juray
Member
Registered: 2012-01-12
Posts: 24

Re: [SOLVED] PlatformIO does not work after last system upgrade

OK I have it, i have uninstalled python-click with all of it's dependencies and platformio from aur... and now it work.. Thank You for the reponses !

Offline

Board footer

Powered by FluxBB