You are not logged in.

#1 2019-11-18 21:01:10

Registered: 2019-11-18
Posts: 1

Cannot boot from live USB, hence nor chroot, nor exit emergency shell

Hello to this great community!

I have a Gigabyte P57, that ran on arch for almost two years.

Some days ago I decided I wanted to have a fresh install of Arch. While not a total newbie now, the install I made of arch 2 years ago probably gathered some mishaps along the way, which obviously have to do with me getting started at the time. I am still far from expert but I cannot make a lot of sense of one of my two problems here.

(Also, english is not my first language, sorry by advance for any mistakes)

The first problem seemed easier but after hours of scratching the net I cant find any solutions : I tinkered with the arch.conf file, on the line that pointed towards the boot system, and modified the PARTUUID (I was trying to replace my bootloader, syslinux to grub). I rebooted only to be welcomed by the emergency shell. While in the emergency shell I cannot for the life of me find out HOW I am supposed to rewrite the arch.conf, as I cannot chroot and mount my root partition. Every time I type something like

 [rootfs ]#mount /dev/sdc1 new_root/ 

... the shell tells me:

 mount: /new_root: unknown filesystem type 'vfat' 

So, if I am not wrong, because it's reading the wrong partition (that is, a vfat one), it cannot do anything else apart from saying this?
Then, how can I regenerate or otherwise modify the arch.conf to rewind on my mistake of changing the PARTUUID?

Problems akin to this one are usually solved with chrooting into the install from a live CD or USB, from what I read here and there over the web.
That is my second trouble, that actually led to me trying to change from syslinux to grub: my computer autorestarted everytime I booted a USB stick (I tried and checked many with various distros, the sticks are not the problem). I though that maybe my syslinux install was somehow corrupt and that grub would help, but then I broke my arch.conf and here I am.
When trying to run from the USB stick, It happens very fast, but I am certain the boot on USB is initiated. No forums I looked in so far could answer why I have this sudden shutdown (with quickly displayed texts that probably say what's going on) and I found no troubleshootings in syslinux online documentation (if that's even the actual culprit. Booting from live USB worked well not even a year ago!)

Summary: How do I restore my arch.conf without chrooting (if that is even possible) ?

Then, could someone point me in some directions about my second problem, at least where logs could be ? I assumed there were none because it happens inside the USB stickm but who knows!

[EDIT: booting with the BIOS set to LEGACY instead of UEFI allowed for the boot screen of a zen-installer from a usb stick, shutdowns automatically after selecting "launch zen-installer" .Trying now with an original arch-iso, the ISO works, although I am a tad afraid of doing anything without proper understanding of what caused previously described problems]

[EDIT 2 : I tried reinstalling arch from the official ISO, the computer shutdowns whenever it tries to access EFI. I really don't know what to do.]

Thanks in advance,

Last edited by jedd_dotraw (2019-11-18 22:47:58)


Board footer

Powered by FluxBB