You are not logged in.

#1 2019-11-20 03:39:44

FyreFly00
Member
Registered: 2019-11-20
Posts: 2

XPS 13 Battery Charging Issues

Hey everyone,
I'm using a 2016 XPS 13 with a fresh install of Arch, and i3 WM. By default, i3 ships with a battery status marker in the toolbar, which gives the current charge and the battery state. When I'm using the laptop on battery power, this functions correctly, and indicates that the laptop is running off the battery. However, when I charge the laptop, the charger light on the front switches on and off, and the battery state alternates between "Charging" and "Unknown." It seems that when the laptop is in the "Unknown" state, with the front light off, no charge enters the battery, although none leaves it, either. I've tried to confirm these results by installing tlp and running "tlp-stat", which, when the battery is not recognized, returns:

/sys/class/power_supply/BAT0/charge_full_design             =   7570 [mAh]
/sys/class/power_supply/BAT0/charge_full                    =   5336 [mAh]
/sys/class/power_supply/BAT0/charge_now                     =   4421 [mAh]
/sys/class/power_supply/BAT0/current_now                    =      1 [mA]
/sys/class/power_supply/BAT0/status                         = Unknown (threshold effective)

When it's properly charging, this returns:

/sys/class/power_supply/BAT0/charge_full_design             =   7570 [mAh]
/sys/class/power_supply/BAT0/charge_full                    =   5336 [mAh]
/sys/class/power_supply/BAT0/charge_now                     =   4423 [mAh]
/sys/class/power_supply/BAT0/current_now                    =   1524 [mA]
/sys/class/power_supply/BAT0/status                         = Charging

Additionally, even when I attempt to charge the laptop while it's powered off, the indicator light continues to blink on and off.

Does anyone know what might be causing this weird behavior, and what I can try to do to regulate it?

Offline

#2 2019-11-24 23:20:37

nimrod_mack
Member
Registered: 2018-11-29
Posts: 4

Re: XPS 13 Battery Charging Issues

Seems very much like an hardware issue to me. Maybe it's the battery, but it could also be the charge controlling chip AFAIK...

Offline

#3 2019-12-04 03:46:04

haloandween
Member
Registered: 2019-10-17
Posts: 3

Re: XPS 13 Battery Charging Issues

same problem on prestigion visconte s

Last edited by haloandween (2019-12-04 03:48:38)

Offline

#4 2019-12-04 04:06:20

FyreFly00
Member
Registered: 2019-11-20
Posts: 2

Re: XPS 13 Battery Charging Issues

Yes, it does seem that this is most likely a hardware problem. As far as I can tell, the problem is unrelated to any software issues, so I'm guessing that either my battery is failing, or there's some issue with the charge controller, as nimrod_mack suggested. I guess there's not really many options to fix this then, short of replacing the battery. Just in case, does anyone have any other test suggestions to rule out other problems?

Offline

Board footer

Powered by FluxBB