You are not logged in.

#1 2019-11-22 13:52:22

Registered: 2019-02-12
Posts: 14

[solved] cannot boot : Error device 'UUID=xxx' not found

When I turn my laptop on, I can't boot into arch anymore (my only os).

The error is exactly this one :

Starting version 243.78-2-arch
ERROR: device 'UUID=830a3ce9-89b8-4c58-97b9-79d3bac07009' not found. Skipping fsck.
mount: /new_root: can't find UUID=830a3ce9-89b8-4c58-97b9-79d3bac07009.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off

When in the emergency shell I can't use the keyboard (whether it's laptop's keyboard or a USB keyboard).
I'm using a Xubuntu USB key to debug and write this.

Here's /etc/fstab :

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# /dev/sda2      (the bad one)
UUID=830a3ce9-89b8-4c58-97b9-79d3bac07009       /               ext4            rw,relatime,noatime,nodiratime  0 1

# /dev/sda1
UUID=9f997449-02cd-4c40-acad-b6c9fe306e2a       /boot           ext4            rw,relatime     0 2

# /dev/sdb1
UUID=7cc9c7c1-74ec-44bd-a0a5-08b02299051b       /var            ext4            rw,relatime     0 2

# /dev/sdb2
UUID=83be4177-d7a6-45f5-a476-b1e7a269c710       /tmp            ext4            rw,relatime     0 2

# /dev/sdb4
UUID=5dbe5284-017b-47c4-8a3d-f6dbdbb3c5a5       /data           ext4            rw,relatime     0 2

# /dev/sdb3
UUID=1f48f52f-5dbf-4714-92dc-91a13c820f6d       none            swap            defaults,pri=-2 0 0

sda is a SSD and sdb a HDD which I use to symlink some directories to (in my home folder)

Here is /boot/grub/grub.cfg  (located on sda1)

fsck :

$ sudo fsck /dev/sda2

fsck from util-linux 2.31.1
e2fsck 1.44.1 (24-Mar-2018)
/dev/sda2: clean, 933279/7782400 files, 17730226/31127382 blocks

I have no clue what caused it, I didn't edit any boot option or partitions since my first installation.

Does anyone have an idea on what I could do ?
Thanks in advance

Last edited by Amaury (2019-11-25 15:21:26)


#2 2019-11-22 16:09:28

Registered: 2008-03-28
Posts: 185

Re: [solved] cannot boot : Error device 'UUID=xxx' not found

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch Linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-830a3ce9-89b8-4c58-97b9-79d3bac07009' {
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,msdos1' --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  9f997449-02cd-4c40-acad-b6c9fe306e2a
	  search --no-floppy --fs-uuid --set=root 9f997449-02cd-4c40-acad-b6c9fe306e2a
	echo	'Chargement de Linux linux…'
	linux	/vmlinuz-linux root=UUID=830a3ce9-89b8-4c58-97b9-79d3bac07009 rw  quiet
	echo	'Chargement du disque mémoire initial…'
	initrd	/initramfs-linux.img

In your grub.cfg, replace every occurrence of 9f997449-02cd-4c40-acad-b6c9fe306e2a with 830a3ce9-89b8-4c58-97b9-79d3bac07009


#3 2019-11-22 16:33:45

Registered: 2019-02-12
Posts: 14

Re: [solved] cannot boot : Error device 'UUID=xxx' not found

Thank you for your reply.

I tried just that, and I can't load the kernel, it gives this error :

error loading "/vmlinuz-linux" : not found

and it goes back to grub

It seems logical because 9f997449-02cd-4c40-acad-b6c9fe306e2a is my boot partition (/boot), and 830a3ce9-89b8-4c58-97b9-79d3bac07009 is my root partition ( / )
Also, I did not change grub.cfg at any time, and I don't think I did something that could have changed it.

So for now I reverted the changes


#4 2019-11-22 17:22:36

Registered: 2019-11-22
Posts: 2

Re: [solved] cannot boot : Error device 'UUID=xxx' not found

Please boot with Arch CD/USB (or any other able) stick and compare blkid output with fstab entries.
i.e #blkid (enter)
shows you current UUID and PARTUUID of hdd in the system.


#5 2019-11-25 12:49:26

Registered: 2019-02-12
Posts: 14

Re: [solved] cannot boot : Error device 'UUID=xxx' not found

blkid, from an arch bootable usb :

/dev/sda1: UUID="9f997449-02cd-4c40-acad-b6c9fe306e2a" TYPE="ext4" PARTUUID="8efd9f66-01"
/dev/sda2: UUID="830a3ce9-89b8-4c58-97b9-79d3bac07009" TYPE="ext4" PARTUUID="8efd9f66-02"
/dev/sdb1: UUID="7cc9c7c1-74ec-44bd-a0a5-08b02299051b" TYPE="ext4" PARTUUID="a7c964a1-01"
/dev/sdb2: UUID="83be4177-d7a6-45f5-a476-b1e7a269c710" TYPE="ext4" PARTUUID="a7c964a1-02"
/dev/sdb3: UUID="1f48f52f-5dbf-4714-92dc-91a13c820f6d" TYPE="swap" PARTUUID="a7c964a1-03"
/dev/sdb4: UUID="5dbe5284-017b-47c4-8a3d-f6dbdbb3c5a5" TYPE="ext4" PARTUUID="a7c964a1-04"
/dev/sdc1: LABEL="ARCH_201911" UUID="32EC-3209" TYPE="vfat" PARTUUID="0c3371fd-01"
/dev/loop0: TYPE="squashfs"

All the UUIDs match with fstab...


#6 2019-11-25 15:21:04

Registered: 2019-02-12
Posts: 14

Re: [solved] cannot boot : Error device 'UUID=xxx' not found

It's solved. Thanks to another post on this forum which I had not found at first (sorry for that).

I booted on my Arch USB
mounted every device like it should be in fstab with mount
arch-chroot to my mount point
then run

mkinitcpio -p linux

and now everything works like it should smile


#7 2021-01-11 20:15:39

Registered: 2021-01-11
Posts: 6

Re: [solved] cannot boot : Error device 'UUID=xxx' not found

In my case it turned out to be that I had an old config in /boot/grub/grub.cfg that was trying to load image from an old UUID that was not present.

I just booted from my install USB, mounted all my partitions (/, /boot/, /swap, /home) and issued the grub-mkconfig -o /boot/grub/grub.cfg as the documentation explains: … d_grub.cfg

Good luck


#8 2021-01-11 23:35:53

Forum Moderator
Registered: 2012-01-15
Posts: 3,503

Re: [solved] cannot boot : Error device 'UUID=xxx' not found

sashok_bg, thanks for the contribution, but please pay attention to the dates on threads. This thread is more than a year old, marked solved, and the original poster has not been here since last January.

Please do not necrobump.


"The prettier the user interface, and the fewer odd replies the system allows you to make, the dumber you once appeared in the mind of the designer." -- Ellen Ullman
How to post


Board footer

Powered by FluxBB