You are not logged in.

#1 2019-11-23 12:13:02

Luker
Member
Registered: 2014-01-11
Posts: 3
Website

[Solved] No keyboard/Mouse after boot, even on console

Hello,

I have an asus N56VZ with arch, I did not upgrade it for a couple of months, so I did a big update.

After the reboot grub lets me choose the menu entry I want as usual, I even have to enter a password to load the kernel, all working here...

Then the initrd starts, prompts me for the encrypted partition password, and I can't type anything anymore. not even ctrl-alt-del works
But if I plug in an external keyboard, that works.

So here I am, working with a keyboard on top of the laptop, 'cause the main keyboard/touchpad are not working anymore.
not on X, not on the console

The hardware is fine, since I can do anything in the bios/grub, even on win10 (in a separate partition)

I thought maybe I mised some module with the kernel change, but I can't find anything.
I tried the linux-lts kernel+headers, still the same issue.

out of desperation I tried loading *every* module:

find /lib/modules/$(uname -r) -name '*ko.xz' | rev | cut -d '/' -f 1 | rev | awk -F ".ko.xz" '{ print $1 }'| while read module; do
  echo $module;
  modprobe $module &
done

run it a couple of times to be sure every modules was loaded with its dependencies,
nothiing changed

lshw (without the external mouse/keyboard) looks like this:

https://privatebin.net/?e14ecbd00fa1e97 … nahb93rV7e

...
So I do not know what else to try right now, any pointers?

Last edited by Luker (2019-11-28 22:13:07)


GPG Key id: 762C35A5
https://www.fenrirproject.org

Offline

#2 2019-11-26 01:27:21

dglt
Member
Registered: 2019-08-14
Posts: 41

Re: [Solved] No keyboard/Mouse after boot, even on console

post outputs

cat /proc/cmdline
cat /etc/modprobe.d/*.conf

Offline

#3 2019-11-28 22:12:39

Luker
Member
Registered: 2014-01-11
Posts: 3
Website

Re: [Solved] No keyboard/Mouse after boot, even on console

Solved, thank you!

your answer made me realize I did not try anthing on the cmdline.

Turns out years ago I had to add 'acpi=noirq' to the cmdline, I don't remember why. Probably for the dedicated nvidia, or less probable the sound. I still have to check if everything else works


I get a lot of:

[  361.337623] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[  361.930925] snd_hda_codec_hdmi hdaudioC1D0: Unable to sync register 0x5f0100. -5

spamming in my dmesg now that I did not see before
Audio still works, so at least I have the basics now.

I'll check if everthing else still works, meanwhile I'll mark this as resolved


GPG Key id: 762C35A5
https://www.fenrirproject.org

Offline

Board footer

Powered by FluxBB