You are not logged in.

#1 2019-11-27 01:46:42

iiwwnnaa
Member
Registered: 2019-11-27
Posts: 2

[SOLVED] Xorg-server Fatal server error: (EE) AddScreen/ScreenInit

I'm using Arch Linux 5.3.13-arch1-1
AMD Ryzen 5 3500U Mobile

I have problem on xorg-server,xorg-xinit, i3-wm
when i install pacman -S xorg-server xorg-xinit and try startx command (Added .xinitrc exec i3)
the i3 start successfully, but when reboot system and try startx command
Fatal server error: [    51.827] (EE) AddScreen/ScreenInit message is printed and not working
so remove pacman -Rns xorg-server xorg-xinit and reinstall again..
it works..! only onetimes i really don't know what is problem.
I already install mesa, xf86-video-amdgpu
plz help.. the log is on down of my topic

lspci -v |grep VGA
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c2) (prog-if 00 [VGA controller])

hostnamectl
   Static hostname: iw-Arch
         Icon name: computer-laptop
           Chassis: laptop
  Operating System: Arch Linux
            Kernel: 
      Architecture: x86-64

cat Xorg.0.log

[    51.433] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[    51.433] 
X.Org X Server 1.20.6
X Protocol Version 11, Revision 0
[    51.434] Build Operating System: Linux Arch Linux
[    51.434] Current Operating System: Linux iw-Arch 5.3.13-arch1-1 #1 SMP PREEMPT Sun, 24 Nov 2019 10:15:50 +0000 x86_64
[    51.434] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID= rw loglevel=3 quiet
[    51.434] Build Date: 23 November 2019  06:54:33AM
[    51.434]  
[    51.434] Current version of pixman: 0.38.4
[    51.434] 	Before reporting problems, check [url]http://wiki.x.org[/url]
	to make sure that you have the latest version.
[    51.434] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    51.434] (==) Log file: "/home/iw/.local/share/xorg/Xorg.0.log", Time: Wed Nov 27 10:10:40 2019
[    51.438] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    51.439] (==) No Layout section.  Using the first Screen section.
[    51.439] (==) No screen section available. Using defaults.
[    51.439] (**) |-->Screen "Default Screen Section" (0)
[    51.439] (**) |   |-->Monitor "<default monitor>"
[    51.440] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    51.440] (==) Automatically adding devices
[    51.440] (==) Automatically enabling devices
[    51.440] (==) Automatically adding GPU devices
[    51.440] (==) Automatically binding GPU devices
[    51.440] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    51.440] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    51.440] 	Entry deleted from font path.
[    51.440] (WW) The directory "/usr/share/fonts/TTF" does not exist.
[    51.440] 	Entry deleted from font path.
[    51.440] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    51.440] 	Entry deleted from font path.
[    51.440] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    51.441] 	Entry deleted from font path.
[    51.441] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    51.441] 	Entry deleted from font path.
[    51.441] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    51.441] 	Entry deleted from font path.
[    51.441] (==) FontPath set to:
	
[    51.441] (==) ModulePath set to "/usr/lib/xorg/modules"
[    51.441] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    51.441] (II) Module ABI versions:
[    51.441] 	X.Org ANSI C Emulation: 0.4
[    51.441] 	X.Org Video Driver: 24.0
[    51.441] 	X.Org XInput driver : 24.1
[    51.441] 	X.Org Server Extension : 10.0
[    51.441] (++) using VT number 1

[    51.443] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    51.444] (II) xfree86: Adding drm device (/dev/dri/card0)
[    51.445] (EE) systemd-logind: failed to take device /dev/dri/card0: Operation not permitted
[    51.464] (--) PCI:*(5@0:0:0) 1002:15d8:1025:134d rev 194, Mem @ 0xb0000000/268435456, 0xc0000000/2097152, 0xc0800000/524288, I/O @ 0x00001000/256
[    51.464] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    51.464] (II) LoadModule: "glx"
[    51.466] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    51.474] (II) Module glx: vendor="X.Org Foundation"
[    51.474] 	compiled for 1.20.6, module version = 1.0.0
[    51.474] 	ABI class: X.Org Server Extension, version 10.0
[    51.474] (II) Applying OutputClass "AMDgpu" to /dev/dri/card0
[    51.474] 	loading driver: amdgpu
[    51.474] (==) Matched amdgpu as autoconfigured driver 0
[    51.474] (==) Matched ati as autoconfigured driver 1
[    51.474] (==) Matched modesetting as autoconfigured driver 2
[    51.474] (==) Matched fbdev as autoconfigured driver 3
[    51.474] (==) Matched vesa as autoconfigured driver 4
[    51.474] (==) Assigned the driver to the xf86ConfigLayout
[    51.474] (II) LoadModule: "amdgpu"
[    51.475] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[    51.478] (II) Module amdgpu: vendor="X.Org Foundation"
[    51.478] 	compiled for 1.20.5, module version = 19.1.0
[    51.478] 	Module class: X.Org Video Driver
[    51.478] 	ABI class: X.Org Video Driver, version 24.0
[    51.478] (II) LoadModule: "ati"
[    51.478] (WW) Warning, couldn't open module ati
[    51.478] (EE) Failed to load module "ati" (module does not exist, 0)
[    51.478] (II) LoadModule: "modesetting"
[    51.478] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    51.479] (II) Module modesetting: vendor="X.Org Foundation"
[    51.479] 	compiled for 1.20.6, module version = 1.20.6
[    51.479] 	Module class: X.Org Video Driver
[    51.479] 	ABI class: X.Org Video Driver, version 24.0
[    51.479] (II) LoadModule: "fbdev"
[    51.479] (WW) Warning, couldn't open module fbdev
[    51.479] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    51.479] (II) LoadModule: "vesa"
[    51.479] (WW) Warning, couldn't open module vesa
[    51.479] (EE) Failed to load module "vesa" (module does not exist, 0)
[    51.479] (II) AMDGPU: Driver for AMD Radeon:
	All GPUs supported by the amdgpu kernel driver
[    51.479] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    51.479] (II) AMDGPU(0): [KMS] Kernel modesetting enabled.
[    51.481] (WW) Falling back to old probe method for modesetting
[    51.481] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    51.481] (II) AMDGPU(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    51.481] (==) AMDGPU(0): Depth 24, (--) framebuffer bpp 32
[    51.481] (II) AMDGPU(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    51.481] (==) AMDGPU(0): Default visual is TrueColor
[    51.481] (==) AMDGPU(0): RGB weight 888
[    51.481] (II) AMDGPU(0): Using 8 bits per RGB (8 bit DAC)
[    51.481] (--) AMDGPU(0): Chipset: "Unknown AMD Radeon GPU" (ChipID = 0x15d8)
[    51.481] (II) Loading sub module "fb"
[    51.481] (II) LoadModule: "fb"
[    51.481] (II) Loading /usr/lib/xorg/modules/libfb.so
[    51.482] (II) Module fb: vendor="X.Org Foundation"
[    51.482] 	compiled for 1.20.6, module version = 1.0.0
[    51.482] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    51.482] (II) Loading sub module "dri2"
[    51.482] (II) LoadModule: "dri2"
[    51.482] (II) Module "dri2" already built-in
[    51.742] (II) Loading sub module "glamoregl"
[    51.742] (II) LoadModule: "glamoregl"
[    51.743] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    51.752] (II) Module glamoregl: vendor="X.Org Foundation"
[    51.752] 	compiled for 1.20.6, module version = 1.0.1
[    51.752] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    51.815] (II) AMDGPU(0): glamor X acceleration enabled on AMD RAVEN (DRM 3.33.0, 5.3.13-arch1-1, LLVM 9.0.0)
[    51.815] (II) AMDGPU(0): glamor detected, initialising EGL layer.
[    51.815] (==) AMDGPU(0): TearFree property default: auto
[    51.815] (==) AMDGPU(0): VariableRefresh: disabled
[    51.815] (II) AMDGPU(0): KMS Pageflipping: enabled
[    51.815] (II) AMDGPU(0): Output HDMI-A-0 has no monitor section
[    51.815] (II) AMDGPU(0): Output eDP has no monitor section
[    51.826] (II) AMDGPU(0): EDID for output HDMI-A-0
[    51.826] (II) AMDGPU(0): EDID for output eDP
[    51.826] (II) AMDGPU(0): Manufacturer: CMN  Model: 15e8  Serial#: 0
[    51.826] (II) AMDGPU(0): Year: 2016  Week: 33
[    51.826] (II) AMDGPU(0): EDID Version: 1.4
[    51.826] (II) AMDGPU(0): Digital Display Input
[    51.826] (II) AMDGPU(0): 8 bits per channel
[    51.826] (II) AMDGPU(0): Digital interface is DisplayPort
[    51.826] (II) AMDGPU(0): Max Image Size [cm]: horiz.: 34  vert.: 19
[    51.826] (II) AMDGPU(0): Gamma: 2.20
[    51.826] (II) AMDGPU(0): No DPMS capabilities specified
[    51.826] (II) AMDGPU(0): Supported color encodings: RGB 4:4:4 
[    51.826] (II) AMDGPU(0): First detailed timing is preferred mode
[    51.826] (II) AMDGPU(0): Preferred mode is native pixel format and refresh rate
[    51.826] (II) AMDGPU(0): redX: 0.648 redY: 0.338   greenX: 0.313 greenY: 0.600
[    51.826] (II) AMDGPU(0): blueX: 0.153 blueY: 0.050   whiteX: 0.313 whiteY: 0.329
[    51.827] (II) AMDGPU(0): Manufacturer's mask: 0
[    51.827] (II) AMDGPU(0): Supported detailed timing:
[    51.827] (II) AMDGPU(0): clock: 152.8 MHz   Image Size:  344 x 193 mm
[    51.827] (II) AMDGPU(0): h_active: 1920  h_sync: 2000  h_sync_end 2054 h_blank_end 2250 h_border: 0
[    51.827] (II) AMDGPU(0): v_active: 1080  v_sync: 1086  v_sync_end 1094 v_blanking: 1132 v_border: 0
[    51.827] (II) AMDGPU(0):  N156HCE-EN1
[    51.827] (II) AMDGPU(0):  CMN
[    51.827] (II) AMDGPU(0):  N156HCE-EN1
[    51.827] (II) AMDGPU(0): EDID (in hex):
[    51.827] (II) AMDGPU(0): 	00ffffffffffff000daee81500000000
[    51.827] (II) AMDGPU(0): 	211a0104a5221378022675a656509927
[    51.827] (II) AMDGPU(0): 	0c505400000001010101010101010101
[    51.827] (II) AMDGPU(0): 	010101010101b43b804a713834405036
[    51.827] (II) AMDGPU(0): 	680058c110000018000000fe004e3135
[    51.827] (II) AMDGPU(0): 	364843452d454e310a20000000fe0043
[    51.827] (II) AMDGPU(0): 	4d4e0a202020202020202020000000fe
[    51.827] (II) AMDGPU(0): 	004e3135364843452d454e310a2000a2
[    51.827] (II) AMDGPU(0): Printing probed modes for output eDP
[    51.827] (II) AMDGPU(0): Modeline "1920x1080"x60.0  152.84  1920 2000 2054 2250  1080 1086 1094 1132 -hsync -vsync (67.9 kHz eP)
[    51.827] (II) AMDGPU(0): Modeline "1680x1050"x60.0  152.84  1680 2000 2054 2250  1050 1086 1094 1132 -hsync -vsync (67.9 kHz e)
[    51.827] (II) AMDGPU(0): Modeline "1280x1024"x60.0  152.84  1280 2000 2054 2250  1024 1086 1094 1132 -hsync -vsync (67.9 kHz e)
[    51.827] (II) AMDGPU(0): Modeline "1440x900"x60.0  152.84  1440 2000 2054 2250  900 1086 1094 1132 -hsync -vsync (67.9 kHz e)
[    51.827] (II) AMDGPU(0): Modeline "1280x800"x60.0  152.84  1280 2000 2054 2250  800 1086 1094 1132 -hsync -vsync (67.9 kHz e)
[    51.827] (II) AMDGPU(0): Modeline "1280x720"x60.0  152.84  1280 2000 2054 2250  720 1086 1094 1132 -hsync -vsync (67.9 kHz e)
[    51.827] (II) AMDGPU(0): Modeline "1024x768"x60.0  152.84  1024 2000 2054 2250  768 1086 1094 1132 -hsync -vsync (67.9 kHz e)
[    51.827] (II) AMDGPU(0): Modeline "800x600"x60.0  152.84  800 2000 2054 2250  600 1086 1094 1132 -hsync -vsync (67.9 kHz e)
[    51.827] (II) AMDGPU(0): Modeline "640x480"x60.0  152.84  640 2000 2054 2250  480 1086 1094 1132 -hsync -vsync (67.9 kHz e)
[    51.827] (II) AMDGPU(0): Output HDMI-A-0 disconnected
[    51.827] (II) AMDGPU(0): Output eDP connected
[    51.827] (II) AMDGPU(0): Using exact sizes for initial modes
[    51.827] (II) AMDGPU(0): Output eDP using initial mode 1920x1080 +0+0
[    51.827] (II) AMDGPU(0): mem size init: gart size :bf7d2000 vram size: s:7e852000 visible:7e852000
[    51.827] (==) AMDGPU(0): DPI set to (96, 96)
[    51.827] (==) AMDGPU(0): Using gamma correction (1.0, 1.0, 1.0)
[    51.827] (II) Loading sub module "ramdac"
[    51.827] (II) LoadModule: "ramdac"
[    51.827] (II) Module "ramdac" already built-in
[    51.827] (II) UnloadModule: "modesetting"
[    51.827] (II) Unloading modesetting
[    51.827] Unable to retrieve master
[    51.827] (EE) 
Fatal server error:
[    51.827] (EE) AddScreen/ScreenInit failed for driver 0
[    51.827] (EE) 
[    51.827] (EE) 
Please consult the The X.Org Foundation support 
	 at [url]http://wiki.x.org[/url]
 for help. 
[    51.827] (EE) Please also check the log file at "/home/iw/.local/share/xorg/Xorg.0.log" for additional information.
[    51.827] (EE) 
[    51.851] (EE) Server terminated with error (1). Closing log file.

Last edited by iiwwnnaa (2019-11-27 11:25:55)

Offline

#2 2019-11-27 01:49:11

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,858

Re: [SOLVED] Xorg-server Fatal server error: (EE) AddScreen/ScreenInit

Please edit your post and use [ code ] tags when posting output.

https://wiki.archlinux.org/index.php/Co … s_and_code
https://bbs.archlinux.org/help.php#bbcode

Offline

#3 2019-11-27 01:53:50

loqs
Member
Registered: 2014-03-06
Posts: 9,256

Re: [SOLVED] Xorg-server Fatal server error: (EE) AddScreen/ScreenInit

[    51.445] (EE) systemd-logind: failed to take device /dev/dri/card0: Operation not permitted

https://github.com/systemd/systemd/issues/13943

Offline

#4 2019-11-27 02:29:00

iiwwnnaa
Member
Registered: 2019-11-27
Posts: 2

Re: [SOLVED] Xorg-server Fatal server error: (EE) AddScreen/ScreenInit

sudo nano /etc/mkinitcpio.conf
MODULES=(... amdgpu ...)
and reboot system
it works! I'm so happy tkx! smile

Offline

Board footer

Powered by FluxBB