You are not logged in.

#1 2019-12-14 00:07:02

Salkay
Member
Registered: 2014-05-22
Posts: 442

[BUG FILED] pyqt5-common removed from repos; uranium depends on it

It looks like pyqt5-common has been removed from the repos.

# pacman -Syu
...
looking for conflicting packages...
:: python2-pyqt5 and pyqt5-common are in conflict. Remove pyqt5-common? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pyqt5-common breaks dependency 'pyqt5-common' required by uranium
Error installing repo packages
$ pacman -Ss pyqt5-common
<no output>

However, it looks like it's still required by the most recent version of uranium

$ pacman -Si uranium
...
Depends On      : python  qt5-quickcontrols  qt5-quickcontrols2  pyqt5-common  python-pyqt5
                  python-numpy  arcus  python-shapely

Should uranium's dependencies have been updated, or am I doing something wrong?

Last edited by Salkay (2019-12-14 00:29:03)

Offline

#2 2019-12-14 00:22:23

loqs
Member
Registered: 2014-03-06
Posts: 10,601

Re: [BUG FILED] pyqt5-common removed from repos; uranium depends on it

The package depends need an update as nothing in the repositories is providing pyqt5-common but uranium 4.3.0-4 / 4.4.0-1 list it as a dependency.

Online

#3 2019-12-14 00:28:40

Salkay
Member
Registered: 2014-05-22
Posts: 442

Re: [BUG FILED] pyqt5-common removed from repos; uranium depends on it

Thanks @loqs, I've filed a bug.

Offline

#4 2019-12-14 01:37:08

openprivacy
Member
From: Pittsburgh, PA
Registered: 2014-11-12
Posts: 8

Re: [BUG FILED] pyqt5-common removed from repos; uranium depends on it

pyqt5-common is also required by multibootusb, python-pyqt5 & python2-pyqt5
Thanks for filing the bug.

Offline

#5 2019-12-14 01:47:56

loqs
Member
Registered: 2014-03-06
Posts: 10,601

Re: [BUG FILED] pyqt5-common removed from repos; uranium depends on it

openprivacy wrote:

pyqt5-common is also required by multibootusb, python-pyqt5 & python2-pyqt5

multibootusb is in AUR,  please notify the package maintainer.
python-pyqt5 5.13.2-6 and python2-pyqt5 5.13.2-6 do not depend on pyqt5-common.

Online

#6 2019-12-14 08:04:34

a821
Member
From: My Location
Registered: 2012-10-31
Posts: 165

Re: [BUG FILED] pyqt5-common removed from repos; uranium depends on it

Offline

#7 2019-12-15 22:03:18

openprivacy
Member
From: Pittsburgh, PA
Registered: 2014-11-12
Posts: 8

Re: [BUG FILED] pyqt5-common removed from repos; uranium depends on it

Edit: fixed now - removed more dependencies and solved the issue. Please ignore the following.

Thank you - still having troubles. How do I remove pyqt5-common (or at least get my system to update again)?

○ [fen@truckin] ~ 
» pacaur -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: python2-pyqt5 and pyqt5-common are in conflict. Remove pyqt5-common? [y/N] y
:: python2-pyqtwebengine and pyqtwebengine-common are in conflict. Remove pyqtwebengine-common? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pyqt5-common breaks dependency 'pyqt5-common' required by multibootusb
:: Starting AUR upgrade...
:: content is not present in AUR -- skipping
:: pyqt5-common is not present in AUR -- skipping
:: pyqtwebengine-common is not present in AUR -- skipping
:: python-sip-pyqt5 is not present in AUR -- skipping
:: scap-workbench is not present in AUR -- skipping
 there is nothing to do

○ [fen@truckin] ~ 
» pacaur -R python2-pyqt5
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python2-pyqt5 breaks dependency 'python2-pyqt5' required by calibre
:: removing python2-pyqt5 breaks dependency 'python2-pyqt5' required by python2-pyqtwebengine

○ [fen@truckin] ~ 
» pacaur -R python2-pyqtwebengine
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python2-pyqtwebengine breaks dependency 'python2-pyqtwebengine' required by calibre

○ [fen@truckin] ~ 
» pacaur -R pyqt5-common
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pyqt5-common breaks dependency 'pyqt5-common' required by multibootusb
:: removing pyqt5-common breaks dependency 'pyqt5-common' required by python-pyqt5
:: removing pyqt5-common breaks dependency 'pyqt5-common' required by python2-pyqt5

Last edited by openprivacy (2019-12-15 22:07:40)

Offline

#8 2019-12-15 22:07:57

loqs
Member
Registered: 2014-03-06
Posts: 10,601

Re: [BUG FILED] pyqt5-common removed from repos; uranium depends on it

:: removing pyqt5-common breaks dependency 'pyqt5-common' required by multibootusb

Remove the AUR package multibootusb then upgrade the system.
Then if you want to reinstall multibootusb rebuild it with its dependency on pyqt5-common removed.

Online

#9 2019-12-15 22:09:07

Salkay
Member
Registered: 2014-05-22
Posts: 442

Re: [BUG FILED] pyqt5-common removed from repos; uranium depends on it

<deleted>

Last edited by Salkay (2019-12-15 22:09:48)

Offline

Board footer

Powered by FluxBB