You are not logged in.

#1 2019-12-14 07:10:37

Kicer
Member
From: Poland
Registered: 2014-10-02
Posts: 50
Website

[SOLVED]Problems with [AUR]android-armv7a-eabi-qt5 installation

Hi

I am trying to setup android toolchain. I need android-armv7a-eabi-qt5 so I follow instructions here:
https://wiki.archlinux.org/index.php/Qt#Android

I am using yay to install these packages:
android-sdk-25.2.5 android-ndk-10e android-armv7a-eabi-qt5 jdk8-openjdk

However I get problems when one of the dependencies (android-armv7a-eabi-zlib) is being build:

==> Making package: android-armv7a-eabi-zlib 1.2.11-4 (Sat Dec 14 08:08:19 2019)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Using ar
Compiler error reporting is too harsh for ./configure (perhaps remove -Werror).
** ./configure aborting.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: android-armv7a-eabi-zlib

Last edited by Kicer (2019-12-31 09:48:17)

Offline

#2 2019-12-14 08:41:54

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,510
Website

Re: [SOLVED]Problems with [AUR]android-armv7a-eabi-qt5 installation

Moving to AUR Issues


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2019-12-14 09:17:16

Kicer
Member
From: Poland
Registered: 2014-10-02
Posts: 50
Website

Re: [SOLVED]Problems with [AUR]android-armv7a-eabi-qt5 installation

I tried to figure out how to install zlib itselft and it seems that choosing newest ndk helps:

yay -S android-armv7a-eabi-zlib
:: There are 8 providers available for android-ndk:
:: Repository AUR
    1) android-ndk 2) android-ndk-10e 3) android-ndk-11c 4) android-ndk-13b 5) android-ndk-14b 6) android-ndk-16b 7) android-ndk-r17c 8) android-ndk-r18b 

Enter a number (default=1): 
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 2]  android-ndk-r20.b-1  android-armv7a-eabi-zlib-1.2.11-4
[Aur Make: 2]  android-environment-2-2  android-pkg-config-2-1
...
==> Leaving fakeroot environment.
==> Finished making: android-armv7a-eabi-zlib 1.2.11-4 (Sat Dec 14 08:50:49 2019)
==> Cleaning up...
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) android-armv7a-eabi-zlib-1.2.11-4

Total Installed Size:  0.31 MiB

This fixes the problem and all packages installed correctly. The only thing I wonder is 'It is highly recommended to install NDK version 10e because of some known issues.' from wiki.

Offline

#4 2019-12-14 13:56:06

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,813

Re: [SOLVED]Problems with [AUR]android-armv7a-eabi-qt5 installation

If you follow the link "known Issues" on that wiki page, you'll see that ndk 10e was recommended when building with gcc 4.9 .
Maybe you can update the note ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2019-12-31 09:47:34

Kicer
Member
From: Poland
Registered: 2014-10-02
Posts: 50
Website

Re: [SOLVED]Problems with [AUR]android-armv7a-eabi-qt5 installation

done

Offline

Board footer

Powered by FluxBB