You are not logged in.

#1 2020-01-03 17:03:31

freshscaped
Member
From: West Yorkshire
Registered: 2015-08-29
Posts: 60

SOLVED running build-hook [block] reports list of missing firmware mod

Running pacman -Syu on two separate servers, from separate providers, in separate datacentres in separate countries, runs OK as far as where it gets to

 ->Running build hook: [build hook] 

where [build hook] is whichever one it is running. The output when it gets to block is as shown:

->Running build hook: [block] 
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: csiostor
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: isci
==> WARNING: Possibly missing firmware for module: advansys
==> WARNING: Possibly missing firmware for module: cxgb3
==> WARNING: Possibly missing firmware for module: cxgb4
==> WARNING: Possibly missing firmware for module: ums_eneub6250
==> WARNING: Possibly missing firmware for module: smsmdtv
  -> Running build hook: [filesystems]

Two of those, IIRC aic94xx and qla1280 have been there whether updating server, desktop or laptop, for what seems like forever. Any explanation available for the additions? Can I safely go on ignoring them? I'm not running any those I vaguely recognise and doubt any of the others are running either.

TIA,

Mike

Last edited by freshscaped (2020-01-03 17:30:07)

Offline

#2 2020-01-03 17:14:42

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,393

Re: SOLVED running build-hook [block] reports list of missing firmware mod

Is linux-firmware installed? If that isn't it you will probably want to ask whoever is providing you with these images.

Offline

#3 2020-01-03 17:17:08

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,403

Re: SOLVED running build-hook [block] reports list of missing firmware mod

Are you using those modules? If so, yeah, you're going to want to find the firmware. If not, ignore it.
Totally normal.

Offline

#4 2020-01-03 17:28:34

freshscaped
Member
From: West Yorkshire
Registered: 2015-08-29
Posts: 60

Re: SOLVED running build-hook [block] reports list of missing firmware mod

Thanks, both. As I suspected. One is a brand new installation from a few days ago but not had time to look inside until now. So no idea yet if linux-firmware is installed. If not by default, i.e. part of base package, then no. The other is a reinstallation, even fresher. I'll mark the thread as solved as there doesn't seem to be much to look at.

Offline

#5 2020-01-03 17:48:34

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,600

Re: SOLVED running build-hook [block] reports list of missing firmware mod

It's clearly stated in the Installation Guide that the linux-firmware package isn't included in the new base group and has to be specifically installed.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#6 2020-01-03 17:55:35

freshscaped
Member
From: West Yorkshire
Registered: 2015-08-29
Posts: 60

Re: SOLVED running build-hook [block] reports list of missing firmware mod

https://bbs.archlinux.org/post.php?tid=251859
Thanks Slithery. Saves me from having to search. Trying to do several things at once here. :-)

Offline

#7 2020-01-03 18:02:01

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,403

Re: SOLVED running build-hook [block] reports list of missing firmware mod

There are 2 modules that get included in the fallback initramfs and do not have firmware in the linux-firmware package, so I doubt linux-firmware is the issue here.

Offline

Board footer

Powered by FluxBB