You are not logged in.
Pages: 1
I started having a "really pissing me off" problem with NFS.
I can no longer reliably connect to my NFS server using the hostname, and I have to connect using the IP address. I read the Arch Wiki page for NFS when I set this up and was working perfectly until yesterday, and I haven't changed _anything_ in my NFS configuration.
Symptoms:
When I run
showmount -e casperit only works about 5% depending on what time of day it is. The other 95% of the time it says "clnt_create: RPC: Timed out"
rpcinfo -p casperis the same, returning "casper: RPC: Remote system error - Connection refused."
But I can still connect to my server using the local IP address.
Please help.
Offline
Your info is kinda sparse to see what's wrong, DNS is the first to think of and second the hosts file.
Are you running a DNS server on your local domain? Check it's settings!
If not what does your hosts file look like?
Then there is:
it only works about 5% depending on what time of day it is.
really this doesn't make any sense, at least to me.
Also check the status of rpcbind.service & nfs-client.target & remote-fs.target, which are probably fine...
But I can still connect to my server using the local IP address.
At least you know there's nothing wrong with your NFS servver which is a good thing;)
Offline
As qinohe indicated, please elaborate on how the hostname is supposed to be resolved, any possible dns cache (dnsmask, systemd-resolved, …)
Can you ping,nslookup,dig,drill it? (That's not meant as options. Test all techniques and report on the result)
Edit: please also alter the subject of the thread (edit your initial post) - this has nothing to do with NFS at all.
Last edited by seth (2020-01-04 20:27:17)
Offline
Pages: 1