You are not logged in.

#1 2020-01-07 03:04:41

Zhme
Member
Registered: 2017-06-11
Posts: 71

Cutter/radare2 script/makepkg -si - [makefile: 3680] error in build()

I have been having issues installing cutter for radare2.  First attempted in Kali VBox to no avail.  Afterwords, I tried to use my actual OS to install using the git clone.

Steps:
- Cloned from the main git repo.
- Attempt to build with the build.sh script
                   ->  failure with a makefile error in "Cutter.o"
- Attempt to build with makepkg -si  (should have been the first choice)
                   ->  failure with a makefile error 1: 3680 in "Cutter.o"

I will post the log when I can find it!

Generally, I am looking for the steps to debug such an error myself. What/where to look, etc.

Offline

#2 2020-01-07 11:05:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,201

Re: Cutter/radare2 script/makepkg -si - [makefile: 3680] error in build()

Usually first place to look at is aur comments.

There are atleast 2 radere2-cutter pacakges in aur, but https://aur.archlinux.org/packages/rada … er-ghidra/ is the one that appears to be maintained better.

Check the comments for it.

- Attempt to build with the build.sh script
                   ->  failure with a makefile error in "Cutter.o"
- Attempt to build with makepkg -si  (should have been the first choice)

AUR packages have PKGBUILDS for a reason, NEVER run some script directly when trying to build an aur package.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2020-02-27 01:31:13

sphraax
Member
Registered: 2020-02-26
Posts: 2

Re: Cutter/radare2 script/makepkg -si - [makefile: 3680] error in build()

Here, try this.

Do the following:

First install the dependencies
sudo pacman -S qt5-webengine jupyter icu qt5-svg qt5-base

Also the python ones (some are needed for the plugins):
python3 -m pip install angrdbg manticore PySide2 shiboken2 dbus-python

Finally run yay -G radare2-cuter

Edit the PKGBUILD file... change the _gitcommit value to the latest if you want, or use the one below, which is the latest by the time I'm posting this.

pkgname=radare2-cutter
_gitcommit=dd7e01be3a4d21d4e788ec534f6ffd125372bdb4
pkgver=1.10.1
epoch=1
pkgrel=1
pkgdesc='Qt and C++ GUI for radare2 reverse engineering framework'
url='https://github.com/radareorg/cutter'
arch=('x86_64')
license=('GPL3')
depends=('radare2' 'capstone' 'qt5-base' 'qt5-svg' 'qt5-webengine' 'icu' 'python' 'jupyter'
         'pyside2' 'python-shiboken2')
makedepends=('git' 'cmake' 'shiboken2')
source=(${pkgname}::"git+https://github.com/radareorg/cutter#commit=${_gitcommit}")
sha512sums=('SKIP')

pkgver() {
  cd ${pkgname}
  git describe --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}

prepare() {
  sed -e 's|PKGCONFIG += python3|PKGCONFIG += python3-embed|' -i $pkgname/src/Cutter.pro # Fix linking to python 3.8
}

build() {
  mkdir -p ${pkgname}/build
  cd ${pkgname}/build
  qmake ../src/Cutter.pro \
    CUTTER_ENABLE_PYTHON=true \
    CUTTER_ENABLE_PYTHON_BINDINGS=true \
    CUTTER_USE_BUNDLED_RADARE2=false
  make
}

package() {
  cd ${pkgname}
  install -Dm 755 build/Cutter -t "${pkgdir}/usr/bin"
  install -Dm 644 src/org.radare.Cutter.desktop -t "${pkgdir}/usr/share/applications"
  install -Dm 644 src/img/cutter.svg -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
  install -d "${pkgdir}/usr/share/doc/${pkgname}"
  cp -a docs/* "${pkgdir}/usr/share/doc/${pkgname}"
}

# vim: ts=2 sw=2 et:

Then create package with: makepkg -i

Good luck smile

Offline

Board footer

Powered by FluxBB