You are not logged in.

#1 2020-01-07 11:53:58

milk
Member
Registered: 2013-02-06
Posts: 37

change to linux-lts to increase realiability?

Hey there,
on my machine at work, I am running arch linux and have not had any major problems for the last few years. However, in the last few weeks there were multiple problems that caused me headaches: the i915-issue resulting in random freezing every now and then (probably the issue described in [1] - it is not as frequent anymore but I can't tell if it is solved) and now a weird ethernet connection issue (maybe the one described in [2]?). I have tried downgrading the kernel, but the ethernet connection is only up as long as I do not decrypt my hard-drive and even then this resulted in a system which is quite unresponsive, e.g., scrolling through a website is super slow, etc. This is quite annoying if you actually need to get real work done..

After downgrading I currently have

$ uname -r
5.3.8-arch1-1

The only thing I see to bring back some measure of reliability is changing to the linux-lts kernel - if you have any other idea, please let me know.

Now, it has been a few years since I set this (single boot) machine up and I do not remember exactly what installation instruction I have followed, I may have lost some details about this machine. In particular I have installed the linux-lts package, and would like to add this option to my boot manager. But since there is no boot manager screen showing up when starting the machine I have no idea what boot manager I am really using.

Here is some output that could help

$ efibootmgr
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0005,0009,0006,0008,0000,0003
Boot0000* Diagnostic Program
Boot0002* Arch Linux fallback efistub
Boot0003* Windows Boot Manager
Boot0005* SAMSUNG MZNTY256HDHP-0000
Boot0006* HL-DT-ST DVDRAM GHCON
Boot0008* IBA CL Slot 00FE v0104
Boot0009* ST1000DX002-2DV162
$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 238.5G  0 disk 
├─sda1   8:1    0   512M  0 part /boot 
└─sda2   8:2    0   238G  0 part /
sdb      8:16   0 931.5G  0 disk
├─sdb1   8:17   0 691.2G  0 part /mnt/attic
└─sdb2   8:18   0 240.3G  0 part /mnt/backup
sr0      11:0   1  1024M  0 rom
$ tree /boot
/boot
├── initramfs-linux-fallback.img
├── initramfs-linux-lts-fallback.img
├── initramfs-linux-lts.img
├── initramfs-linux.img
├── intel-ucode.img
├── vmlinuz-linux
└── vmlinuz-linux-lts

0 directories, 7 files

The "fallback" name in efibootmgr suggests there is something wrong, also the Windows Boot Manager option makes me wonder if I have planned to keep something for possible needs one might bump into later.. Anyway, even if I set the efibootmgr timeout to a higher value there is no boot menu showing.
Thus, my questions are:

1) Is linux-lts going to save me from issues as mentioned above, or is there some more obvious solution?
2) If so, how do I figure out what bootloader I am using + show the boot menu?
3) How do I add linux-lts to the boot menu.

Sorry if anything is unclear (I have tried a lot of googleing), I will add infos if necessary.

Thank you in advance.

[1] https://bbs.archlinux.org/viewtopic.php?id=250765
[2] https://bbs.archlinux.org/viewtopic.php?id=249406&p=3
---

EDIT: From

$ sudo blkid
/dev/sda1: LABEL_FATBOOT="EFIBOOT" LABEL="EFIBOOT" UUID="F928-1EDE" TYPE="vfat" PARTLABEL="EFI System" PARTUUID="fab4d72f-d2ae-4c01-9675-eedb587357b7"
...

it looks like my bootloader is EFISTUB, probably installed as described under Using UEFI directly in [3], right? But how come there is no boot menu showing?

[3] https://wiki.archlinux.org/index.php/EFISTUB

EDIT 2: I just figured if I restart and press F12 the menu is showing, which confirms my assumptions. Now, I have added an entry via efibootmgr pointing to the linux-lts kernel, but this seems to get lost, i.e., this entry is not shown in the menu when booting....Any ideas?

Last edited by milk (2020-01-07 12:33:15)

Offline

#2 2020-01-07 12:45:15

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,395

Re: change to linux-lts to increase realiability?

Some UEFIs only allow adding new entries within their own firmware, check there.

Offline

#3 2020-01-07 12:46:30

milk
Member
Registered: 2013-02-06
Posts: 37

Re: change to linux-lts to increase realiability?

Okay, could you elaborate on that, please? Do you mean the UEFI shell?

Last edited by milk (2020-01-07 12:48:11)

Offline

#4 2020-01-07 12:57:42

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,395

Re: change to linux-lts to increase realiability?

No, the menu you get into when pressing delete or F10 or what have you.

Offline

#5 2020-01-07 13:07:37

milk
Member
Registered: 2013-02-06
Posts: 37

Re: change to linux-lts to increase realiability?

Mh the menu when pressing F12 shows the options

Arch Linux fallback efistub (P0: SAMSUNG MZNTY256HDHP-00000)
P0: SAMSUNG MZNTY256HDHP-00000
P3: ST1000DX002-2DV162
P1: HL-DT-ST DVDRAM GHCON
IBA CL Slot 00FE v0104
Diagnostic Program
Enter Setup

Anything above Diagnostic setup does not make sense, and I haven't found anything in the setup itself.
Hm...anymore ideas?

Offline

#6 2020-01-07 13:15:32

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,395

Re: change to linux-lts to increase realiability?

Post exact command you tried to use to create an additional entry and efibootmgr -v  also motherboard/PC vendor/other identifying model information.

Offline

#7 2020-01-07 13:28:09

milk
Member
Registered: 2013-02-06
Posts: 37

Re: change to linux-lts to increase realiability?

Okay, here we go:

# efibootmgr --disk /dev/sda --part 2 --create --label "Arch linux LTS" --loader /vmlinuz-linux-lts --unicode 'root=PARTUUID=e88e5273-bc34-48a7-a394-1114c6772003 rw initrd=\initramfs-linux-lts.img'
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0005,0009,0006,0008,0000,0003,0001
Boot0000* Diagnostic Program
Boot0001* Arch linux LTS
Boot0002* Arch Linux fallback efistub
Boot0003* Windows Boot Manager
Boot0005* SAMSUNG MZNTY256HDHP-0000
Boot0006* HL-DT-ST DVDRAM GHCON
Boot0008* IBA CL Slot 00FE v0104
Boot0009* ST1000DX002-2DV162

(changing the bootorder did not make the entry appear in the menu/boot the lts kernel)

PC Vendor: FUJITSU
Motherboard: FUJITSU D3402-A1
Processor: Intel Core i5-6500 CPU @ 3.20 GHz (1 physical processor, 4 cores, 4 threads)

What else do you need?

Last edited by milk (2020-01-07 13:29:16)

Offline

#8 2020-01-07 16:32:03

milk
Member
Registered: 2013-02-06
Posts: 37

Re: change to linux-lts to increase realiability?

Anything?

Offline

#9 2020-01-07 16:45:03

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,097
Website

Re: change to linux-lts to increase realiability?

Did you check the firmware options to see if you could use them to add an entry, as V1del suggested?

If you can't make new entries "stick" then you'll have to switch to systemd-boot instead and try to delete the old entries (either from Arch or using the firmware menus). The systemd-boot EFI loader will be copied to the fallback location and that should boot without entries.

As a last resort you could set Windows as the default boot option (which should happen if you don't have any NVRAM entries or $ESP/EFI/Boot/bootx64.efi) and force that to chainload systemd-boot (or GRUB): https://wiki.archlinux.org/index.php/UE … boot_order

Offline

#10 2020-01-07 16:50:47

milk
Member
Registered: 2013-02-06
Posts: 37

Re: change to linux-lts to increase realiability?

Well, I have tried, but where do I find these firmware options? In the boot menu are just the above options, and if I enter setup I could not find anything relevant...

Just in case you have missed it: It is a single boot machine with just arch (the windows boot entry seems to be some relict that is not working/needed)...

Last edited by milk (2020-01-07 19:32:45)

Offline

#11 2020-01-07 16:56:11

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,395

Re: change to linux-lts to increase realiability?

Can you post the

efibootmgr -v

?

Offline

#12 2020-01-07 16:57:38

milk
Member
Registered: 2013-02-06
Posts: 37

Re: change to linux-lts to increase realiability?

$ efibootmgr -v
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0005,0009,0006,0008,0000,0001,0003
Boot0000* Diagnostic Program   
FvVol(5c60f367-a505-419a-859e-2a4ff6ca6fe5)/FvFile(085e8cc2-8ec9-4666-bd2a-49d481e95fa7)
Boot0001* Arch linux LTS       
VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)r.o.o.t.=.P.A.R.T.U.U.I.D.=.e.8.8.e.5.2.7.3.-.b.c.3.4.-.4.8.a.7.-.a.3.9.4.-.1.1.1.4.c.6.7.7.2.0.0.3.
.r.w. .i.n.i.t.r.d.=.\.i.n.i.t.r.a.m.f.s.-.l.i.n.u.x.-.l.t.s...i.m.g.
Boot0002* Arch Linux fallback efistub  
HD(1,GPT,fab4d72f-d2ae-4c01-9675-eedb587357b7,0x800,0x100000)/File(vmlinuz-linux)i.n.i.t.r.d.=./.i.n.i.t.r.a.m.f.s.-.l.i.n.u.x.-.f.a.l.l.b.a.c.k...i.m.g.
.r.o.o.t.=./.d.e.v./.s.d.a.2. .r.w.
Boot0003* Windows Boot Manager 
VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0005* SAMSUNG MZNTY256HDHP-00000    BBS(HD,,0x0)..BO
Boot0006* HL-DT-ST DVDRAM GHC0N BBS(CDROM,,0x0)..BO
Boot0008* IBA CL Slot 00FE v0104        BBS(Network,,0x0)..BO
Boot0009* ST1000DX002-2DV162    BBS(HD,,0x0)..BO

Offline

Board footer

Powered by FluxBB